You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2014-01-30 11:08:57

kenvi348
Member
Registered: 2009-11-17
Posts: 34

Impossible d'installer le plugin

Bonjour,

J'ai effectué ce jour une migration de mon installation glpi de 0.83.7 vers 0.84.4.
J'ai ensuite décompressé l'archive du plugin ocsinventoryng dans le dossier plugin mais une fois que je me rend dans configuration>plugin le lien vert "installer" n'est pas cliquable, je ne peux pas l'installer donc...
Il y a aussi mes anciens plugins répertoriés sur cette page (donc l'ancien mode ocs) avec le lien vert "désinstaller" qui n'est lui non plus pas cliquable, en gros je peux rien faire hmm
Voici une capture d'écran :
1fc8.png

On voit bien que les mots "installer" et "désinstaller" sont de couleur verte ce qui veut dire que ce sont des liens, mais au final ya un bug qui fait que ce ne sont pas des liens mais du simple texte non cliquable...

Merci pour votre aide !

Offline

#2 2014-01-31 10:53:08

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 15,185

Re: Impossible d'installer le plugin

Les 2 premiers plugins ne sont pas en version comptabile GLPI 0.84.
Concernant le plugin OCSNG, je n'ai pas de problème.
Avez-vous des erreurs dans les logs ? en mode debug ?


CentOS 6.5 - CentOS 7.x
PHP 5.6 - PHP 7.x - MySQL 5.6  - MariaDB 10.2 + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#3 2014-01-31 12:32:06

kenvi348
Member
Registered: 2009-11-17
Posts: 34

Re: Impossible d'installer le plugin

Du coup faut-il que je désactive les plugins avant de migrer?
pour le moment je suis retourné sur mon ancienne version qui fonctionne car c'est en prod.
pas d'erreurs dans les logs, le seul problème que j'ai c'est les mots "installer" et "désinstaller" qui ne sont pas des liens mais juste du texte non cliquable.
J'ai essayé avec 0.84.3 et 0.84.0 c'est pareil.
Du coup retour à 0.83.7

Offline

#4 2014-01-31 14:07:17

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 15,185

Re: Impossible d'installer le plugin

Normalement, une version de GLPI s'installe avec le dossier plugins vide.
Vous y décompressé vos plugins au fur et à mesure que vous récupéez les nouvelles versions.
Je précise que vider le répertoire Plugins de GLPI ne vide pas les bases correspondantes.


CentOS 6.5 - CentOS 7.x
PHP 5.6 - PHP 7.x - MySQL 5.6  - MariaDB 10.2 + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#5 2014-01-31 15:09:09

kenvi348
Member
Registered: 2009-11-17
Posts: 34

Re: Impossible d'installer le plugin

D'accord je vais faire le test de vider donc le dossier plugin avant de migrer mon GLPI.
Dois-je d'abord cliquer sur les liens "désinstaller" dans GLPI lui même avant?
(j'aimerais tout de même qu'il garde ma config ocs)

Offline

#6 2014-02-04 14:21:03

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 15,185

Re: Impossible d'installer le plugin

Non, si vous désinstallez le plugin, cela supprimera les données en base. Glpi vous proposera de mettre à jour votre plugin.


CentOS 6.5 - CentOS 7.x
PHP 5.6 - PHP 7.x - MySQL 5.6  - MariaDB 10.2 + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#7 2014-04-11 11:19:41

sbocquet
Member
Registered: 2014-04-11
Posts: 5

Re: Impossible d'installer le plugin

Hi,

Désolé de remonter le sujet, mais j'ai exactement le même soucis sur une installation fraîche de GLPI (v0.84.x) sur une machine en OS Debian Testing (Installation depuis les packages Debian).

http://postimg.org/image/4emthludb/

Les liens Installer/Désinstaller ne sont pas cliquable et je ne peux donc pas installer ces deux plugins (ou n'importe lequel d'ailleurs dont OCS NG).

Last edited by sbocquet (2014-04-11 11:22:09)

Offline

#8 2014-04-11 12:50:30

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 15,185

Re: Impossible d'installer le plugin

VBous avez des messages dans les logs de GLPI ? en mode Debug ?


CentOS 6.5 - CentOS 7.x
PHP 5.6 - PHP 7.x - MySQL 5.6  - MariaDB 10.2 + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#9 2014-04-11 13:59:34

sbocquet
Member
Registered: 2014-04-11
Posts: 5

Re: Impossible d'installer le plugin

Bonjour,

Je ne trouve pas les log de GLPI sur mon installation Debian, ni dans GLPI (/usr/share/glpi), ni dans /var/log...

Y-a t'il un endroit dans l'application où configurer le niveau de log ?

Merci

Offline

#10 2014-04-11 15:05:24

sbocquet
Member
Registered: 2014-04-11
Posts: 5

Re: Impossible d'installer le plugin

Ok, j'ai trouvé les log... les seuls messages que j'ai dedans sont :

Warning(2): include(): Failed opening '/usr/share/glpi/lib/phpcas/CAS.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear')
Backtrace :
/usr/share/glpi/inc/config.class.php:1302               Toolbox::userErrorHandlerNormal()
/usr/share/glpi/inc/config.class.php:1302               Config::showLibrariesInformation()
/usr/share/glpi/inc/config.class.php:1270               Config::showLibrariesInformation()
/usr/share/glpi/inc/config.class.php:1498               Config->showSystemInformations()
/usr/share/glpi/inc/commonglpi.class.php:284            Config::displayTabContentForItem()
/usr/share/glpi/ajax/common.tabs.php:71         CommonGLPI::displayStandardTab()

Le répertoire/ficher phpcas/CAS.php n'existe pas sur mon disque, mais pas sur que les deux problèmes soient liés...

Offline

#11 2014-04-11 15:31:41

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 15,185

Re: Impossible d'installer le plugin

Le dossier /lib/phpcas est fourni dans le tar.gz de GLPI.
Votre paquet debian ne pas pas être complet


CentOS 6.5 - CentOS 7.x
PHP 5.6 - PHP 7.x - MySQL 5.6  - MariaDB 10.2 + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#12 2014-04-11 15:52:49

sbocquet
Member
Registered: 2014-04-11
Posts: 5

Re: Impossible d'installer le plugin

J'ai rajouté 2 répertoires manquant, à savoir phpcas et phpmailer.

Cela a réglé le problème décrit dans la log, mais toujours le même problème pour installer les plugins. sad

Je n'ai pas non plus d'erreur même en mode débug... !

Last edited by sbocquet (2014-04-11 15:53:59)

Offline

#13 2014-04-11 16:00:41

sbocquet
Member
Registered: 2014-04-11
Posts: 5

Re: Impossible d'installer le plugin

Ok... j'ai trouvé le problème

J'utilise IE11 et apparemment le HTML de la page ne doit pas être 'compatible'.
En utilisant Chrome ou Firefox, les boutons apparaissent et on peut installer et activer les plugins.

probablement qu'il faut passer IE en mode compatibilité IE10 ou autre...

Offline

#14 2014-06-13 11:18:10

ajdw
Member
Registered: 2009-08-27
Posts: 18

Re: Impossible d'installer le plugin

Bonjour,

J'ai eu le même souci ce matin mais sous Firefox. J'ai trouvé la solution, il suffit de vider le cache.

Bonne journée.


Ubuntu 14.04 et GLPI 9.1RC2

Offline

Board footer

Powered by FluxBB