You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2006-06-30 09:03:07

Etienne
Guest
From: Nancy
Registered: 2006-06-29
Posts: 19

Problème de mise à jour 0.65 -> 0.68

Bonjour,

Lors d'une mise à jour de GLPI de depuis la version 0.65 vers la toute nouvelle 0.68 en suivant les instruction du LISEZMOI.TXT, j'obtient le message suivant :
0.68 glpi_dropdown_tracking_category to dropdown treeErreur durant la mise à jour de la base de donnéesChamp 'comments' inconnu dans glpi_dropdown_tracking_category
au moment de la mise à jour de la base

Mon serveur est une debian sarge ( avec un MySQL 5.0.22 backporté -si j'ose dire  smile - )

Excusez moi si je ne poste pas au bon endroit...vu que c'est un problème lors de la mise à jour, il y avait plusieurs possibilités !


Etienne
Responsable informatique
Ecole de santé publique


Etienne Rozé
Responsable informatique
Ecole de santé publique - Université Henri Poincaré

Offline

#2 2006-06-30 11:21:20

MoYo
GLPI - Lead
From: Poitiers
Registered: 2004-09-13
Posts: 14,513
Website

Re: Problème de mise à jour 0.65 -> 0.68

c'est qu'il y a eut un soucis dans la mise à jour 0.6-> 0.65.
Ce champ comments a été ajouté dans cette mise à jour.
Dans toutes les tables glpi_dropdown_* et glpi_type_* il doit y avoir un champ comments.


MoYo - Julien Dombre - Association INDEPNET
Contribute to GLPI :    Support     Contribute     References     Freshmeat

Offline

#3 2006-06-30 11:44:34

Etienne
Guest
From: Nancy
Registered: 2006-06-29
Posts: 19

Re: Problème de mise à jour 0.65 -> 0.68

Bonjour,

Merci de votre réponse.
Quelle est la meilleure façon de m'en tirer ?
- Ajouter les champs "comments" à la main ? ( quel type de champ ?)
- Installer une nouvelle version et injecter une sauvegarde ?
- autre ?


Etienne Rozé
Responsable informatique
Ecole de santé publique - Université Henri Poincaré

Offline

#4 2006-06-30 11:53:38

MoYo
GLPI - Lead
From: Poitiers
Registered: 2004-09-13
Posts: 14,513
Website

Re: Problème de mise à jour 0.65 -> 0.68

- oui c'est une solution : $query="ALTER TABLE `glpi_dropdown_tracking_catégory` ADD `comments` TEXT NULL ";
- non ca ne changera rien car il va recharger la structure de la DB


MoYo - Julien Dombre - Association INDEPNET
Contribute to GLPI :    Support     Contribute     References     Freshmeat

Offline

#5 2006-06-30 12:22:01

Cedinvs
Guest
From: Saint Maurice
Registered: 2006-04-20
Posts: 21

Re: Problème de mise à jour 0.65 -> 0.68

Bonjour,

Sur ma config de test, j'ai fait la mise à jour en 0.68 mais j'ai le message suivant qui apparait :

Warning: include_once(C:/OCS Inventory NG/xampp/htdocs/ocsreports/glpi/config/config.php) [function.include-once]: failed to open stream: No such file or directory in C:\OCS Inventory NG\xampp\htdocs\ocsreports\glpi\inc\includes.php on line 53

Warning: include_once() [function.include]: Failed opening 'C:/OCS Inventory NG/xampp/htdocs/ocsreports/glpi/config/config.php' for inclusion (include_path='.;C:\OCS Inventory NG\xampp\php\pear\') in C:\OCS Inventory NG\xampp\htdocs\ocsreports\glpi\inc\includes.php on line 53

Warning: include(C:/OCS Inventory NG/xampp/htdocs/ocsreports/glpi/locales/) [function.include]: failed to open stream: Permission denied in C:\OCS Inventory NG\xampp\htdocs\ocsreports\glpi\inc\auth.function.php on line 316

Warning: include() [function.include]: Failed opening 'C:/OCS Inventory NG/xampp/htdocs/ocsreports/glpi/locales/' for inclusion (include_path='.;C:\OCS Inventory NG\xampp\php\pear\') in C:\OCS Inventory NG\xampp\htdocs\ocsreports\glpi\inc\auth.function.php on line 316

Fatal error: Class 'DB' not found in C:\OCS Inventory NG\xampp\htdocs\ocsreports\glpi\inc\includes.php on line 86

J'ai bien entendu vérifier les droits d'accès aux répertoires (rien de modifier).
La machine vient d'etre reformater et j'ai réinstallé le système à l'identique pour écarter un souci système ... sans résultats.
Quelqu'un aurait il une solution ???


Config Prod : Debian 5.0.6 + OCS 1.0 RC 3-1 + GLPI 0.72.3
PHP  5.1.1 - MySql 5.0.18 - Apache 2.2.9
Config Test : Debian 5.0.6 + OCS 1.0 RC 3-1 + GLPI 0.78RC3
PHP  5.1.1 - MySql 5.0.18 - Apache 2.2.9

Offline

#6 2006-06-30 12:38:38

JMD
GLPI - Lead
Registered: 2004-09-13
Posts: 9,180
Website

Re: Problème de mise à jour 0.65 -> 0.68

Vous avez bien lu le fichier lisez-moi pour faire la mise à jour ?


JMD / Jean-Mathieu Doléans - Glpi-project.org - Association Indepnet
Apportez votre pierre au  projet GLPI   : Soutenir     Contribuer

Offline

#7 2006-06-30 13:49:58

Cedinvs
Guest
From: Saint Maurice
Registered: 2006-04-20
Posts: 21

Re: Problème de mise à jour 0.65 -> 0.68

JMD wrote:

Vous avez bien lu le fichier lisez-moi pour faire la mise à jour ?

Ben vi ... aurais je mal compris ou omis quelque chose ??? hmm


Config Prod : Debian 5.0.6 + OCS 1.0 RC 3-1 + GLPI 0.72.3
PHP  5.1.1 - MySql 5.0.18 - Apache 2.2.9
Config Test : Debian 5.0.6 + OCS 1.0 RC 3-1 + GLPI 0.78RC3
PHP  5.1.1 - MySql 5.0.18 - Apache 2.2.9

Offline

#8 2006-06-30 14:15:28

JMD
GLPI - Lead
Registered: 2004-09-13
Posts: 9,180
Website

Re: Problème de mise à jour 0.65 -> 0.68

J'"en sais rien wink

J'ai bien entendu vérifier les droits d'accès aux répertoires (rien de modifier).

Les repertoires ont changé, il y  a donc des droits d'accés différents.

Ensuite, une possibilité c'est qu'il vous manque des fichiers. A vérifier avec votre décompacteur..... cf forum qui traite de ce pb.


JMD / Jean-Mathieu Doléans - Glpi-project.org - Association Indepnet
Apportez votre pierre au  projet GLPI   : Soutenir     Contribuer

Offline

#9 2006-06-30 14:49:35

Cedinvs
Guest
From: Saint Maurice
Registered: 2006-04-20
Posts: 21

Re: Problème de mise à jour 0.65 -> 0.68

JMD wrote:

J'"en sais rien wink

J'ai bien entendu vérifier les droits d'accès aux répertoires (rien de modifier).

Les repertoires ont changé, il y  a donc des droits d'accés différents.

Ensuite, une possibilité c'est qu'il vous manque des fichiers. A vérifier avec votre décompacteur..... cf forum qui traite de ce pb.

Il est bien mon dépacteur tongue ... j'ai pourtant mis du controle total sur ces 2 répertoires.
Par ailleurs, elle fonctionne bien en "directe" sans mise à jour . Snif .


Config Prod : Debian 5.0.6 + OCS 1.0 RC 3-1 + GLPI 0.72.3
PHP  5.1.1 - MySql 5.0.18 - Apache 2.2.9
Config Test : Debian 5.0.6 + OCS 1.0 RC 3-1 + GLPI 0.78RC3
PHP  5.1.1 - MySql 5.0.18 - Apache 2.2.9

Offline

#10 2006-07-03 10:12:52

Etienne
Guest
From: Nancy
Registered: 2006-06-29
Posts: 19

Re: Problème de mise à jour 0.65 -> 0.68

MoYo wrote:

- oui c'est une solution : $query="ALTER TABLE `glpi_dropdown_tracking_catégory` ADD `comments` TEXT NULL ";

Ok. Ce changement fait et tout a roulé comme sur des roulettes ! J'ai cru un moment que j'aurais plusieurs tables à modifier mais le problème n'existait que sur glpi_dropdown_tracking_catégory.

Tout ceci est parfait ..


Etienne Rozé
Responsable informatique
Ecole de santé publique - Université Henri Poincaré

Offline

Board footer

Powered by FluxBB