You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2017-07-31 09:02:00

n.clavel
Guest
Registered: 2015-01-08
Posts: 256

Problème action automatique CLI

Bonjour,

J'ai mis certaines actions automatiques en CLI et j'ai créé des tâches planifiées correspondantes sur un serveur Windows Server 2008.
Je rencontre un problème avec l'action "queuemail". Les mails ne sont pas envoyés car il semblerait que l'action se bloque dans GLPI (Statut: en cours d'éxécution).
J'ai l'impression que l'action automatique est toujours en mode GLPi même si la configuration en CLI est OK.

Des avis ?

Merci


Versions GLPI utilisées:
PROD: 9.1.3
TEST: 9.1.6

Offline

#2 2017-08-02 16:59:27

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 13,580

Re: Problème action automatique CLI

La file d'attente se vide suivant les paramètres de la configuration de votre entité


CentOS 6.5 - PHP 5.6 - PHP 7 - MySQL 5.6  + APC + memcached
GLPI 0.90.5 SVN - GLPI 9.1.3 SVN
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#3 2017-08-03 12:23:35

n.clavel
Guest
Registered: 2015-01-08
Posts: 256

Re: Problème action automatique CLI

Ce matin, la file d'attente contient 65 mails non envoyés depuis hier.
L'action automatique queuedmail est "En cours d’exécution" avec une dernière exécution aujourd’hui à 00:00.

La tâche planifiée sous Windows a bien été éxécuté entre temps


Versions GLPI utilisées:
PROD: 9.1.3
TEST: 9.1.6

Offline

#4 2017-08-03 17:45:12

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 13,580

Re: Problème action automatique CLI

Et le paramétrage dans la configuration de votre entité ?
Arrêtez vous les tâches automatiques lors des sauvegardes ?


CentOS 6.5 - PHP 5.6 - PHP 7 - MySQL 5.6  + APC + memcached
GLPI 0.90.5 SVN - GLPI 9.1.3 SVN
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#5 2017-08-04 09:02:13

n.clavel
Guest
Registered: 2015-01-08
Posts: 256

Re: Problème action automatique CLI

Dans les options de notification de l'entité, le délai pour envoyer des notifications par courriel est à 1 minutes.
Non je n'arrête pas les actions (Surtout si l'arrêt doit se faire manuellement). La sauvegarde de la base de données est faite par un script lancé via une tâche planifiée.

Par contre, une tâche planifiée de redémarrage du serveur qui a peut être bloqué cette action.

Les actions peuvent t elles être arrêtées via un script?


Versions GLPI utilisées:
PROD: 9.1.3
TEST: 9.1.6

Offline

#6 2017-08-04 12:44:20

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 13,580

Re: Problème action automatique CLI

Il suffit de ne pas les activer pendant le redémarrage du serveur (modifier la plage horaire d'exécution de l'action automatique).
Mais ou une relance de serveur pendant l'exécution d'une tâche va bloquer celle-ci. Il faut alors cliquer sur la X à côte de "en cours d'exécution" pour la réinitialiser


CentOS 6.5 - PHP 5.6 - PHP 7 - MySQL 5.6  + APC + memcached
GLPI 0.90.5 SVN - GLPI 9.1.3 SVN
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#7 2017-08-04 16:28:28

n.clavel
Guest
Registered: 2015-01-08
Posts: 256

Re: Problème action automatique CLI

J'ai modifié les plages d’exécution.
A voir si problème se reproduit


Versions GLPI utilisées:
PROD: 9.1.3
TEST: 9.1.6

Offline

Board footer

Powered by FluxBB