1

Topic: Installing the "apcu-bc" extension may improve GLPI performance

Bonjour

J'ai ce message dans GLPI

Une procédure pour mettre en place cette extension sur w2012r2

Yannick

Prod : GLPI 9.2 - Windows 2012 R2 - IIS 8.5 - Mariadb 10.1 - PHP 7.12 - Fusion 2.3.19
Certifié ITIL V3, PMP

2

Re: Installing the "apcu-bc" extension may improve GLPI performance

j'ai aussi ce message mais en français et il s'affiche uniquement dans Configuration -> Générale -> Performance

J'ai aussi celui-là :

Installer et activer l'extension Zend OPcache peux améliorer les performances de GLPI

Entre parenthèses il y a une faute à "peux"

GLPI sous Windows : 9.1.1, Fusioninventory 9.1+1.0
Apache/2.4.7 (Win32) mod_authnz_sspi/0.1.0 PHP/5.4.22, MySQL : 5.5.34
300 machines Windows avec l'agent Fusioninventory 2.3.18
Autres plugins : Arrêté du parc 2.3.0, Badges    2.2.0, Bases de données    1.9.0,  Comptes 2.2.0, Gestion de baies    1.7.0, Escalades 2.1.0, Gestion des SIM 1.4.2, Imports fabricants    1.9.0

3

Re: Installing the "apcu-bc" extension may improve GLPI performance

zend opcache il faut l'installer et l'âctiver

Yannick

Prod : GLPI 9.2 - Windows 2012 R2 - IIS 8.5 - Mariadb 10.1 - PHP 7.12 - Fusion 2.3.19
Certifié ITIL V3, PMP

4

Re: Installing the "apcu-bc" extension may improve GLPI performance

Faute corrigée.

Dév. Fedora 25 - PHP 5.4/5.5/5.6/7.0/7.1 - MariaDB 10.1 - GLPI master
Certifié ITILv3 - RPM pour Fedora, RHEL et CentOS sur https://blog.remirepo.net/

5

Re: Installing the "apcu-bc" extension may improve GLPI performance

Uniyannick wrote:

zend opcache il faut l'installer et l'âctiver

Pas obligé

remi wrote:

Faute corrigée.

Merci remi

GLPI sous Windows : 9.1.1, Fusioninventory 9.1+1.0
Apache/2.4.7 (Win32) mod_authnz_sspi/0.1.0 PHP/5.4.22, MySQL : 5.5.34
300 machines Windows avec l'agent Fusioninventory 2.3.18
Autres plugins : Arrêté du parc 2.3.0, Badges    2.2.0, Bases de données    1.9.0,  Comptes 2.2.0, Gestion de baies    1.7.0, Escalades 2.1.0, Gestion des SIM 1.4.2, Imports fabricants    1.9.0

6

Re: Installing the "apcu-bc" extension may improve GLPI performance

Bonjour,

Je viens de passer en version 9.1.2 et découvre ce menu "Performance" qui est bien pratique et m'a permis de grandement améliorer le temps de chargement des pages (Il ne me reste plus qu'à trouver comment améliorer le chargement des dropdown lists...).

Pour répondre à Yannick, l'activation de opcache et apcu sur Windows est très facile et je recommande vivement d'au moins le tester.

Pour opcache:
Il suffit juste d'ajouter la ligne suivante dans php.ini (à la fin des autres extensions par exemple):

zend_extension=php_opcache.dll

Pour apcu:
C'est juste un peu plus long puisqu'il faut aller télécharger la bonne .dll correspondant à sa version de PHP, puis la placer dans le répertoire d'extension de php, et enfin ajouter quelques lignes de conf dans php.ini
L'explication en détail se trouve sur stackoverflow.

Prod: Windows 2008 R2 - Apache 2.4.20 (Win64) - OpenSSL 1.0.2h - PHP 5.5.15 - MySQL 5.5.39 - GLPI 9.1.2 (600+ users authenticated with AD in 20+ entities)

7 (edited by Wawa69 2017-04-13 16:32:31)

Re: Installing the "apcu-bc" extension may improve GLPI performance

Bonjour MarcW
merci beaucoup pour ton aide.

pour ma part j'ai la version php 5.6.24 , je dois prendre quelle versions apcu ? http://windows.php.net/downloads/pecl/releases/apcu/

merci d'avance

8

Re: Installing the "apcu-bc" extension may improve GLPI performance

Wawa69 wrote:

pour ma part j'ai la version php 5.6.24 , je dois prendre quelle versions apcu ?

Les versions 5.1.x de apcu sont pour PHP 7, donc tu dois prendre la dernière version de 4.0.x (soit la version 4.0.11 à la date de ce post). En supposant que tu sois sur une version Windows 64 bits, tu dois télécharger php_apcu-4.0.11-5.6-ts-vc11-x64.zip

Prod: Windows 2008 R2 - Apache 2.4.20 (Win64) - OpenSSL 1.0.2h - PHP 5.5.15 - MySQL 5.5.39 - GLPI 9.1.2 (600+ users authenticated with AD in 20+ entities)