1

Topic: Can't save mailservers with novalidate-cert in 0.84.3 and 0.90.1

Hi,

I'm running two different versions of GLPI, just for testing purposes, and I'm having a hard time trying to connect to my local mail server, both in receivers and auth > mail servers. I always get the same message in my php-errors.log:

*** PHP Notice(8): Unknown: Certificate failure for 192.168.1.17: self signed certificate: /C=--/ST=SomeState/L=SomeCity/O=SomeOrganization/OU=SomeOrganizat[email protected]caldomain (errflg=2)
  Backtrace :
  :                                                 
2016-03-31 15:34:06 [[email protected]]
  *** PHP Warning(2): imap_open(): Couldn't open stream {192.168.1.17:143/imap}INBOX
  Backtrace :
  :                                                 
  inc/auth.class.php:196                             imap_open()
  inc/authmail.class.php:263                         Auth->connection_imap()
  front/authmail.form.php:69                         AuthMail::testAuth()
2016-03-31 15:34:06 [[email protected]]
  *** PHP Notice(8): Unknown: Certificate failure for 192.168.1.17: self signed certificate: /C=--/ST=SomeState/L=SomeCity/O=SomeOrganization/OU=SomeOrganizat[email protected]caldomain (errflg=2)
  Backtrace :
  :

Ok, looks like a simple message, setting the option "novalidate-cert" should do the job, right? But I'm currently unable to turn this setting on. I tried in both GLPI versions to set it and test the connection, then tried to set it, save the connection and test it, also tried to create a new connection from scratch, and it's like the setting can't be turned on. I save the change, the page reloads, the dropdown with this option comes back empty and it doesn't show up in my connection string.

The settings I'm using right now:
name: whatever
active: yes
Domain name: mydomain.com.br
Server: 192.168.1.17
Options: IMAP and everything else empty (except for no-validate-cert)
Inbox directory: INBOX
Port: 143

Am I doing something wrong? How can I "force" GLPI to try connecting without checking the certificate?

Thanks in advance, sorry for my broken english. big_smile

2

Re: Can't save mailservers with novalidate-cert in 0.84.3 and 0.90.1

name must be the name of the mail box (ex.: [email protected])
server: imap.mydomain.com
You don't have domain name in the collector configuration

CentOS 6.5 - PHP 5.6 - PHP 7 - MySQL 5.6  + APC + memcached
GLPI 0.90.5 SVN - GLPI 9.1.3 SVN
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

3

Re: Can't save mailservers with novalidate-cert in 0.84.3 and 0.90.1

Hello

I have the same problem, the mail server only has open port 143 without any kind of security. Is there any way to configure the GLPI extractor?

4

Re: Can't save mailservers with novalidate-cert in 0.84.3 and 0.90.1

Please open new case, old have wrong configuration please post your versions and configuration

You can mark this threat as [resolved] in subject of your threat. (This is only available edit of the first post.) It is good for users who help others to quickly see which post is still open.
##############################################
GLPI 9.1.2 /Ubuntu 14.04.4 LTS
Apache/2.4.7 (Ubuntu) - PHP 5.5.9-1ubuntu4.16 - MySQL: 5.5.49-0ubuntu0.14.04.1