You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2016-10-16 17:35:30

[email protected]
Guest
Registered: 2011-07-18
Posts: 16

Can't receive e-mail after upgrading to 9.1

I've recently updated to 9.1 and now I can't receive e-mails.

When I do a test I get a Information pop-up that says array.

I'm not sure where to begin troubleshooting. Where can I find relevant logs?

UnzFPyS.png


Operating System : Ubuntu Linux 14.04.1 | Kernel and CPU : Linux 3.13.0-55-generic on x86_64 | Processor : Intel(R) Xeon(R) CPU E5405 @ 2.00GHz, 1 cores | RAM : 1024 MB | Apache : Version 2.4.7 | MySQL : Version 5.5.46 | PHP : Version 5.5.9-1 | GLPI : Version 0.90

Offline

#2 2016-10-17 13:38:24

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 13,879

Re: Can't receive e-mail after upgrading to 9.1

Have you somme errors in apache logs? in glpi logs?


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#3 2016-10-22 17:41:01

[email protected]
Guest
Registered: 2011-07-18
Posts: 16

Re: Can't receive e-mail after upgrading to 9.1

Here is what I see in the logs after I try receiving new e-mails.

Apache log:

[Sat Oct 22 10:21:16.919955 2016] [:error] [pid 1220] [client MyWorkstation:53508] PHP Fatal error:  Uncaught Error: Call to undefined method Html::getCopyrightMessage() in /var/www/html/glpi/index.php:191\nStack trace:\n#0 {main}\n  thrown in /var/www/html/glpi/index.php on line 191

[Sat Oct 22 10:21:22.464596 2016] [:error] [pid 1220] [client MyWorkstation:53520] PHP Fatal error:  Uncaught Error: Call to undefined method Html::getCopyrightMessage() in /var/www/html/glpi/index.php:191\nStack trace:\n#0 {main}\n  thrown in /var/www/html/glpi/index.php on line 191, referer: http://MyGLPIServer/front/logout.php?noAUTO=1

/var/www/html/glpi/files/_log/php-errors.log:

2016-10-22 10:21:20 [@MyGLPIServer]
  *** PHP Warning(2): imap_open(): Couldn't open stream {outlook.office365.com:993/imap/ssl/validate-cert/notls}
  Backtrace :
  :                                                 
  inc/auth.class.php:195                             imap_open()
  inc/authmail.class.php:282                         Auth->connection_imap()
  inc/authmail.class.php:313                         AuthMail::mailAuth()
  inc/auth.class.php:729                             AuthMail::tryMailAuth()
  front/login.php:78                                 Auth->Login()
2016-10-22 10:21:20 [@MyGLPIServer]
  *** PHP Notice(8): Unknown: Can not authenticate to IMAP server: AUTHENTICATE failed. (errflg=2)
  Backtrace :
  :                                                 
2016-10-22 10:23:45 [[email protected]]
  *** PHP Notice(8): Array to string conversion
  Backtrace :
  inc/html.class.php:567                             
  inc/html.class.php:1738                            Html::displayMessageAfterRedirect()
  front/mailcollector.form.php:85                    Html::header()


Operating System : Ubuntu Linux 14.04.1 | Kernel and CPU : Linux 3.13.0-55-generic on x86_64 | Processor : Intel(R) Xeon(R) CPU E5405 @ 2.00GHz, 1 cores | RAM : 1024 MB | Apache : Version 2.4.7 | MySQL : Version 5.5.46 | PHP : Version 5.5.9-1 | GLPI : Version 0.90

Offline

#4 2016-10-22 17:47:56

[email protected]
Guest
Registered: 2011-07-18
Posts: 16

Re: Can't receive e-mail after upgrading to 9.1

Also here are the specs on my servers.

GLPI Server:
Operating system    Ubuntu Linux 16.04.1
Kernel and CPU    Linux 4.4.0-45-generic on x86_64
Processor information    Intel(R) Xeon(R) CPU E5-2640 v3 @ 2.60GHz, 1 cores
CPU load averages    0.03 (1 min) 0.03 (5 mins) 0.05 (15 mins)
CPU usage    0% user, 0% kernel, 0% IO, 100% idle
Real memory    212.21 MB used, 479.82 MB total
Virtual memory    97.91 MB used, 512 MB total
Local disk space    3.86 GB used, 14.13 GB total
Apache version 2.4.18
PHP Version 7.0.8-0ubuntu0.16.04.3

MySQL Server:
Operating system    Ubuntu Linux 16.04.1
Kernel and CPU    Linux 4.4.0-45-generic on x86_64
Processor information    Intel(R) Xeon(R) CPU E5-2640 v3 @ 2.60GHz, 1 cores
CPU load averages    0.00 (1 min) 0.00 (5 mins) 0.00 (15 mins)
CPU usage    0% user, 0% kernel, 0% IO, 100% idle
Real memory    323.65 MB used, 983.80 MB total
Virtual memory    1.05 MB used, 1024 MB total
Local disk space    3.62 GB used, 13.64 GB total
MySQL version 5.7.15


Operating System : Ubuntu Linux 14.04.1 | Kernel and CPU : Linux 3.13.0-55-generic on x86_64 | Processor : Intel(R) Xeon(R) CPU E5405 @ 2.00GHz, 1 cores | RAM : 1024 MB | Apache : Version 2.4.7 | MySQL : Version 5.5.46 | PHP : Version 5.5.9-1 | GLPI : Version 0.90

Offline

#5 2016-10-29 15:54:30

[email protected]
Guest
Registered: 2011-07-18
Posts: 16

Re: Can't receive e-mail after upgrading to 9.1

bump


Operating System : Ubuntu Linux 14.04.1 | Kernel and CPU : Linux 3.13.0-55-generic on x86_64 | Processor : Intel(R) Xeon(R) CPU E5405 @ 2.00GHz, 1 cores | RAM : 1024 MB | Apache : Version 2.4.7 | MySQL : Version 5.5.46 | PHP : Version 5.5.9-1 | GLPI : Version 0.90

Offline

#6 2017-01-01 09:06:19

[email protected]
Guest
Registered: 2011-07-18
Posts: 16

Re: Can't receive e-mail after upgrading to 9.1

bump


Operating System : Ubuntu Linux 14.04.1 | Kernel and CPU : Linux 3.13.0-55-generic on x86_64 | Processor : Intel(R) Xeon(R) CPU E5405 @ 2.00GHz, 1 cores | RAM : 1024 MB | Apache : Version 2.4.7 | MySQL : Version 5.5.46 | PHP : Version 5.5.9-1 | GLPI : Version 0.90

Offline

#7 2017-01-05 17:52:57

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 13,879

Re: Can't receive e-mail after upgrading to 9.1

GLPI can't open your collector. Verify the configuration of it


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#8 2017-01-23 00:15:54

[email protected]
Guest
Registered: 2011-07-18
Posts: 16

Re: Can't receive e-mail after upgrading to 9.1

yllen, thanks for your response. I actually just reloaded everything and installed the latest version glpi. everything seems to be working now.


Operating System : Ubuntu Linux 14.04.1 | Kernel and CPU : Linux 3.13.0-55-generic on x86_64 | Processor : Intel(R) Xeon(R) CPU E5405 @ 2.00GHz, 1 cores | RAM : 1024 MB | Apache : Version 2.4.7 | MySQL : Version 5.5.46 | PHP : Version 5.5.9-1 | GLPI : Version 0.90

Offline

Board footer

Powered by FluxBB