You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2018-02-07 15:58:51

maryy
Guest
Registered: 2009-01-09
Posts: 23

[Résolu] Pb envoi notifications - version 9.2.1

Bonjour,

J'ai lu pas mal de posts à ce sujet mais je n'ai pas pour autant solutionné notre problème :

Lorsqu'on ajoute un suivi sur un ticket, il part par mail seulement au bout d'une heure.

Pourtant l'action automatique queuednotification est programmée pour s'exécuter toutes les 5mn en mode CLI.

Il y a aussi une tâche CRON GLPI qui tourne (Le serveur tourne sur un Windows 7), l'action est la suivante : "C:\wamp\bin\php\php7.0.3\php.exe C:\wamp\www\glpi\front\cron.php" et elle fonctionne bien (toutes les 10 mn), mais a priori elle n'est pas d'une grande efficacité...

Que dois-je vérifier d'autre ?

Merci d'avance !

Marie

Last edited by maryy (2018-02-22 18:19:28)

Offline

#2 2018-02-07 16:24:21

LaDenrée
HELPER
Registered: 2012-11-19
Posts: 3,695

Re: [Résolu] Pb envoi notifications - version 9.2.1

bonjour,
vérifiez :
administration>entités>[MonEntité]>onglet notifications>Délai pour envoyer des notifications par courriel


Trouver la panne avant de réparer...
*GLPI 9.1.6+fusion9.1+1.1+behaviours1.5.0+reports+fields+appliances+pdf+badges+webservices PHP7.0 Mariadb10
*GLPI 9.2.1(behaviours1.5.2+fusion9.2+1.0+applicatifs2.3.0+dashboard 0.8.9)hebergé sur serveur mutualisé.

Offline

#3 2018-02-08 10:08:00

maryy
Guest
Registered: 2009-01-09
Posts: 23

Re: [Résolu] Pb envoi notifications - version 9.2.1

Oh génial, je vois 60 minutes, ça correspond forcément ..! Merciiiii !

Offline

#4 2018-02-19 13:17:23

maryy
Guest
Registered: 2009-01-09
Posts: 23

Re: [Résolu] Pb envoi notifications - version 9.2.1

Bonjour,

Bon, je me suis peut-être un peu emballée. J'ai mis 5 mn à la place des 60 mais l'envoi des notifications est toujours d'environ 60 minutes. Y'aurait-il un autre endroit où un paramètre serait à corriger ?

Merci d'avance !

Offline

#5 2018-02-19 15:06:13

LaDenrée
HELPER
Registered: 2012-11-19
Posts: 3,695

Re: [Résolu] Pb envoi notifications - version 9.2.1

configuration>actions automatiques>queuedmail (ou queuednotifications)>fréquence

quel mode est défini CLI ou GLPI ?


Trouver la panne avant de réparer...
*GLPI 9.1.6+fusion9.1+1.1+behaviours1.5.0+reports+fields+appliances+pdf+badges+webservices PHP7.0 Mariadb10
*GLPI 9.2.1(behaviours1.5.2+fusion9.2+1.0+applicatifs2.3.0+dashboard 0.8.9)hebergé sur serveur mutualisé.

Offline

#6 2018-02-19 18:10:06

maryy
Guest
Registered: 2009-01-09
Posts: 23

Re: [Résolu] Pb envoi notifications - version 9.2.1

La fréquence est à 5 mn également, en mode CLI.

Offline

#7 2018-02-19 18:14:29

LaDenrée
HELPER
Registered: 2012-11-19
Posts: 3,695

Re: [Résolu] Pb envoi notifications - version 9.2.1

votre cron tourne toutes les 10 minutes d'après le post #1
donc au mieux, l'action se lance toutes les 10 minutes même si la fréquence de l'action automatique est de 5 minutes.

dernier point auquel je pense :
qu'avez vous dans :
configuration>générale>système>Nombre maximum d'actions automatiques simultanées (exécution CLI)


Trouver la panne avant de réparer...
*GLPI 9.1.6+fusion9.1+1.1+behaviours1.5.0+reports+fields+appliances+pdf+badges+webservices PHP7.0 Mariadb10
*GLPI 9.2.1(behaviours1.5.2+fusion9.2+1.0+applicatifs2.3.0+dashboard 0.8.9)hebergé sur serveur mutualisé.

Offline

#8 2018-02-19 18:29:09

maryy
Guest
Registered: 2009-01-09
Posts: 23

Re: [Résolu] Pb envoi notifications - version 9.2.1

Oui exact. Mais je me suis demandé si ce cron faisait bien qqch, peut-être que des paramètres n'ont pas été correctement corrigé lors de la mise à jour vers la version 9.2.1.

Dans Nb maximum d'actions auto simultanées (CLI) j'ai la valeur 5. Ce serait trop faible ?

Offline

#9 2018-02-22 10:39:37

maryy
Guest
Registered: 2009-01-09
Posts: 23

Re: [Résolu] Pb envoi notifications - version 9.2.1

J'ai augmenté à 10 mais le délai d'expédition des notifications est toujours le même.

Offline

#10 2018-02-22 10:44:54

LaDenrée
HELPER
Registered: 2012-11-19
Posts: 3,695

Re: [Résolu] Pb envoi notifications - version 9.2.1

autre idée : est ce que glpi et le serveurs sont paramétrés sur le même fuseau horaire time/zone UTC+1 ?


Trouver la panne avant de réparer...
*GLPI 9.1.6+fusion9.1+1.1+behaviours1.5.0+reports+fields+appliances+pdf+badges+webservices PHP7.0 Mariadb10
*GLPI 9.2.1(behaviours1.5.2+fusion9.2+1.0+applicatifs2.3.0+dashboard 0.8.9)hebergé sur serveur mutualisé.

Offline

#11 2018-02-22 10:56:43

maryy
Guest
Registered: 2009-01-09
Posts: 23

Re: [Résolu] Pb envoi notifications - version 9.2.1

Bonjour !

GLPI n'utilise pas l'heure du serveur sur lequel il tourne ? Il a sa propre configuration de timezone ?

Offline

#12 2018-02-22 11:04:35

LaDenrée
HELPER
Registered: 2012-11-19
Posts: 3,695

Re: [Résolu] Pb envoi notifications - version 9.2.1

j'ai déjà lu sur ce forum des problèmes liés à timezone.  mais sans certitude que ça soit vraiment la cause de votre problème.

vous pouvez peut être vérifier les mails en file d'attente et regarder l'heure d'envoi planifiée
http://forum.glpi-project.org/viewtopic.php?id=159118


Trouver la panne avant de réparer...
*GLPI 9.1.6+fusion9.1+1.1+behaviours1.5.0+reports+fields+appliances+pdf+badges+webservices PHP7.0 Mariadb10
*GLPI 9.2.1(behaviours1.5.2+fusion9.2+1.0+applicatifs2.3.0+dashboard 0.8.9)hebergé sur serveur mutualisé.

Offline

#13 2018-02-22 14:54:33

maryy
Guest
Registered: 2009-01-09
Posts: 23

Re: [Résolu] Pb envoi notifications - version 9.2.1

Bien vu ..! C'est la timeout qui n'était pas correcte dans php.ini, j'ai mis date.timezone = Europe/Paris .
J'ai fait un suivi sur un ticket vers 13h00 et je l'ai reçu dans les 10 mn qui suivent, ce qui correspond à mon paramétrage.

Bravo ! Et un grand merci ! Je n'aurais jamais trouvé !

Offline

Board footer

Powered by FluxBB