You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2018-01-11 18:22:45

Ph1
Guest
From: Maine et loire
Registered: 2008-08-05
Posts: 150

Migration vers GLPI 9.2.1 et Plugins incompatibles

Bonjour à toutes et à tous !

Nous envisageons de migrer notre GLPI 0.90.3 vers GLPI 9.2.1.
Nous avons une douzaine de plugins que j'ai checkés pour vérifier s'ils ont été mis à jour dans cette version et la plupart sont OK.

Du coup, pour certains, il n'est pas mentionné la version 9.2 de GLPI, j'imagine donc qu'ils ne sont pas compatibles. Ce sont les suivants :

• Datainjection : à priori, la mise à jour est à l'étude, mais pas de news depuis octobre/novembre 2017. Les échanges sur github indiquent que ce n'est clairement pas compatible. Avez-vous un moyen de contournement ou attendez-vous comme moi que ce plugin soit compatible ?
• MoreLDAP : visiblement, les fonctionnalités sont reprises nativement dans la version 9.2.1 (great !) Avez-vous des précisions si tout est bien repris ? on ne peut y avoir accès via la démo en ligne.
• Webservices : La version 1.7.1 est-elle compatible avec GLPI 9.2.1 ?
• Dashboard : la version sur plugins.glpi-project.org indique une compatibilité en 9.1.x seulement, mais à priori, une version compatible 9.2.x est dispo sur la forge.

Merci pour vos retours et/ou expériences !

Phi.


Ph1 // Admin Systèmes & Réseaux
OS : Ubuntu 14.04
Authentification Kerberos // SSO Multi domaines AD
GLPI 9.2.3 // Fusion Inventory 9.2+2.0-RC1 (agent 2.4)

Offline

#2 2018-01-11 18:26:21

LaDenrée
HELPER
Registered: 2012-11-19
Posts: 4,038

Re: Migration vers GLPI 9.2.1 et Plugins incompatibles

datainjection : pas compatible

dashboard 0.8.9 compatible


Trouver la panne avant de réparer...
*GLPI 9.1.6+fusion9.1+1.1+behaviours1.5.0+reports+fields+appliances+pdf+badges+formcreator2.5.2 PHP7.0 Mariadb10
*GLPI 9.2.4(behaviours1.5.2+fusion9.2+1.0+applicatifs2.3.0+dashboard 0.8.9)hebergé sur serveur mutualisé.
*GLPI 9.3  en test (ubuntu 16.04 mariadb 10.2.4) (attente plugin compatible avant mise en prod)

Offline

#3 2018-01-11 18:29:06

btry
Guest
Registered: 2015-10-01
Posts: 196

Re: Migration vers GLPI 9.2.1 et Plugins incompatibles

bonjour

MoreLDAP est osbolète. Je l'ai "mis à mort" il y a peu car une fonctionnalité identique est implémentée dans le coeur.

Webservices => Ca doit être un highlander. Il vaudrait mieux migrer vers l'API native de GLPI. Il semble fonctionner avec GLPI 9.2.x au vu du retour de certains utilsiateurs. Mais ce n''est pas recommandé.

Last edited by btry (2018-01-11 18:29:17)


Always run an upgrade task on a testing instance before running it on production ! Always backup before any upgrade task !

Flyve MDM: https://github.com/flyve-mdm/glpi-plugin
Formcreator: https://github.com/pluginsGLPI/formcreator

Offline

#4 2018-01-15 11:29:37

Ph1
Guest
From: Maine et loire
Registered: 2008-08-05
Posts: 150

Re: Migration vers GLPI 9.2.1 et Plugins incompatibles

Merci à tous les 2 pour vos réponses.
Donc si j'ai bien noté :
• pour le webservices, il faut migrer vers l'API native de GLPI
• pour le datainjection, il faut attendre et rejoindre les discussions directement sur le github du plugin.

Pour le reste, pas de soucis.


Ph1 // Admin Systèmes & Réseaux
OS : Ubuntu 14.04
Authentification Kerberos // SSO Multi domaines AD
GLPI 9.2.3 // Fusion Inventory 9.2+2.0-RC1 (agent 2.4)

Offline

Board footer

Powered by FluxBB