You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2017-02-14 16:54:12

anyssen
Guest
Registered: 2014-06-12
Posts: 18

php-imap no matches found

Bonjour à toutes et tous,

Lors de l'installation de la version 9.1.2 de GLPI sur un CentOS 7.2.1511 je rencontre un problème au niveau de PHP.
En effet, lors de la vérification de compatibilité, j'ai un message disant que l'extension imap n'est pas présente.

J'ai essayé en vain de faire un yum install php-imap, même un yum search *imap* et toujours le même résultat => No matches found.

Il ne me manque que cette extension pour continuer, j'en ai besoin pour la configuration future de mon environnement.

J'ai la version PHP 5.4.16
Le repo epel-release est installé.

Est-ce que quelqu'un a déjà eu ce problème ?

Je n'ai plus de solution sous la main.

D'avance je vous remercie.

Offline

#2 2017-02-14 17:07:19

bzh
Guest
Registered: 2016-09-25
Posts: 270

Re: php-imap no matches found

je ne suis pas un spécialiste linux et CentOS  moins que les autres distrib !


regarde ce lien de notre ami  Remi

https://blog.remirepo.net/post/2016/02/ … HEL-CentOS


Virtual Box \ Debian 8 \ GLPI 9.4

Offline

#3 2017-02-14 17:31:48

anyssen
Guest
Registered: 2014-06-12
Posts: 18

Re: php-imap no matches found

Bonjour,

Je te remercie pour la réponse rapide, malheureusement c'est pour installer PHP7 et l'extension php-imap n'est pas présente.
Je ne peux pas installer la version 7 car incompatibilité avec d'autres applications.

Une autre idée ?

Offline

#4 2017-02-15 08:50:49

bzh
Guest
Registered: 2016-09-25
Posts: 270

Re: php-imap no matches found

si tu installe php 5 plus update ?


Virtual Box \ Debian 8 \ GLPI 9.4

Offline

#5 2017-02-15 09:12:17

remi
GLPI-DEV
From: Champagne
Registered: 2007-04-28
Posts: 7,074
Website

Re: php-imap no matches found

CentOS 7 ne fournit pas php-imap, mais l'extension est disponible dans le dépôt EPEL (il faut dire qu'elle nécessite une bibliothèque qui est morte depuis des années, on parle même de virer imap de php)
Cf: https://fedoraproject.org/wiki/EPEL

Après tu peux aussi utiliser mon dépôt qui fournit à la fois GLPI et les versions récentes de PHP (glpi 9.2 nécessitera PHP 5.6, et de toutes manières, même avec la 9.1, PHP 7 est bien plus rapide)


Dév. Fedora 25 - PHP 5.4/5.5/5.6/7.0/7.1/7.2 - MariaDB 10.1 - GLPI master
Certifié ITILv3 - RPM pour Fedora, RHEL et CentOS sur https://blog.remirepo.net/

Offline

#6 2017-02-15 09:22:16

remi
GLPI-DEV
From: Champagne
Registered: 2007-04-28
Posts: 7,074
Website

Re: php-imap no matches found

Il est dans EPEL, la preuve => http://dl.fedoraproject.org/pub/epel/7/ … x86_64.rpm

Donc si yum ne le trouve pas, c'est que EPEL n'est pas corretement installé (yum repolist ?) ou qu'il y a une règle filtrage quelque part qui le bloque (colle la sortie "complète" de yum install php-imap)


Dév. Fedora 25 - PHP 5.4/5.5/5.6/7.0/7.1/7.2 - MariaDB 10.1 - GLPI master
Certifié ITILv3 - RPM pour Fedora, RHEL et CentOS sur https://blog.remirepo.net/

Offline

#7 2017-02-15 10:23:14

anyssen
Guest
Registered: 2014-06-12
Posts: 18

Re: php-imap no matches found

Bonjour remi,

Merci pour tes réponses et explications.
Ce matin en me connectant sur le serveur je me dit je vais faire un "yum install php-imap" et je collerai la sortie.
A ne rien y comprendre, ça a fonctionné. Il m'a directement proposé d'installer php-imap.

Installed:
  php-imap.x86_64 0:5.4.16-7.el7

Dependency Installed:
  libc-client.x86_64 0:2007f-4.el7.1

Je te remercie pour le temps que tu as pris à me répondre.

Bonne journée.

Offline

Board footer

Powered by FluxBB