You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2020-09-10 09:19:22

Storck
Member
Registered: 2019-03-13
Posts: 5

Problème mise à jour security key

Bonjour,

après l'installation d'une nouvelle instance GLPI en 9.5.0 sur une nouvelle machine, nous avons importé notre base de donnée venant d'une instance en 9.4.5

l'importation ainsi que l'initialisation de la migration vers la nouvelle version de base de donne a été effectuée avec succès.

mon problème actuel est le suivant.

au moment ou j'essai de supprimer un item dans authentification LDAP je me retrouves avec un message d'erreur concernant PHP Sodium.

(message d'erreur : Uncaught Exception SodiumException: public nonce size should be SODIUM_CRYPTO_AEAD_XCHACHA20POLY1305_IETF_NPUBBYTES bytes in /var/www/glpi/inc/toolbox.class.php at line 293 )

j'ai donc voulu mettre à jour les security key grâce à la commande : "php bin/console glpi:security:change_key" mais je me retrouve avec cette erreur :


```
In toolbox.class.php line 293:

  public nonce size should be SODIUM_CRYPTO_AEAD_XCHACHA20POLY1305_IETF_NPUBBYTES bytes

```

et après quelques instant l'application GLPI semble avoir des problèmes pour se relink avec notre LDAP et je suis forcé de me log avec le user glpi local.

auriez-vous une idée d'ou peu venir le problème et comment le résoudre ?

salutations,

Storck

Last edited by Storck (2020-09-10 09:40:44)

Offline

#2 2020-09-10 10:03:49

LaDenrée
HELPER
Registered: 2012-11-19
Posts: 5,151

Re: Problème mise à jour security key

saisissez à nouveau le mot de passe de connexion au LDAP dans configuration>authentification


Trouver la panne avant de réparer...
*GLPI 9.1.6+fusion9.1+1.1+behaviours1.5.0+reports+fields+appliances+pdf+badges+formcreator2.5.2 PHP7.0 Mariadb10
*GLPI 9.4.6(behaviours2.2.1+fusioninventoty 9.4+1.1+applicatifs2.5.0+fields 1.9.1) php7.3 mysql5.6 hebergé sur serveur mutualisé.
TEST GLPI9.5.2 mutualisé OVH (  collecteur KO en attente 9.5.3 pour tester fix)

Offline

#3 2020-09-10 10:42:26

Storck
Member
Registered: 2019-03-13
Posts: 5

Re: Problème mise à jour security key

en remettant le mot de passe sur cette entrée LDAP effectivement le link interfonctionne, mais je ne peux toujours pas supprimer une des anciennes entrée qui a été aussi importée. Je vais essayer de la supprimer sur notre serveur qui est actuellement en 9.4.4, refaire un dump sql et importer cette version. peut-être que le GLPI n'aime pas avoir cette vielle règle d'authentification LDAP non fonctorielle.

Offline

#4 2020-09-10 10:53:08

Storck
Member
Registered: 2019-03-13
Posts: 5

Re: Problème mise à jour security key

Alors j'ai supprimé directement depuis la base de donnée cette vielle règle, le problème sodium persiste.

Found 2 field(s) and 2 configuration entries requiring migration.
Do you want to continue ? [Yes/no]yes

In toolbox.class.php line 293:

  public nonce size should be SODIUM_CRYPTO_AEAD_XCHACHA20POLY1305_IETF_NPUBBYTES bytes

Offline

#5 2020-09-14 13:25:36

Storck
Member
Registered: 2019-03-13
Posts: 5

Re: Problème mise à jour security key

Bonjour,

je ne trouves toujours pas de solution pour renouvelé ces clés qui bloque pas mal l'utilisation de cette nouvelle version de GLPI.

quelqu'un aurait une piste à suivre ?

Merci d'avance.

Offline

Board footer

Powered by FluxBB