You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2020-07-10 15:24:02

supertracteur
Member
Registered: 2020-07-10
Posts: 4

[RESOLU] MAJ vers GLPI 9.5 : erreur dans la mise à jour de la BDD

Bonjour,
Lorsque je tente la mise à jour de la BDD par la console, j'ai ce message :

[root@xxx glpi]# php bin/console db:update
Certains prérequis système optionnels sont manquants. Lancez "php bin/console glpi:system:check_requirements" pour plus de détails.
+------------------------------------+-----------+-------+
|                                    | Actuel    | Cible |
+------------------------------------+-----------+-------+
| Hôte de la base de données         | localhost |       |
| Nom de la base de données          | glpi      |       |
| Utilisateur de la base de données  | glpi      |       |
| Version de GLPI                    | 9.4.5     | 9.5.0 |
| Version de la base de données GLPI | 9.4.5     | 9.5.0 |
+------------------------------------+-----------+-------+
Voulez-vous continuer ? [Yes/no]y
====================================== Mise à jour en 9.4.6 =======================================
====================================== Mise à jour en 9.4.7 =======================================
====================================== Mise à jour en 9.5.0 =======================================
============================= Rename "AuthLdap" itemtype to "AuthLDAP" =============================
============================= Rename "Crontask" itemtype to "CronTask" =============================
============================== Rename "InfoCom" itemtype to "Infocom" ==============================
PHP Warning:  mysqli::query(): MySQL server has gone away in /var/www/html/glpi/inc/dbmysql.class.php on line 298
PHP Warning:  mysqli::query(): Error reading result set's header in /var/www/html/glpi/inc/dbmysql.class.php on line 298
DBmysql::query() in /var/www/html/glpi/inc/dbmysql.class.php line 305
  *** MySQL query error:
  SQL: UPDATE `glpi_items_softwareversions` SET `itemtype` = 'AuthLDAP' WHERE `itemtype` = 'AuthLdap'
  Error: MySQL server has gone away
  Backtrace :
  inc/dbmysql.class.php:339
  inc/migration.class.php:759                        DBmysql->queryOrDie()
  install/update_94_95.php:2089                      Migration->executeMigration()
  inc/update.class.php:475                           update94to95()
  inc/console/database/updatecommand.class.php:160   Update->doUpdates()
  vendor/symfony/console/Command/Command.php:255     Glpi\Console\Database\UpdateCommand->execute()
  vendor/symfony/console/Application.php:1000        Symfony\Component\Console\Command\Command->run()
  inc/console/application.class.php:232              Symfony\Component\Console\Application->doRunCommand()
  vendor/symfony/console/Application.php:271         Glpi\Console\Application->doRunCommand()
  vendor/symfony/console/Application.php:147         Symfony\Component\Console\Application->doRun()
  bin/console:102                                    Symfony\Component\Console\Application->run()
SQL Error "2006": MySQL server has gone away in query "UPDATE `glpi_items_softwareversions` SET `itemtype` = 'AuthLDAP' WHERE `itemtype` = 'AuthLdap'"

In dbmysql.class.php line 349:

  - Erreur durant l'éxecution de la requête : UPDATE `glpi_items_softwareversions` SET `itemtype` = 'AuthLDAP' WHERE `itemtype` = 'AuthLdap' - L'erreur est MySQL server has gone away


glpi:database:update [-u|--allow-unstable] [-f|--force]


Pouvez vous m'aider?
Merci.
Cordialement,

Last edited by supertracteur (2020-07-15 17:37:58)

Offline

#2 2020-07-13 19:17:30

nicolaay
Member
Registered: 2020-07-13
Posts: 5

Re: [RESOLU] MAJ vers GLPI 9.5 : erreur dans la mise à jour de la BDD

Hello,

J'ai exactement le même problème sur la même table SQL  lorsque je veux mettre à jour la BDD vers 9.5.


Voici la configuration de mon serveur.

Server

Operating system: Linux support-info 4.9.0-8-amd64 #1 SMP Debian 4.9.130-2 (2018-10-27) x86_64
PHP 7.3.19-1~deb10u1 apache2handler (Core, PDO, Phar, Reflection, SPL, SimpleXML, Zend OPcache, apache2handler, apc, apcu,
    calendar, ctype, curl, date, dom, exif, fileinfo, filter, ftp, gd, gettext, hash, iconv, imap, json, ldap, libxml, mbstring,
    mysqli, mysqlnd, openssl, pcre, pdo_mysql, posix, readline, session, shmop, sockets, sodium, standard, sysvmsg, sysvsem,
    sysvshm, tokenizer, wddx, xml, xmlreader, xmlrpc, xmlwriter, xsl, zlib)
Setup: max_execution_time="600" memory_limit="512M" post_max_size="20M" safe_mode="" session.save_handler="files"
    upload_max_filesize="20M"
Software: Apache/2.4.25 (Debian) (Apache/2.4.25 (Debian) Server at support-info Port 80)
    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:78.0) Gecko/20100101 Firefox/78.0
Server Software: Debian 9.1
    Server Version: 10.1.26-MariaDB-0+deb9u1
    Server SQL Mode:
    Parameters: GLPI@localhost/glpi_db
    Host info: Localhost via UNIX socket
   
mysqli extension is installed
ctype extension is installed
fileinfo extension is installed
json extension is installed
mbstring extension is installed
iconv extension is installed
zlib extension is installed
curl extension is installed
gd extension is installed
simplexml extension is installed
xml extension is installed
ldap extension is installed
imap extension is installed
Zend OPcache extension is installed
APCu extension is installed
xmlrpc extension is installed
CAS extension is installed
exif extension is installed
Database version seems correct (10.1.26) - Perfect!Database version seems correct (10.1.26) - Perfect!
OK/var/www/glpi/files/_log : OK
OK/var/www/glpi/config : OK
OK/var/www/glpi/files : OK
OK/var/www/glpi/files/_dumps : OK
OK/var/www/glpi/files/_sessions : OK
OK/var/www/glpi/files/_cron : OK
OK/var/www/glpi/files/_graphs : OK
OK/var/www/glpi/files/_lock : OK
OK/var/www/glpi/files/_plugins : OK
OK/var/www/glpi/files/_tmp : OK
OK/var/www/glpi/files/_cache : OK
OK/var/www/glpi/files/_rss : OK
OK/var/www/glpi/files/_uploads : OK
OK/var/www/glpi/files/_pictures : OK
Web access to files directory is protectedWeb access to files directory is protected : OK

Libraries

htmLawed version 1.2.4 in (/var/www/glpi/lib/htmlawed)
phpmailer/phpmailer version 6.0.7 in (/var/www/glpi/vendor/phpmailer/phpmailer/src)
simplepie/simplepie version 1.5.2 in (/var/www/glpi/vendor/simplepie/simplepie/library)
tecnickcom/tcpdf version 6.2.26 in (/var/www/glpi/vendor/tecnickcom/tcpdf)
michelf/php-markdown in (/var/www/glpi/vendor/michelf/php-markdown/Michelf)
true/punycode in (/var/www/glpi/vendor/true/punycode/src)
iamcal/lib_autolink in (/var/www/glpi/vendor/iamcal/lib_autolink)
sabre/vobject in (/var/www/glpi/vendor/sabre/vobject/lib)
zendframework/zend-cache in (/var/www/glpi/vendor/zendframework/zend-cache/src)
zendframework/zend-i18n in (/var/www/glpi/vendor/zendframework/zend-i18n/src)
zendframework/zend-serializer in (/var/www/glpi/vendor/zendframework/zend-serializer/src)
monolog/monolog in (/var/www/glpi/vendor/monolog/monolog/src/Monolog)
sebastian/diff in (/var/www/glpi/vendor/sebastian/diff/src)
elvanto/litemoji in (/var/www/glpi/vendor/elvanto/litemoji/src)
symfony/console in (/var/www/glpi/vendor/symfony/console)
leafo/scssphp in (/var/www/glpi/vendor/leafo/scssphp/src)
phpCas version 1.3.6 in (/usr/share/php/CAS/source)

LDAP directories

Server: 'xxxx', Port: '389', BaseDN: 'DC=xxxx,DC=local', Connection filter:
        '(&(objectClass=user)(objectCategory=person)(!(userAccountControl:1.2.840.113556.1.4.803:=2)))', RootDN: 'xxxx\S_GLPI', Use
        TLS: none

SQL replicas


Not active

Notifications


Way of sending emails: PHP

Mails receivers


Name: 'support-info@vss-sas.com' Active: Yes
    Server: '{172.17.49.101:143/imap/novalidate-cert/notls}INBOX' Login: 'support-info' Password: Yes

Plugins list


    behaviors            Name: Comportements                  Version: 2.2.2      State: Enabled
    datainjection        Name: Data injection                 Version: 2.7.1      State: Enabled
    mailanalyzer         Name: Mail Analyzer                  Version: 1.6.1      State: Enabled
    moreticket           Name: More ticket                    Version: 1.5.1      State: Enabled
    ocsinventoryng       Name: OCS Inventory NG               Version: 1.6.0      State: Enabled
    dashboard            Name: Tableau de bord                Version: 0.9.8      State: Enabled

OCS Inventory NG
Host: localhost
Connection: Ok
Use the OCSNG software dictionary: No

voici l’erreur rencontrée lors de la mise à jour de la DB ....

  SQL: UPDATE `glpi_items_softwareversions` SET `itemtype` = 'AuthLDAP' WHERE `itemtype` = 'AuthLdap'
  Error: MySQL server has gone away
  Backtrace :
  inc/dbmysql.class.php:339
  inc/migration.class.php:759                        DBmysql->queryOrDie()
  install/update_94_95.php:2089                      Migration->executeMigration()
  inc/update.class.php:475                           update94to95()
  inc/console/database/updatecommand.class.php:160   Update->doUpdates()
  vendor/symfony/console/Command/Command.php:255     Glpi\Console\Database\UpdateCommand->execute()
  vendor/symfony/console/Application.php:1000        Symfony\Component\Console\Command\Command->run()
  inc/console/application.class.php:232              Symfony\Component\Console\Application->doRunCommand()
  vendor/symfony/console/Application.php:271         Glpi\Console\Application->doRunCommand()
  vendor/symfony/console/Application.php:147         Symfony\Component\Console\Application->doRun()
  bin/console:102                                    Symfony\Component\Console\Application->run()
SQL Error "2006": MySQL server has gone away in query "UPDATE `glpi_items_softwareversions` SET `itemtype` = 'AuthLDAP' WHERE `itemtype` = 'AuthLdap'"

In dbmysql.class.php line 349:

  - Erreur durant l'éxecution de la requête : UPDATE `glpi_items_softwareversions` SET `it
  emtype` = 'AuthLDAP' WHERE `itemtype` = 'AuthLdap' - L'erreur est MySQL server has gone
  away


Dans le fichier de logs mysql j'ai ca :

Trying to get some variables.
Some pointers may be invalid and cause the dump to abort.
Query (0x7f453f030020): UPDATE `glpi_items_softwareversions` SET `itemtype` = 'AuthLDAP' WHERE `itemtype` = 'AuthLdap'
Connection ID (thread ID): 3
Status: NOT_KILLED

Optimizer switch: index_merge=on,index_merge_union=on,index_merge_sort_union=on,index_merge_intersection=on,index_merge_sort_intersection=off,engine_condition_pushdown=off,index_condition_pushdown=on,derived_merge=on,derived_with_keys=on,firstmatch=on,loosescan=on,materialization=on,in_to_exists=on,semijoin=on,partial_match_rowid_merge=o                 n,partial_match_table_scan=on,subquery_cache=on,mrr=off,mrr_cost_based=off,mrr_sort_keys=off,outer_join_with_cache=on,semijoin_with_cache=on,join_cache_incremental=on,join_cache_hashed=on,join_cache_bka=on,optimize_join_buffer_size=off,table_elimination=on,extended_keys=on,exists_to_in=on,orderby_uses_equalities=off

The manual page at XXX contains
information that should help you find out what is causing the crash.
2020-07-13 16:13:17 140456899855296 [Note] InnoDB: innodb_empty_free_list_algorithm has been changed to legacy because of small buffer pool size. In order to use backoff, increase buffer pool at least up to 20MB.

2020-07-13 16:13:17 140456899855296 [Note] InnoDB: Using mutexes to ref count buffer pool pages
2020-07-13 16:13:17 140456899855296 [Note] InnoDB: The InnoDB memory heap is disabled
2020-07-13 16:13:17 140456899855296 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2020-07-13 16:13:17 140456899855296 [Note] InnoDB: GCC builtin __atomic_thread_fence() is used for memory barrier
2020-07-13 16:13:17 140456899855296 [Note] InnoDB: Compressed tables use zlib 1.2.8
2020-07-13 16:13:17 140456899855296 [Note] InnoDB: Using Linux native AIO
2020-07-13 16:13:17 140456899855296 [Note] InnoDB: Using SSE crc32 instructions
2020-07-13 16:13:17 140456899855296 [Note] InnoDB: Initializing buffer pool, size = 128.0M
2020-07-13 16:13:17 140456899855296 [Note] InnoDB: Completed initialization of buffer pool
2020-07-13 16:13:17 140456899855296 [Note] InnoDB: Highest supported file format is Barracuda.
2020-07-13 16:13:17 140456899855296 [Note] InnoDB: The log sequence number 19003106439 in ibdata file do not match the log sequence number 19003106519 in the ib_logfiles!
2020-07-13 16:13:17 140456899855296 [Note] InnoDB: Restoring possible half-written data pages from the doublewrite buffer...
2020-07-13 16:13:17 140456899855296 [Note] InnoDB: 128 rollback segment(s) are active.
2020-07-13 16:13:17 140456899855296 [Note] InnoDB: Waiting for purge to start
2020-07-13 16:13:17 140456899855296 [Note] InnoDB:  Percona XtraDB  5.6.36-82.1 started; log sequence number 19003106519
2020-07-13 16:13:17 140456281241344 [Note] InnoDB: Dumping buffer pool(s) not yet started
2020-07-13 16:13:17 140456899855296 [Note] Plugin 'FEEDBACK' is disabled.
2020-07-13 16:13:17 140456899855296 [Note] Recovering after a crash using tc.log
2020-07-13 16:13:17 140456899855296 [Note] Starting crash recovery...
2020-07-13 16:13:17 140456899855296 [Note] Crash recovery finished.
2020-07-13 16:13:17 140456899855296 [Note] Server socket created on IP: '127.0.0.1'.
2020-07-13 16:13:17 140456899855296 [Note] /usr/sbin/mysqld: ready for connections.
Version: '10.1.26-MariaDB-0+deb9u1'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  Debian 9.1
2020-07-13 16:16:19 140456899008256 [ERROR] Found index itemtype whose column info does not match that of MySQL.
2020-07-13 16:16:19 140456899008256 [ERROR] Build InnoDB index translation table for Table ./glpi_db/glpi_items_softwareversions failed
2020-07-13 16:16:19 140456899008256 [ERROR] Index itemtype of glpi_db/glpi_items_softwareversions has 1 columns unique inside InnoDB, but MySQL is asking statistics for 2 columns. Have you mixed up .frm files from different installations? See XXX

2020-07-13 16:16:19 140456899008256 [ERROR] Index items_id of glpi_db/glpi_items_softwareversions has 1 columns unique inside InnoDB, but MySQL is asking statistics for 2 columns. Have you mixed up .frm files from different installations? See XXX

2020-07-13 16:16:19 140456899008256 [ERROR] Index item of glpi_db/glpi_items_softwareversions has 2 columns unique inside InnoDB, but MySQL is asking statistics for 3 columns. Have you mixed up .frm files from different installations? See XXX


Merci de votre aide,
Nicolas

Last edited by nicolaay (2020-07-14 13:07:36)

Offline

#3 2020-07-15 03:15:45

nicolaay
Member
Registered: 2020-07-13
Posts: 5

Re: [RESOLU] MAJ vers GLPI 9.5 : erreur dans la mise à jour de la BDD

Ok j'ai trouvé la solution, j'ai fais une installation propre de glpi 9.5 sur une autre VM.
Ensuite j'ai exporter la table qui posait problème avec cette commande
/home/nicolas# mysqldump --databases glpi --tables glpi_items_softwareversions > computers.sql

j'ai ensuite importé la table sur ma base de prod avec la commande
mysql glpi_db < computers.sql

Installation et migration OK.

Bon courage.

Last edited by nicolaay (2020-07-15 17:15:25)

Offline

#4 2020-07-15 16:23:28

nicolaay
Member
Registered: 2020-07-13
Posts: 5

Re: [RESOLU] MAJ vers GLPI 9.5 : erreur dans la mise à jour de la BDD

La table au format txt

 -- MySQL dump 10.16  Distrib 10.1.26-MariaDB, for debian-linux-gnu (x86_64)
--
-- Host: localhost    Database: glpi_db
-- ------------------------------------------------------
-- Server version	10.1.26-MariaDB-0+deb9u1

/*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */;
/*!40101 SET @OLD_CHARACTER_SET_RESULTS=@@CHARACTER_SET_RESULTS */;
/*!40101 SET @OLD_COLLATION_CONNECTION=@@COLLATION_CONNECTION */;
/*!40101 SET NAMES utf8mb4 */;
/*!40103 SET @OLD_TIME_ZONE=@@TIME_ZONE */;
/*!40103 SET TIME_ZONE='+00:00' */;
/*!40014 SET @OLD_UNIQUE_CHECKS=@@UNIQUE_CHECKS, UNIQUE_CHECKS=0 */;
/*!40014 SET @OLD_FOREIGN_KEY_CHECKS=@@FOREIGN_KEY_CHECKS, FOREIGN_KEY_CHECKS=0 */;
/*!40101 SET @OLD_SQL_MODE=@@SQL_MODE, SQL_MODE='NO_AUTO_VALUE_ON_ZERO' */;
/*!40111 SET @OLD_SQL_NOTES=@@SQL_NOTES, SQL_NOTES=0 */;

--
-- Table structure for table `glpi_items_softwareversions`
--

DROP TABLE IF EXISTS `glpi_items_softwareversions`;
/*!40101 SET @saved_cs_client     = @@character_set_client */;
/*!40101 SET character_set_client = utf8 */;
CREATE TABLE `glpi_items_softwareversions` (
  `id` int(11) NOT NULL AUTO_INCREMENT,
  `items_id` int(11) NOT NULL DEFAULT '0',
  `itemtype` varchar(100) COLLATE utf8_unicode_ci NOT NULL,
  `softwareversions_id` int(11) NOT NULL DEFAULT '0',
  `is_deleted_item` tinyint(1) NOT NULL DEFAULT '0',
  `is_template_item` tinyint(1) NOT NULL DEFAULT '0',
  `entities_id` int(11) NOT NULL DEFAULT '0',
  `is_deleted` tinyint(1) NOT NULL DEFAULT '0',
  `is_dynamic` tinyint(1) NOT NULL DEFAULT '0',
  `date_install` date DEFAULT NULL,
  PRIMARY KEY (`id`),
  UNIQUE KEY `unicity` (`itemtype`,`items_id`,`softwareversions_id`),
  KEY `items_id` (`items_id`),
  KEY `itemtype` (`itemtype`),
  KEY `item` (`itemtype`,`items_id`),
  KEY `softwareversions_id` (`softwareversions_id`),
  KEY `computers_info` (`entities_id`,`is_template_item`,`is_deleted_item`),
  KEY `is_template` (`is_template_item`),
  KEY `is_deleted` (`is_deleted_item`),
  KEY `is_dynamic` (`is_dynamic`),
  KEY `date_install` (`date_install`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci;
/*!40101 SET character_set_client = @saved_cs_client */;

--
-- Dumping data for table `glpi_items_softwareversions`
--

LOCK TABLES `glpi_items_softwareversions` WRITE;
/*!40000 ALTER TABLE `glpi_items_softwareversions` DISABLE KEYS */;
/*!40000 ALTER TABLE `glpi_items_softwareversions` ENABLE KEYS */;
UNLOCK TABLES;
/*!40103 SET TIME_ZONE=@OLD_TIME_ZONE */;

/*!40101 SET SQL_MODE=@OLD_SQL_MODE */;
/*!40014 SET FOREIGN_KEY_CHECKS=@OLD_FOREIGN_KEY_CHECKS */;
/*!40014 SET UNIQUE_CHECKS=@OLD_UNIQUE_CHECKS */;
/*!40101 SET CHARACTER_SET_CLIENT=@OLD_CHARACTER_SET_CLIENT */;
/*!40101 SET CHARACTER_SET_RESULTS=@OLD_CHARACTER_SET_RESULTS */;
/*!40101 SET COLLATION_CONNECTION=@OLD_COLLATION_CONNECTION */;
/*!40111 SET SQL_NOTES=@OLD_SQL_NOTES */;

-- Dump completed on 2020-07-15  2:21:48


Tiens moi au courant

Nicolas

Last edited by nicolaay (2020-07-15 16:57:04)

Offline

#5 2020-07-15 16:46:20

supertracteur
Member
Registered: 2020-07-10
Posts: 4

Re: [RESOLU] MAJ vers GLPI 9.5 : erreur dans la mise à jour de la BDD

nicolaay wrote:

Je ne peux pas envoyer de lien du fichier dump SQL de la table glpi_items_softwareversions, qu'il faut importer avant de lancer la mise à jour de la BDD vers 9.5.

Combine : voici le lien https, après sharepoint c'est .com | il s'agit d'un lien OneDrive.

duclot-my.sharepoint/:u:/g/personal/ntrophime_vss-sas_com/ET84A_YYc5BMtmWzRmfbu9gBNNd15LhAhgfixxyqV_NNbw?e=60QFX9

Sinon le voici en format TXT.

 -- MySQL dump 10.16  Distrib 10.1.26-MariaDB, for debian-linux-gnu (x86_64)
--
-- Host: localhost    Database: glpi_db
-- ------------------------------------------------------
-- Server version	10.1.26-MariaDB-0+deb9u1

/*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */;
/*!40101 SET @OLD_CHARACTER_SET_RESULTS=@@CHARACTER_SET_RESULTS */;
/*!40101 SET @OLD_COLLATION_CONNECTION=@@COLLATION_CONNECTION */;
/*!40101 SET NAMES utf8mb4 */;
/*!40103 SET @OLD_TIME_ZONE=@@TIME_ZONE */;
/*!40103 SET TIME_ZONE='+00:00' */;
/*!40014 SET @OLD_UNIQUE_CHECKS=@@UNIQUE_CHECKS, UNIQUE_CHECKS=0 */;
/*!40014 SET @OLD_FOREIGN_KEY_CHECKS=@@FOREIGN_KEY_CHECKS, FOREIGN_KEY_CHECKS=0 */;
/*!40101 SET @OLD_SQL_MODE=@@SQL_MODE, SQL_MODE='NO_AUTO_VALUE_ON_ZERO' */;
/*!40111 SET @OLD_SQL_NOTES=@@SQL_NOTES, SQL_NOTES=0 */;

--
-- Table structure for table `glpi_items_softwareversions`
--

DROP TABLE IF EXISTS `glpi_items_softwareversions`;
/*!40101 SET @saved_cs_client     = @@character_set_client */;
/*!40101 SET character_set_client = utf8 */;
CREATE TABLE `glpi_items_softwareversions` (
  `id` int(11) NOT NULL AUTO_INCREMENT,
  `items_id` int(11) NOT NULL DEFAULT '0',
  `itemtype` varchar(100) COLLATE utf8_unicode_ci NOT NULL,
  `softwareversions_id` int(11) NOT NULL DEFAULT '0',
  `is_deleted_item` tinyint(1) NOT NULL DEFAULT '0',
  `is_template_item` tinyint(1) NOT NULL DEFAULT '0',
  `entities_id` int(11) NOT NULL DEFAULT '0',
  `is_deleted` tinyint(1) NOT NULL DEFAULT '0',
  `is_dynamic` tinyint(1) NOT NULL DEFAULT '0',
  `date_install` date DEFAULT NULL,
  PRIMARY KEY (`id`),
  UNIQUE KEY `unicity` (`itemtype`,`items_id`,`softwareversions_id`),
  KEY `items_id` (`items_id`),
  KEY `itemtype` (`itemtype`),
  KEY `item` (`itemtype`,`items_id`),
  KEY `softwareversions_id` (`softwareversions_id`),
  KEY `computers_info` (`entities_id`,`is_template_item`,`is_deleted_item`),
  KEY `is_template` (`is_template_item`),
  KEY `is_deleted` (`is_deleted_item`),
  KEY `is_dynamic` (`is_dynamic`),
  KEY `date_install` (`date_install`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci;
/*!40101 SET character_set_client = @saved_cs_client */;

--
-- Dumping data for table `glpi_items_softwareversions`
--

LOCK TABLES `glpi_items_softwareversions` WRITE;
/*!40000 ALTER TABLE `glpi_items_softwareversions` DISABLE KEYS */;
/*!40000 ALTER TABLE `glpi_items_softwareversions` ENABLE KEYS */;
UNLOCK TABLES;
/*!40103 SET TIME_ZONE=@OLD_TIME_ZONE */;

/*!40101 SET SQL_MODE=@OLD_SQL_MODE */;
/*!40014 SET FOREIGN_KEY_CHECKS=@OLD_FOREIGN_KEY_CHECKS */;
/*!40014 SET UNIQUE_CHECKS=@OLD_UNIQUE_CHECKS */;
/*!40101 SET CHARACTER_SET_CLIENT=@OLD_CHARACTER_SET_CLIENT */;
/*!40101 SET CHARACTER_SET_RESULTS=@OLD_CHARACTER_SET_RESULTS */;
/*!40101 SET COLLATION_CONNECTION=@OLD_COLLATION_CONNECTION */;
/*!40111 SET SQL_NOTES=@OLD_SQL_NOTES */;

-- Dump completed on 2020-07-15  2:21:48


Tiens moi au courant

Nicolas

Merci Nicolas.
Tu peux annuler le lien ONEDrive, le format txt est parfait pour les autres.
J'ai inséré la table en suivant tes instructions et j'ai le meme souci. Pas de souci sur mysqldump mais la mise à jour de la base coince toujours.
Cordialement,

Last edited by supertracteur (2020-07-15 16:54:56)

Offline

#6 2020-07-15 16:58:12

nicolaay
Member
Registered: 2020-07-13
Posts: 5

Re: [RESOLU] MAJ vers GLPI 9.5 : erreur dans la mise à jour de la BDD

supertracteur wrote:
nicolaay wrote:

Je ne peux pas envoyer de lien du fichier dump SQL de la table glpi_items_softwareversions, qu'il faut importer avant de lancer la mise à jour de la BDD vers 9.5.

Combine : voici le lien https, après sharepoint c'est .com | il s'agit d'un lien OneDrive.

duclot-my.sharepoint/:u:/g/personal/ntrophime_vss-sas_com/ET84A_YYc5BMtmWzRmfbu9gBNNd15LhAhgfixxyqV_NNbw?e=60QFX9

Sinon le voici en format TXT.

 -- MySQL dump 10.16  Distrib 10.1.26-MariaDB, for debian-linux-gnu (x86_64)
--
-- Host: localhost    Database: glpi_db
-- ------------------------------------------------------
-- Server version	10.1.26-MariaDB-0+deb9u1

/*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */;
/*!40101 SET @OLD_CHARACTER_SET_RESULTS=@@CHARACTER_SET_RESULTS */;
/*!40101 SET @OLD_COLLATION_CONNECTION=@@COLLATION_CONNECTION */;
/*!40101 SET NAMES utf8mb4 */;
/*!40103 SET @OLD_TIME_ZONE=@@TIME_ZONE */;
/*!40103 SET TIME_ZONE='+00:00' */;
/*!40014 SET @OLD_UNIQUE_CHECKS=@@UNIQUE_CHECKS, UNIQUE_CHECKS=0 */;
/*!40014 SET @OLD_FOREIGN_KEY_CHECKS=@@FOREIGN_KEY_CHECKS, FOREIGN_KEY_CHECKS=0 */;
/*!40101 SET @OLD_SQL_MODE=@@SQL_MODE, SQL_MODE='NO_AUTO_VALUE_ON_ZERO' */;
/*!40111 SET @OLD_SQL_NOTES=@@SQL_NOTES, SQL_NOTES=0 */;

--
-- Table structure for table `glpi_items_softwareversions`
--

DROP TABLE IF EXISTS `glpi_items_softwareversions`;
/*!40101 SET @saved_cs_client     = @@character_set_client */;
/*!40101 SET character_set_client = utf8 */;
CREATE TABLE `glpi_items_softwareversions` (
  `id` int(11) NOT NULL AUTO_INCREMENT,
  `items_id` int(11) NOT NULL DEFAULT '0',
  `itemtype` varchar(100) COLLATE utf8_unicode_ci NOT NULL,
  `softwareversions_id` int(11) NOT NULL DEFAULT '0',
  `is_deleted_item` tinyint(1) NOT NULL DEFAULT '0',
  `is_template_item` tinyint(1) NOT NULL DEFAULT '0',
  `entities_id` int(11) NOT NULL DEFAULT '0',
  `is_deleted` tinyint(1) NOT NULL DEFAULT '0',
  `is_dynamic` tinyint(1) NOT NULL DEFAULT '0',
  `date_install` date DEFAULT NULL,
  PRIMARY KEY (`id`),
  UNIQUE KEY `unicity` (`itemtype`,`items_id`,`softwareversions_id`),
  KEY `items_id` (`items_id`),
  KEY `itemtype` (`itemtype`),
  KEY `item` (`itemtype`,`items_id`),
  KEY `softwareversions_id` (`softwareversions_id`),
  KEY `computers_info` (`entities_id`,`is_template_item`,`is_deleted_item`),
  KEY `is_template` (`is_template_item`),
  KEY `is_deleted` (`is_deleted_item`),
  KEY `is_dynamic` (`is_dynamic`),
  KEY `date_install` (`date_install`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci;
/*!40101 SET character_set_client = @saved_cs_client */;

--
-- Dumping data for table `glpi_items_softwareversions`
--

LOCK TABLES `glpi_items_softwareversions` WRITE;
/*!40000 ALTER TABLE `glpi_items_softwareversions` DISABLE KEYS */;
/*!40000 ALTER TABLE `glpi_items_softwareversions` ENABLE KEYS */;
UNLOCK TABLES;
/*!40103 SET TIME_ZONE=@OLD_TIME_ZONE */;

/*!40101 SET SQL_MODE=@OLD_SQL_MODE */;
/*!40014 SET FOREIGN_KEY_CHECKS=@OLD_FOREIGN_KEY_CHECKS */;
/*!40014 SET UNIQUE_CHECKS=@OLD_UNIQUE_CHECKS */;
/*!40101 SET CHARACTER_SET_CLIENT=@OLD_CHARACTER_SET_CLIENT */;
/*!40101 SET CHARACTER_SET_RESULTS=@OLD_CHARACTER_SET_RESULTS */;
/*!40101 SET COLLATION_CONNECTION=@OLD_COLLATION_CONNECTION */;
/*!40111 SET SQL_NOTES=@OLD_SQL_NOTES */;

-- Dump completed on 2020-07-15  2:21:48


Tiens moi au courant

Nicolas

Merci Nicolas.
Tu peux annuler le lien ONEDrive, le format txt est parfait pour les autres.
J'ai inséré la table en suivant tes instructions et j'ai le meme souci. Pas de souci sur mysqldump mais la mise à jour de la base coince toujours.
Cordialement,

Je suis desolé j'ai fais une erreur dans mon précedent post c'est pour ca que ca ne fonctionne pas chez toi.

Ca me met la puce à l'oreille quand je vois ton dernier post parler de mysqldump. Il ne faut pas faire un mysqldump pour importer la table, ce n'est que pour l'exporter..
Pour l'importer fais plutôt 

mysql nomdelabase < nomdufichier.sql 

J'ai modifié pour ceux qui vont me relire =/

Cordialement,
Nicolas

Last edited by nicolaay (2020-07-15 17:16:53)

Offline

#7 2020-07-15 17:36:34

supertracteur
Member
Registered: 2020-07-10
Posts: 4

Re: [RESOLU] MAJ vers GLPI 9.5 : erreur dans la mise à jour de la BDD

Bonjour Nicolas,
Je ne fais plus de citations sinon le post va etre trop long ^^
en fait, le simple fait de dropper la table semble avoir fait son effet.
Le script a pu se lancer et se terminer correctement.

MariaDB [glpi]> DROP TABLE glpi_items_softwareversions;

Merci beaucoup pour ton aide.
Nous allons maintenant tester cette nouvelle version (gros changement cosmétique c'est bien).

Je mets le post en résolu.
Cordialement,

Supertracteur.

Offline

Board footer

Powered by FluxBB