You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2020-07-08 18:43:03

juuuuu
Member
Registered: 2019-12-11
Posts: 6

Soucis plugin après migration vers GLPI 9.5

Bonjour,

J'ai suivi la procédure pour la migration d'une version 9.4.2 à la version 9.5, j'ai bien copié le dossier files et le fichier de configuration de l'ancienne version.

La migration s'est bien déroulée (update de la base sql), cependant mes plugins apparaissent en statut 'Erreur / à nettoyer'.

J'ai tenté de copier le contenu de mon ancienne version sur celle-ci, mais maintenant la liste de plugins est vide.

Dans mes recherches, je suis tombé sur un souci similaire, et j'ai compris que les dossiers de plugins devaient être copiés avant la migration.

Comment est-ce que je peux faire , pour éviter de réinstaller chaque plugins à la main et perdre peut-être chaque configuration.

Merci

Offline

#2 2020-07-08 18:50:38

mecmav
Member
From: Brasil
Registered: 2019-03-22
Posts: 294

Re: Soucis plugin après migration vers GLPI 9.5

Je pense que si vous l'avez fait en production, il est très probable que vous ayez des problèmes avec les paramètres des plugins.

mais s'il s'agit d'un scénario de test, vous devriez essayer de refaire les procédures, en copiant les fichiers depuis les dossiers "files, config, plugins", et vérifier les autorisations d'accès des utilisateurs et des groupes après la migration.

Offline

#3 2020-07-08 20:38:13

juuuuu
Member
Registered: 2019-12-11
Posts: 6

Re: Soucis plugin après migration vers GLPI 9.5

Vous voulez dire plutôt faire les procédures, les copies et les autorisations d'accès avant de lancer la migration ?

Offline

#4 2020-07-09 07:09:09

GillesZoratti
Member
From: Luxembourg
Registered: 2019-05-06
Posts: 14

Re: Soucis plugin après migration vers GLPI 9.5

Pour ma part j'ai testé la migration de la 9.4.6 aujourd'hui vers la 9.5

et a part le plugin Dashboard

tous les autres m'ont annonçés qu'ils étaient compatibles avec la version glpi >= 9.4.2 et glpi < 9.5

Offline

#5 2020-07-09 12:23:31

juuuuu
Member
Registered: 2019-12-11
Posts: 6

Re: Soucis plugin après migration vers GLPI 9.5

GillesZoratti wrote:

Pour ma part j'ai testé la migration de la 9.4.6 aujourd'hui vers la 9.5

et a part le plugin Dashboard

tous les autres m'ont annonçés qu'ils étaient compatibles avec la version glpi >= 9.4.2 et glpi < 9.5

Je vais regarder en détail la compatibilité de mes plugins, merci.

Pour la migration, vous avez copié le contenu des dossiers files, config et plugins avant de lancer la procédure ?

Offline

#6 2020-07-09 13:27:41

mecmav
Member
From: Brasil
Registered: 2019-03-22
Posts: 294

Re: Soucis plugin après migration vers GLPI 9.5

vous devez extraire les fichiers du projet tar.gz de la version glpi souhaitée.

après avoir extrait dans le dossier d'intérêt, copiez l'ancien contenu des dossiers config, files et plugins superposant les fichiers créés par la nouvelle installation.

c'est-à-dire que vous profiterez de vos anciennes données dans une nouvelle version, vous vérifierez les autorisations de ces dossiers après avoir déplacé les anciens vers le nouvel emplacement.

vérifiez la compatibilité des plugins si vous en avez plusieurs installés.
si vous êtes en erreur, désactivez le plugin et vérifiez sa compatibilité avec la dernière version

Offline

#7 2020-07-09 14:27:07

juuuuu
Member
Registered: 2019-12-11
Posts: 6

Re: Soucis plugin après migration vers GLPI 9.5

mecmav wrote:

vous devez extraire les fichiers du projet tar.gz de la version glpi souhaitée.

après avoir extrait dans le dossier d'intérêt, copiez l'ancien contenu des dossiers config, files et plugins superposant les fichiers créés par la nouvelle installation.

c'est-à-dire que vous profiterez de vos anciennes données dans une nouvelle version, vous vérifierez les autorisations de ces dossiers après avoir déplacé les anciens vers le nouvel emplacement.

vérifiez la compatibilité des plugins si vous en avez plusieurs installés.
si vous êtes en erreur, désactivez le plugin et vérifiez sa compatibilité avec la dernière version

Merci de votre réponse, je vais refaire les choses comme vous l'indiquez

Offline

Board footer

Powered by FluxBB