You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2019-01-17 17:52:42

Marouanec
Member
Registered: 2019-01-17
Posts: 3

Installation GLPI avec Wampserver et windows7 x64 bloquee a l'etape 3

Bonjour a tous,

Tout d'abord ne pretrez s'il vous plait pas attention a l'ortographe car j'utilise un clavier QWERTY donc pas d'accents smile.

Voila je me lance dans l'installation de GLPI et je suis bloque a l'etape 3:

===================
GLPI SETUP
     Step 3
Initialization of the database
===================

Pas de bouton continuer  pour passer a l'etape 4.

J'utilise:

  • Windows 7 X64.

  • wampserver3.1.7_x64.

  • Apache 2.4.37.

  • Php 7.2.14.

  • MySQL 5.7.24.

J'ai bien cree une nouvelle base de donnees que j'ai nome GLPI, aussi j'ai cree un nouvel utilisateur a qui j'ai attribue les meme droits que le root.
J'ai suivi la procedure d'installation decrite dans le document officiel que j'ai telecharge depuis le site de GLPI d'ou jai reproduit a la lettre la configuration du php.ini mais ca ne marche pas je reste toujours bloque a l'etape 3.

Pouvez vous me venir en aide SVP.
Je vous remercie par avance.

Last edited by Marouanec (2019-01-17 18:38:32)

Offline

#2 2019-01-21 11:37:32

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 15,184

Re: Installation GLPI avec Wampserver et windows7 x64 bloquee a l'etape 3

Quelles sont les erreurs exactes dans Apache ?


CentOS 6.5 - CentOS 7.x
PHP 5.6 - PHP 7.x - MySQL 5.6  - MariaDB 10.2 + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#3 2019-01-21 16:51:51

Marouanec
Member
Registered: 2019-01-17
Posts: 3

Re: Installation GLPI avec Wampserver et windows7 x64 bloquee a l'etape 3

ci-dessous le contenu de mon fichier appache_error.log :

PI: j'ai supprime le sous repertoire glpi du repertoire www et l'ai remis encore une fois puis relance l'installation de nouveau ==> toujours le meme resultat.
J'ai remerque que lerreur AH01630 revient a chaque fois.

[Wed Jan 16 16:14:58.667771 2019] [mpm_winnt:notice] [pid 8144:tid 428] AH00455: Apache/2.4.37 (Win64) PHP/7.2.14 configured -- resuming normal operations
[Wed Jan 16 16:14:58.667771 2019] [mpm_winnt:notice] [pid 8144:tid 428] AH00456: Apache Lounge VC15 Server built: Nov 21 2018 11:51:35
[Wed Jan 16 16:14:58.668771 2019] [core:notice] [pid 8144:tid 428] AH00094: Command line: 'c:\\wamp64\\bin\\apache\\apache2.4.37\\bin\\httpd.exe -d C:/wamp64/bin/apache/apache2.4.37'
[Wed Jan 16 16:14:58.705972 2019] [mpm_winnt:notice] [pid 8144:tid 428] AH00418: Parent: Created child process 6448
[Wed Jan 16 16:15:06.776735 2019] [mpm_winnt:notice] [pid 6448:tid 348] AH00354: Child: Starting 64 worker threads.
[Wed Jan 16 20:02:41.543244 2019] [authz_core:error] [pid 6448:tid 896] [client 10.100.10.185:5623] AH01630: client denied by server configuration: C:/wamp64/www/
[Thu Jan 17 00:02:32.270938 2019] [authz_core:error] [pid 6448:tid 896] [client 10.100.10.185:18669] AH01630: client denied by server configuration: C:/wamp64/www/
[Thu Jan 17 03:44:14.461803 2019] [mpm_winnt:notice] [pid 8144:tid 428] AH00422: Parent: Received shutdown signal -- Shutting down the server.
[Thu Jan 17 03:44:21.918616 2019] [mpm_winnt:notice] [pid 6448:tid 348] AH00364: Child: All worker threads have exited.
[Thu Jan 17 03:44:38.064645 2019] [mpm_winnt:notice] [pid 8144:tid 428] AH00430: Parent: Child process 6448 exited successfully.
[Thu Jan 17 08:12:07.107993 2019] [mpm_winnt:notice] [pid 1164:tid 436] AH00455: Apache/2.4.37 (Win64) PHP/7.2.14 configured -- resuming normal operations
[Thu Jan 17 08:12:07.108992 2019] [mpm_winnt:notice] [pid 1164:tid 436] AH00456: Apache Lounge VC15 Server built: Nov 21 2018 11:51:35
[Thu Jan 17 08:12:07.108992 2019] [core:notice] [pid 1164:tid 436] AH00094: Command line: 'c:\\wamp64\\bin\\apache\\apache2.4.37\\bin\\httpd.exe -d C:/wamp64/bin/apache/apache2.4.37'
[Thu Jan 17 08:12:07.129977 2019] [mpm_winnt:notice] [pid 1164:tid 436] AH00418: Parent: Created child process 6532
[Thu Jan 17 08:12:10.279771 2019] [mpm_winnt:notice] [pid 6532:tid 352] AH00354: Child: Starting 64 worker threads.
[Thu Jan 17 08:23:00.987136 2019] [authz_core:error] [pid 6532:tid 888] [client ::1:58130] AH01630: client denied by server configuration: C:/wamp64/www/glpi/files/_log/php-errors.log
[Thu Jan 17 12:05:51.490374 2019] [authz_core:error] [pid 6532:tid 892] [client 10.100.10.185:62171] AH01630: client denied by server configuration: C:/wamp64/www/
[Fri Jan 18 03:45:22.557004 2019] [mpm_winnt:notice] [pid 1164:tid 436] AH00422: Parent: Received shutdown signal -- Shutting down the server.
[Fri Jan 18 03:45:37.361430 2019] [mpm_winnt:notice] [pid 6532:tid 352] AH00364: Child: All worker threads have exited.
[Fri Jan 18 03:45:54.225060 2019] [mpm_winnt:notice] [pid 1164:tid 436] AH00431: Parent: Forcing termination of child process 6532
[Fri Jan 18 09:49:50.618618 2019] [mpm_winnt:notice] [pid 3460:tid 436] AH00455: Apache/2.4.37 (Win64) PHP/7.2.14 configured -- resuming normal operations
[Fri Jan 18 09:49:50.618618 2019] [mpm_winnt:notice] [pid 3460:tid 436] AH00456: Apache Lounge VC15 Server built: Nov 21 2018 11:51:35
[Fri Jan 18 09:49:50.618618 2019] [core:notice] [pid 3460:tid 436] AH00094: Command line: 'c:\\wamp64\\bin\\apache\\apache2.4.37\\bin\\httpd.exe -d C:/wamp64/bin/apache/apache2.4.37'
[Fri Jan 18 09:49:50.649819 2019] [mpm_winnt:notice] [pid 3460:tid 436] AH00418: Parent: Created child process 7164
[Fri Jan 18 09:49:52.745266 2019] [mpm_winnt:notice] [pid 7164:tid 352] AH00354: Child: Starting 64 worker threads.
[Fri Jan 18 09:50:54.719944 2019] [authz_core:error] [pid 7164:tid 864] [client ::1:51337] AH01630: client denied by server configuration: C:/wamp64/www/glpi/files/_log/php-errors.log
[Fri Jan 18 15:55:01.952484 2019] [authz_core:error] [pid 7164:tid 872] [client 10.100.10.191:50105] AH01630: client denied by server configuration: C:/wamp64/www/
[Fri Jan 18 15:55:10.741484 2019] [authz_core:error] [pid 7164:tid 872] [client 10.100.10.191:50108] AH01630: client denied by server configuration: C:/wamp64/www/share
[Fri Jan 18 15:55:14.415484 2019] [authz_core:error] [pid 7164:tid 872] [client 10.100.10.191:50108] AH01630: client denied by server configuration: C:/wamp64/www/share
[Fri Jan 18 15:55:18.728484 2019] [authz_core:error] [pid 7164:tid 872] [client 10.100.10.191:50108] AH01630: client denied by server configuration: C:/wamp64/www/share
[Fri Jan 18 15:55:22.895484 2019] [authz_core:error] [pid 7164:tid 872] [client 10.100.10.191:50108] AH01630: client denied by server configuration: C:/wamp64/www/share
[Sat Jan 19 03:43:44.428404 2019] [mpm_winnt:notice] [pid 3460:tid 436] AH00422: Parent: Received shutdown signal -- Shutting down the server.
[Sat Jan 19 03:43:55.722824 2019] [mpm_winnt:notice] [pid 7164:tid 352] AH00364: Child: All worker threads have exited.
[Sat Jan 19 03:44:15.378859 2019] [mpm_winnt:notice] [pid 3460:tid 436] AH00431: Parent: Forcing termination of child process 7164
[Mon Jan 21 09:26:16.004212 2019] [mpm_winnt:notice] [pid 6412:tid 436] AH00455: Apache/2.4.37 (Win64) PHP/7.2.14 configured -- resuming normal operations
[Mon Jan 21 09:26:16.004212 2019] [mpm_winnt:notice] [pid 6412:tid 436] AH00456: Apache Lounge VC15 Server built: Nov 21 2018 11:51:35
[Mon Jan 21 09:26:16.004212 2019] [core:notice] [pid 6412:tid 436] AH00094: Command line: 'c:\\wamp64\\bin\\apache\\apache2.4.37\\bin\\httpd.exe -d C:/wamp64/bin/apache/apache2.4.37'
[Mon Jan 21 09:26:16.021212 2019] [mpm_winnt:notice] [pid 6412:tid 436] AH00418: Parent: Created child process 3776
[Mon Jan 21 09:26:18.447212 2019] [mpm_winnt:notice] [pid 3776:tid 352] AH00354: Child: Starting 64 worker threads.
[Mon Jan 21 09:27:20.984212 2019] [authz_core:error] [pid 3776:tid 876] [client ::1:49514] AH01630: client denied by server configuration: C:/wamp64/www/glpi/files/_log/php-errors.log
[Mon Jan 21 09:27:26.990212 2019] [authz_core:error] [pid 3776:tid 880] [client ::1:49524] AH01630: client denied by server configuration: C:/wamp64/www/glpi/files/_log/php-errors.log
[Mon Jan 21 09:33:21.579212 2019] [authz_core:error] [pid 3776:tid 896] [client ::1:49631] AH01630: client denied by server configuration: C:/wamp64/www/glpi/files/_log/php-errors.log 

Merci d'avance.

Last edited by Marouanec (2019-01-21 17:19:47)

Offline

#4 2019-01-21 17:38:23

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 15,184

Re: Installation GLPI avec Wampserver et windows7 x64 bloquee a l'etape 3

Le message est assez claire je pense :  client denied by server configuration : C:/wamp64/www/glpi/files/_log/php-errors.log
GLPI ne peut pas écrire dans ces fichiers de log
Vérifiez que le dossier C:/wamp64/www/glpi/files/ ait bien Apache en propriétaire récursif.


CentOS 6.5 - CentOS 7.x
PHP 5.6 - PHP 7.x - MySQL 5.6  - MariaDB 10.2 + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#5 2019-01-21 18:00:09

Marouanec
Member
Registered: 2019-01-17
Posts: 3

Re: Installation GLPI avec Wampserver et windows7 x64 bloquee a l'etape 3

Merci bcp pour le retour rapid.
Toutefois pouvez vous me guider pour faire cette verification sous windows. je n'ai absolument aucune idee de comment la realiser.

Merci d'avance

Offline

#6 2019-12-01 01:21:48

radiojivatty
Member
Registered: 2019-12-01
Posts: 3

Re: Installation GLPI avec Wampserver et windows7 x64 bloquee a l'etape 3

Marouanec wrote:

Bonjour a tous,

Tout d'abord ne pretrez s'il vous plait pas attention a l'ortographe car j'utilise un clavier QWERTY donc pas d'accents smile.

Voila je me lance dans l'installation de GLPI et je suis bloque a l'etape 3:

===================
GLPI SETUP
     Step 3
Initialization of the database
===================

Pas de bouton continuer  pour passer a l'etape 4.

J'utilise:

  • Windows 7 X64.

  • wampserver3.1.7_x64.

  • Apache 2.4.37.

  • Php 7.2.14.

  • MySQL 5.7.24.

J'ai bien cree une nouvelle base de donnees que j'ai nome GLPI, aussi j'ai cree un nouvel utilisateur a qui j'ai attribue les meme droits que le root.
J'ai suivi la procedure d'installation decrite dans le document officiel que j'ai telecharge depuis le site de GLPI d'ou jai reproduit a la lettre la configuration du php.ini mais ca ne marche pas je reste toujours bloque a l'etape 3.

Pouvez vous me venir en aide SVP.
Je vous remercie par avance.

Quelles sont les erreurs exactes dans Apache

Offline

#7 2020-02-29 21:10:38

lionel70
Member
Registered: 2020-02-29
Posts: 1

Re: Installation GLPI avec Wampserver et windows7 x64 bloquee a l'etape 3

Bonjour,

J'ai rencontré le même problème de blocage à l'étape 3 avec GLPI 9.4.5, xampp 3.2.4, apache 2.4.4, mariaDB 10.4.6 et PHP 7.3.9 sur W10 64bits.

J'avais trouvé sur un forum d'installer en premier une version GLPI 9.2.3 et ensuite de faire une mise à jour. Nouvel échec : l'installation de la v9.2.3 se bloque aussi à l'étape 3. Ensuite , j'ai suivi le début de ce tuto wiki.glpi-project.org/doku.php?id=fr:install:gplixampp malheureusement non terminé mais qui indique de créer la base et l'utilisateur avant l'installation automatique : Miracle ça marche et l'installation se déroule sans problème.

Afin d'avoir une installation propre je recommence le process mais avec la version GLPI 9.4.5 et là de nouveau blocage à l'étape 3... donc retour la version GLPI 9.2.5 en suivant la procédure et ensuite mise à jour vers la version 9.4.5. Installation parfait et fonctionnement OK.

Rq importante : j'avais comme utilisateur "par défaut" de la base de données root sans mot de passe déjà existant. Si on prend cet utilisateur, il y a aussi blocage à l'étape 3. Il m'a fallu créer un utilisateur comme indiqué dans le tuto et non pas reprendre le root qui existait sur MariaDB. Je n'ai pas creusé plus loin ce problème.

En espérant que cela puisse aider.
Lionel

Last edited by lionel70 (2020-02-29 21:11:40)

Offline

Board footer

Powered by FluxBB