You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2005-05-17 11:42:06

ybardeau
Guest
Registered: 2005-05-17
Posts: 3

utilisation MS/ad - glpi sous debian

Bonjour, j'ai installé glpi sous debian et j'essaie en vain d' authentifier les utilisateurs référencés dans un active directory sous windows 2000 serveur :
domaine=chschs.fr
nom du win2ks=serveur-ad
nom du poste debian=serveur-glpi
utilisateur ad=utilisateur glpi dans l'uo informatique
LDAP configuration dans glpi:
Hote LDAP:ldap://serveur-ad.chschs.fr
Basedn:DC=chschs,DC=fr
rootdn:CN=utilisateur glpi,OU=informatique,DC=chschs,DC=fr
pass:mot depasse utilisé par l'utilisateur "utilisateur glpi" pour se connecter au domaine

dans ces conditions, quant je tente un login avec un utilisateur non référencé dans glpi, l'erreur suivante est retournée:

C'ANT CONTACT LDAP SERVER

C'ANT CONTACT LDAP SERVER
BAD USERNAME OR PASSWORD

quelqu'un a-t-il une solution à me proposer sachant que je n'ai rien trouvé dans le forum

merçi d'avance

Offline

#2 2005-05-20 13:23:12

Guillaume Mortier
Guest
From: Tergnier (02)
Registered: 2005-05-13
Posts: 8

Re: utilisation MS/ad - glpi sous debian

Bonjour,



dans ton Basedn, il faut que tu précises l'OU où se trouvent tes utilisateurs windows
n'oublie pas non plus de documenter les champs du bas de l'écran (liaisons GLPI/LDAP) comme suit :

name --> samaccountname
email --> mail
location --> physicaldeliveryofficename
phone --> telephonenumber
realname --> name

Comme ça, ça devrait marcher.



GM

Offline

#3 2005-05-23 14:47:28

ybardeau
Guest
Registered: 2005-05-17
Posts: 3

Re: utilisation MS/ad - glpi sous debian

Merci du tuyau guillaume ça marche
A+

Offline

#4 2005-06-09 15:18:42

jfbaulme
Guest
Registered: 2005-05-26
Posts: 4

Re: utilisation MS/ad - glpi sous debian

Bonjour,

J'ai le même problème mais moi les erreurs sont :

Invalid credentials

Invalid credentials
Bad username or password
.

Relogin

Mes infos à moi :

domaine=quetigny.epl
nom du win2ks=epl
nom du poste debian=intranet
utilisateur ad=utilisateur glpi dans l'uo administratif
LDAP configuration dans glpi:
Hote LDAP:ldap://epl.quetigny.epl
Basedn:DC=quetigny,DC=epl
rootdn:CN=utilisateur glpi,OU=administratif,DC=quetigny,DC=epl
pass:mot de passe utilisé par l'utilisateur "utilisateur glpi" pour se connecter au domaine

name : samaccountname
email : mail
location : physicaldeliveryofficename
phone : telephonenumber
realname : name

Dites moi ce que j'oublie ou que je loupe ?

Merci

@+

JF

Last edited by jfbaulme (2005-06-09 15:20:38)

Offline

#5 2005-06-09 17:17:28

Guillaume Mortier
Guest
From: Tergnier (02)
Registered: 2005-05-13
Posts: 8

Re: utilisation MS/ad - glpi sous debian

Bonjour JF,



je pense que tu as mauvais dans Basedn:DC=quetigny,DC=epl : ton basedn doit être une OU, celle sous laquelle se trouvent tes utilisateurs. Ne donner que le nom du domaine, c'est "trop haut" dans l'arbre LDAP.


Ce qui te donnarait un Basedn:OU=tous_mes_users,DC=quetigny,DC=epl


En espérant que ce soit ça.


A+

Guillaume.

Offline

#6 2005-06-29 11:17:00

ybardeau
Guest
Registered: 2005-05-17
Posts: 3

Re: utilisation MS/ad - glpi sous debian

problème authentification par serveur AD win2003 :
tous les utilisateurs de mon AD sont dans le CN Users et je n'arrive pas à utiliser l'authentification AD. Par contre on peut se logger sans problèmes à partir d'utilisateurs de test dans une UO.Dois-je déplacer tous mes utilisateurs dans une UO ou peut-on travailler dans mon CN Users  et comment ?
Merci d'avance

Offline

#7 2005-06-29 15:54:59

Belu
Guest
From: Lyon
Registered: 2005-05-10
Posts: 58
Website

Re: utilisation MS/ad - glpi sous debian

Moi j'avais le meme probleme et du coup j'ai créer une UO et hop résolue wink

Glpi sur serveur Debian et controleur de domaine 2003

Offline

Board footer

Powered by FluxBB