You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2019-11-20 14:38:17

Christophe11
Member
Registered: 2019-11-20
Posts: 1

erreur mise a jour fusioninventory

Bonjour,

je viens de mettre à jour GLPI. 9.1 >> 9.4.4. et du coup je dois mettre à jour le plugin fusioninventory. lors de l'installation, j'ai ce message d'erreur :

PHP Notice: mysqli::query(): in C:\wamp64\www\glpi\inc\dbmysql.class.php at line 181
PHP Warning: mysqli::query(): MySQL server has gone away in C:\wamp64\www\glpi\inc\dbmysql.class.php at line 181
PHP Warning: mysqli::query(): Error reading result set's header in C:\wamp64\www\glpi\inc\dbmysql.class.php at line 181

( ! ) Fatal error: Call to a member function bind_param() on boolean in C:\wamp64\www\glpi\plugins\fusioninventory\install\update.php on line 680
Call Stack
#    Time    Memory    Function    Location
1    0.0006    245440    {main}( )    ...\plugin.form.php:0
2    0.1354    10234272    call_user_func:{C:\wamp64\www\glpi\front\plugin.form.php:47} ( )    ...\plugin.form.php:47
3    0.1355    10234784    Plugin->install( )    ...\plugin.form.php:47
4    0.1537    11059728    plugin_fusioninventory_install( )    ...\plugin.class.php:521
5    0.6694    62755944    pluginFusioninventoryUpdate( )    ...\hook.php:849

je me suis reporté à la ligne pour le fichier update.php :
   foreach ($insert_data as $idata) {
         $stmt->bind_param(
            'ss',
            $idata[0],
            $idata[1]
         );
         $stmt->execute();

et la ligne 181 pour le fichier dbmysql.class.php :
$res = @$this->dbh->query($query);


si quelqu'un a une idée ....

Offline

#2 2019-12-02 11:49:54

dfeuilloy_metalis
Guest
Registered: 2013-02-04
Posts: 53

Re: erreur mise a jour fusioninventory

Bonjour,

Avez vous trouver la solution j'ai exactement la même erreur?


GLPI 9.4.4 FusionInventory 9.4+2.1
Apache/2.4.7 (Win32) mod_authnz_sspi/0.1.0 PHP/5.4.22, MySQL : 5.5.34
300 machines Windows avec l'agent Fusioninventory 2.5.1

Offline

Board footer

Powered by FluxBB