You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2019-04-11 16:37:34

Fortin
Guest
Registered: 2005-03-30
Posts: 9

Impossible de mettre à jour 9.4.0 vers 9.4.2

Bonjour,

Pour régler les problèmes de sécurité annoncés, j'ai téléchargé la dernière version 9.4.2.
J'ai procédé comme à l'habitude pour mettre à jour Glpi avec les bons droits pour /config et /files et plugins désactivés et rien ne se produit !
Que ce soit via le web ou en ligne de commande avec php install.php
J'ai juste le message sur la page d'accueil qui me demande de supprimer le fichier /install/install.php

Si vous avez une piste à creuser, je suis preneur !

Merci
Cordialement

Offline

#2 2019-04-11 16:44:36

Fortin
Guest
Registered: 2005-03-30
Posts: 9

Re: Impossible de mettre à jour 9.4.0 vers 9.4.2

J'ajoute qu'il n'y a aucune trace dans les logs attestant un problème particulier !

Offline

#3 2019-04-11 23:13:44

Jean-Christophe
Moderator
Registered: 2007-08-22
Posts: 347

Re: Impossible de mettre à jour 9.4.0 vers 9.4.2

Peut-être qu'il n'y a pas de mise à jour de DB entre la 9.4.0 et la 9.4.2... Du coup, pas besoin de l'assistant de mise à jour. Je ne sais pas hein! C'est juste une piste de réflexion.

Et dans le footer, quelle version est affichée après la mise à jour (silencieuse) ?

Offline

#4 2019-04-12 07:05:47

Fortin
Guest
Registered: 2005-03-30
Posts: 9

Re: Impossible de mettre à jour 9.4.0 vers 9.4.2

Bonjour,

Dans le footer reste l'info suivante :

GLPI 9.4.0 Copyright (C) 2015-2018 Teclib' and contributors
FusionInventory 9.4.0+1.0 - Copyleft © 2010-2019 by FusionInventory Team

et

Une nouvelle version est disponible : 9.4.2

Pour moi rien ne se produit et pourtant dans /install il y a bien les  update_940_941.php et  update_941_942.php
Même en ligne de commande rien ne s'active

Je vais tester avec les nouvelles commandes /bin/console apparues depuis la version 9.4.0 et voir ce que je peux obtenir comme comportement.

Merci

Offline

#5 2019-04-12 07:13:28

Fortin
Guest
Registered: 2005-03-30
Posts: 9

Re: Impossible de mettre à jour 9.4.0 vers 9.4.2

Voici ce que me donne la commande : bin/console db:update
Donc bien vu sur le fait que la DB ne nécessite pas de mise à jour :-)

root@xxxxxxx:/var/www/glpi# bin/console db:update
+-----------------------+-----------+-------+
|                       | Current   | Cible |
+-----------------------+-----------+-------+
| Database host         | localhost |       |
| Database name         | glpidb    |       |
| Database user         | root      |       |
| GLPI version          | 9.4.0     | 9.4.0 |
| GLPI database version | 9.4       | 9.4   |
+-----------------------+-----------+-------+
No migration needed.

Je ne comprends toujours pas le comportement de cette mise à jour vers 9.4.2 ?

Cordialement

Offline

#6 2019-09-04 17:00:24

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 15,053

Re: Impossible de mettre à jour 9.4.0 vers 9.4.2

Il y a des changements en base entre le 9.4.0 et la 9.4.2
Maois en 9.4 la mise à jour ne se fait plus pareil. Voir https://glpi-install.readthedocs.io/fr/ … ne-install


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

Board footer

Powered by FluxBB