You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2019-03-07 20:19:19

CLINIEUX
Member
Registered: 2019-03-07
Posts: 1

Installation de la version 9.4.0, ancienne 9.3.3

Bonjour à tous,

J'ai voulu installer la version 9.4.0 en lieu et place de la version 9.3.3 mais j'obtiens l'erreur : PHP Notice: Undefined index: dbversion in C:\xampp\htdocs\glpi\inc\config.php at line 214

Quelqu'un connait-il ce problème ? j'en serai enchanté
Je précise que j'ai supprimé toutes les tables et restauré par la sauvegarde SQL mais ça ne fonctionne pas mieux.

Merci de votre aide précieuse

Jean Clinieux

Last edited by CLINIEUX (2019-03-07 20:21:38)

Offline

#2 2019-03-08 00:47:55

LaDenrée
HELPER
Registered: 2012-11-19
Posts: 4,536

Re: Installation de la version 9.4.0, ancienne 9.3.3

bonjour,
est ce que votre base de données respecte les prérequis pour la version 9.4 ?

https://github.com/glpi-project/glpi#prerequisites


Trouver la panne avant de réparer...
*GLPI 9.1.6+fusion9.1+1.1+behaviours1.5.0+reports+fields+appliances+pdf+badges+formcreator2.5.2 PHP7.0 Mariadb10
*GLPI 9.4.2(behaviours2.2.1+fusioninventoty 9.4+1.1+applicatifs2.5.0+fields 1.9.1)hebergé sur serveur mutualisé.

Offline

#3 2019-03-22 12:25:11

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 14,930

Re: Installation de la version 9.4.0, ancienne 9.3.3

Vous ne pouvez pas restaurer une version 9.3.3 dans une base 9.4.

PHP Notice n'est pas une erreur mais une information.
Quelle est le message complet dans glpi/files/_log/php-error.log ?


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#4 2019-03-26 15:11:53

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 14,930

Re: Installation de la version 9.4.0, ancienne 9.3.3

Appliquer les corrections de la PR : https://github.com/glpi-project/glpi/pull/5685
et relancer la migration.


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#5 2019-05-07 13:25:12

John86
Member
Registered: 2019-05-07
Posts: 1

Re: Installation de la version 9.4.0, ancienne 9.3.3

D'accord, j'ai mis à jour étape par étape la version 9.4.0. Maintenant, j'ai le même problème. Je ne peux pas mettre à jour 9.4.0 à 9.4.1.1.
"La version de la base de données n’est pas compatible avec la version des fichiers installés. Une mise à jour est nécessaire."

Offline

#6 2019-05-10 10:05:38

LaDenrée
HELPER
Registered: 2012-11-19
Posts: 4,536

Re: Installation de la version 9.4.0, ancienne 9.3.3

ou trouvez vous vos sources ? vous utilisez bien le fichier .tgz  disponible sur GitHub
https://github.com/glpi-project/glpi/re … -9.4.2.tgz

vous devriez envisager le passage en 9.4.2 (  même fonctionnalités avec moins de bugs et sécurité améliorée)


Trouver la panne avant de réparer...
*GLPI 9.1.6+fusion9.1+1.1+behaviours1.5.0+reports+fields+appliances+pdf+badges+formcreator2.5.2 PHP7.0 Mariadb10
*GLPI 9.4.2(behaviours2.2.1+fusioninventoty 9.4+1.1+applicatifs2.5.0+fields 1.9.1)hebergé sur serveur mutualisé.

Offline

#7 2019-05-16 08:43:36

Kristi36
Member
Registered: 2019-05-14
Posts: 1

Re: Installation de la version 9.4.0, ancienne 9.3.3

You can not restore a 9.3.3 version to a 9.4 database.
PHP Notice is not an error but information.
What is the complete message in glpi / files / _log / php-error.log?

Last edited by Kristi36 (2019-05-16 08:46:28)

Offline

Board footer

Powered by FluxBB