You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2018-12-10 16:51:46

cutpeter56
Member
Registered: 2018-12-10
Posts: 1

Upload Document Impossible

Bonjour à toutes et tous.

Je viens d'installer GPLI 9.3.1 + Fusion Sur un 2016 Server avec Base MySQL.

Le GLPi est accessible. La liaison LDAP fonctionne. Le déploiement Fusion se fait petit à petit sur les postes.
Et j'ai aussi réussi à pimper mes notifications mail.

Par contre, il m'est impossible d'ajouter un document dans GLPI. Je voudrais le faire par exemple pour des Fiches support que j'ai rédigé, à destination des mes utilisateurs, afin qu'elles apparaissent dans la FAQ.

Lorsque je sélectionne mon document en cliquant sur parcourir et ouvrir, le document n'apparait pas.
Si je glisse le document dans l'espace prévu, j'ai le message suivant qui apparait :
Erreur de serveur
500 - Erreur interne au serveur.
La ressource que vous recherchez prsente un problme, elle ne peut donc pas tre affiche.

Tout le monde à les autorisations de modification sur mon dossier GLPI et les dossiers enfants.
J'avoue que je ne vois pas comment me dépatouiller. Je sèche complètement.

Merci de votre aide.
Cdt,
Pierre

Offline

#2 2018-12-20 11:09:54

Uniyannick
Guest
Registered: 2014-04-29
Posts: 441
Website

Re: Upload Document Impossible

Bonjour

As tu bien donné les droits sur le repertoire files dans glpi à tes utilisateur IIS ? modifier php.ini pour la taille des fichiers / vérifier les extensions autorisées dans documents

Bonne journée


Yannick

Prod : GLPI 9.3.2 - Windows 2012 - php 7.2 - mysql mariadb
Certifié ITIL V3, PMP - http://www.itamconsulting.com

Offline

#3 2018-12-28 11:35:01

MJPI
Member
Registered: 2018-12-10
Posts: 9

Re: Upload Document Impossible

Bonjour,

J'ai le même problème.
J'ai vérifié les ACL sur le répertoire files dans GLPI et j'ai mis "tout le monde" en contrôle total.
Ensuite dans le fichier php.ini l'option est bien active et j'ai bien 2M sur la taille de la pièce jointe.
Les extensions autorisés sont bien paramétré (par défaut).

Une personne a-t-il trouvé une solution ?

Last edited by MJPI (2018-12-28 11:35:31)


MJ
OS : Windows Server 2012 R2
IIS : 8.5.9600.16384 - PHP : 7.3.2 - MySQL : 8.0.13
GLPI : 9.4 - FusionInventory : 9.4.0+1.0

Offline

#4 2018-12-28 16:05:36

Uniyannick
Guest
Registered: 2014-04-29
Posts: 441
Website

Re: Upload Document Impossible

quelle extension de fichier utilises tu ?


Yannick

Prod : GLPI 9.3.2 - Windows 2012 - php 7.2 - mysql mariadb
Certifié ITIL V3, PMP - http://www.itamconsulting.com

Offline

#5 2018-12-28 16:06:42

Uniyannick
Guest
Registered: 2014-04-29
Posts: 441
Website

Re: Upload Document Impossible

as tu essayé avec d'autres fichiers ?


Yannick

Prod : GLPI 9.3.2 - Windows 2012 - php 7.2 - mysql mariadb
Certifié ITIL V3, PMP - http://www.itamconsulting.com

Offline

#6 2018-12-28 16:07:58

Uniyannick
Guest
Registered: 2014-04-29
Posts: 441
Website

Re: Upload Document Impossible

as tu enlevé l'extension apcu dans php.ini ?


Yannick

Prod : GLPI 9.3.2 - Windows 2012 - php 7.2 - mysql mariadb
Certifié ITIL V3, PMP - http://www.itamconsulting.com

Offline

#7 2019-01-07 16:43:56

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 14,842

Re: Upload Document Impossible

C'est GLPI qui charge le document donc le dossier files doit avec Apache en propriétaire récursif


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#8 2019-01-17 10:28:44

MJPI
Member
Registered: 2018-12-10
Posts: 9

Re: Upload Document Impossible

Bonjour,

Avant de commencer, je tiens à souhaiter une excellente année aux membres de ce forum !

Tout d'abord, il s'agit d'un serveur sous IIS, puis j'ai bien mis le groupe IUSR en accès total, propriétaire du répertoire GLPI et ce en mode récursif.

Cela ne fonctionne toujours pas.

Avez-vous une solution à me proposer ?

Bien à vous,


MJ
OS : Windows Server 2012 R2
IIS : 8.5.9600.16384 - PHP : 7.3.2 - MySQL : 8.0.13
GLPI : 9.4 - FusionInventory : 9.4.0+1.0

Offline

#9 2019-01-17 11:18:05

MJPI
Member
Registered: 2018-12-10
Posts: 9

Re: Upload Document Impossible

Veuillez trouver ci-dessous la configuration du serveur GLPI:

Informations sur le système, l'installation et la configuration

 
GLPI 9.3.3 ( => C:\GLPI)
Installation mode: TARBALL

Server

 
Operating system: Windows NT MAINTENANCE 6.3 build 9600 (Windows Server 2012 R2 Standard Edition) AMD64
PHP 7.2.7 cgi-fcgi (Core, PDO, Phar, Reflection, SPL, SimpleXML, bcmath, calendar, cgi-fcgi, ctype, curl, date, dom, fileinfo,
	filter, gd, hash, iconv, imap, json, ldap, libxml, mbstring, mysqli, mysqlnd, openssl, pcre, readline, session, standard,
	tokenizer, wddx, xml, xmlreader, xmlrpc, xmlwriter, zip, zlib)
Setup: max_execution_time="600" memory_limit="128M" post_max_size="8M" safe_mode="" session.save_handler="files"
	upload_max_filesize="2M" 
Software: Microsoft-IIS/8.5
	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0
Server Software: MySQL Community Server - GPL
	Server Version: 8.0.13
	Server SQL Mode: 
	Parameters: root@localhost/glpi
	Host info: localhost via TCP/IP
	
mysqli extension is installed
ctype extension is installed
fileinfo extension is installed
json extension is installed
mbstring extension is installed
zlib extension is installed
curl extension is installed
gd extension is installed
simplexml extension is installed
xml extension is installed
ldap extension is installed
imap extension is installed
xmlrpc extension is installed
Zend OPcache extension is not present
APCu extension is not present
CAS extension is not present
Database version seems correct (8.0.13) - Perfect!Database version seems correct (8.0.13) - Perfect!
OKC:\GLPI/files/_log : OK
OKC:\GLPI/config : OK
OKC:\GLPI/files : OK
OKC:\GLPI/files/_dumps : OK
OKC:\GLPI/files/_sessions : OK
OKC:\GLPI/files/_cron : OK
OKC:\GLPI/files/_graphs : OK
OKC:\GLPI/files/_lock : OK
OKC:\GLPI/files/_plugins : OK
OKC:\GLPI/files/_tmp : OK
OKC:\GLPI/files/_cache : OK
OKC:\GLPI/files/_rss : OK
OKC:\GLPI/files/_uploads : OK
OKC:\GLPI/files/_pictures : OK
Web access to the files directory should not be allowed but this cannot be checked automatically on this instance.
Make sure acces to error log file is forbidden; otherwise review .htaccess file and web server configuration.

Libraries

 
htmLawed version 1.2.4 in (C:\GLPI\lib\htmlawed)
SimplePie version 1.5.2 in (C:\GLPI\vendor\simplepie\simplepie\library)
TCPDF version 6.2.25 in (C:\GLPI\vendor\tecnickcom\tcpdf)
michelf/php-markdown in (C:\GLPI\vendor\michelf\php-markdown\Michelf)
true/punycode in (C:\GLPI\vendor\true\punycode\src)
iacaml/autolink in (C:\GLPI\vendor\iamcal\lib_autolink)
sabre/vobject in (C:\GLPI\vendor\sabre\vobject\lib)

LDAP directories

 
Server: 'XXXXXX', Port: '389', BaseDN: 'dc=XXX,dc=XXXX', Connection filter:
		'(&(objectClass=user)(objectCategory=person)(!(userAccountControl:1.2.840.113556.1.4.803:=2)))', RootDN: 'XXXXXX', Use
		TLS: none

SQL replicas

 
Not active

Notifications

 
Way of sending emails: SMTP (xxxxxxxx)

Mails receivers

 

Plugins list

 
	behaviors            Name: Comportements                  Version: 2.1.1      State: Enabled
	formcreator          Name: Forms                          Version: 2.7.0-beta.1 State: Enabled
	fusioninventory      Name: FusionInventory                Version: 9.3+1.3    State: Enabled
	mreporting           Name: More Reporting                 Version: 1.5.3      State: Enabled
	reports              Name: Rapports                       Version: 1.12.0     State: Enabled

A copier/coller dans vos demandes d'assistance


MJ
OS : Windows Server 2012 R2
IIS : 8.5.9600.16384 - PHP : 7.3.2 - MySQL : 8.0.13
GLPI : 9.4 - FusionInventory : 9.4.0+1.0

Offline

#10 2019-01-25 16:40:53

MJPI
Member
Registered: 2018-12-10
Posts: 9

Re: Upload Document Impossible

Je relance ce sujet, une personne du forum pourrait-il m'aider ?


MJ
OS : Windows Server 2012 R2
IIS : 8.5.9600.16384 - PHP : 7.3.2 - MySQL : 8.0.13
GLPI : 9.4 - FusionInventory : 9.4.0+1.0

Offline

#11 2019-01-29 10:26:51

kbaudoux
Member
Registered: 2018-12-28
Posts: 12

Re: Upload Document Impossible

J'ai exactement le même problème. Impossible de télécharger un document, même un fichier .ocs pour fusion.
Tout bloque et pourtant tout les droits semble donné.

Et en passant par un serveur Appache, j'obtiens ce message en plus :
Test du bbcode FluxBB

Mais mon entreprise préfère passer par IIS si possible.

Offline

#12 2019-02-11 09:05:17

Uniyannick
Guest
Registered: 2014-04-29
Posts: 441
Website

Re: Upload Document Impossible

BOnjour

pour ma part
iis_usrs rw
iusr rw


Yannick

Prod : GLPI 9.3.2 - Windows 2012 - php 7.2 - mysql mariadb
Certifié ITIL V3, PMP - http://www.itamconsulting.com

Offline

#13 2019-02-14 16:32:09

rreglpimc
Guest
Registered: 2018-02-09
Posts: 48

Re: Upload Document Impossible

kbaudoux wrote:

J'ai exactement le même problème. Impossible de télécharger un document, même un fichier .ocs pour fusion.
Tout bloque et pourtant tout les droits semble donné.

Et en passant par un serveur Appache, j'obtiens ce message en plus :
https://image.noelshack.com/fichiers/20 … erreur.png

Mais mon entreprise préfère passer par IIS si possible.

@kbaudoux
A priori d'après le message d'erreur ton glpi tente d'écrire dans C:\windows\temp au lieu de son propre dossier, ça pourrait être l'origine de ton soucis. Peut être une variable d'environnement pas à jour, en tout cas ça pourrait expliquer ton soucis d'upload


@MJPI
est ce que tu as des erreurs dans les log glpi ? (log php ou autre)

Offline

#14 2019-02-14 18:14:28

Oli.be
Member
Registered: 2019-02-14
Posts: 2

Re: Upload Document Impossible

Bonjour,
Comme pour le précédent ticket,

j'ai eu un souci similaire sour windows et iis
j'ai du changer le répertoire temporaire dans php.ini
en : upload_tmp_dir =C:\GLPI\0.9.3\files\_tmp\
restart, et c'est ok

Offline

#15 2019-02-15 19:11:31

MJPI
Member
Registered: 2018-12-10
Posts: 9

Re: Upload Document Impossible

Oli.be wrote:

Bonjour,
Comme pour le précédent ticket,

j'ai eu un souci similaire sour windows et iis
j'ai du changer le répertoire temporaire dans php.ini
en : upload_tmp_dir =C:\GLPI\0.9.3\files\_tmp\
restart, et c'est ok


MERCIIIIIIIIIII ............!

Enfin une personne qui a su répondre au problème !


MJ
OS : Windows Server 2012 R2
IIS : 8.5.9600.16384 - PHP : 7.3.2 - MySQL : 8.0.13
GLPI : 9.4 - FusionInventory : 9.4.0+1.0

Offline

#16 2019-02-23 14:51:26

Tripland
Member
Registered: 2019-02-04
Posts: 4

Re: Upload Document Impossible

yllen wrote:

C'est GLPI qui charge le document donc le dossier files doit avec Apache en propriétaire récursif


Essai de le faire de façon manuelle en donnant les droits d'accès à ton serveur sous IIS ou répertoire file.

Offline

Board footer

Powered by FluxBB