You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2018-12-07 17:56:52

lascar
Member
Registered: 2018-12-07
Posts: 1

Migration GLPI de 9.2.1 en 9.3.3

Bonjour,

je patauge depuis quelques heures...

Mon infra, migration effectuée sur le serveur de TEST pour l'instant...

[root@srv-glpi-ocs-02 glpi]# cat /etc/redhat-release
CentOS Linux release 7.6.1810 (Core)

[root@srv-glpi-ocs-02 glpi]# php -v
PHP 5.6.38 (cli) (built: Sep 15 2018 08:16:33)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
    with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2016, by Zend Technologies

[root@srv-glpi-ocs-02 glpi]# mysql --version
mysql  Ver 15.1 Distrib 10.3.11-MariaDB, for Linux (x86_64) using readline 5.1
[root@srv-glpi-ocs-02 glpi]#

Donc à jour, il me semble pour l'essentiel...

Comme recommandé dans la doc, voici les étapes réalisées:

- Migration Mariadb en 10.3.11 effectuée
- cd /opt && wget --> sur le git officiel
- service httpd stop
- tar xvf glpi-9.3.3.tgz
- chown -R apache:apache glpi
- service httpd start
--> il n'est plus possible d'effectuer la mise à jour depuis l'interface web ?

pas grave, lancé par le script:

[root@srv-glpi-ocs-02 glpi]# php scripts/cliupdate.php
Config::getCache() in /opt/glpi/inc/config.class.php line 2985
Service with name "Zend\Cache\Storage\Adapter\Apc" could not be created. Reason: ext/apc is disabled - see 'apc.enabled' and 'apc.enable_cli' Database version seems correct (10.3.11) - Perfect!
Current GLPI version         : 9.2.1
New GLPI version             : 9.3.3
Current GLPI database version: 9.2.1
New GLPI database version    : 9.3.2
Default GLPI Language        : fr_FR

========================================= Update to 9.2.2 ==========================================
Task completed. (0 seconds)
========================================= Update to 9.2.2 ==========================================
Task completed. (0 seconds)
========================================= Update to 9.2.3 ==========================================
Task completed. (0 seconds)
========================================== Update to 9.3 ===========================================
** New rights has been added for datacenter, you should review ACLs after update
Configuration values added for purge_computer_software_install, purge_software_computer_install, purge_software_version_install, purge_infocom_creation, purge_profile_user, purge_group_user, purge_adddevice, purge_updatedevice, purge_deletedevice, purge_connectdevice, purge_disconnectdevice, purge_userdeletedfromldap, purge_addrelation, purge_deleterelatTask completed. (4 seconds)                                                                         datemod, purge_all, purge_user_auth_changes, purge_plugins. (4 seconds)
========================================= Update to 9.3.1 ==========================================
Task completed. (4 seconds)
========================================= Update to 9.3.2 ==========================================
Task completed. (4 seconds)
Migration Done.
[root@srv-glpi-ocs-02 glpi]#


Ok, comme une lettre à la poste semble-il ...

Mais lorsque je lance l'interface web, celà me dit:
-->
Vous tentez d'utiliser GLPI avec des fichiers d'une version antérieure à la version de la base de données. Veuillez installer les fichiers GLPI dans la version correspondante à votre base de données..
De plus, le bandeau en bas de page me signale toujours la version 9.2.1 ...

la page de check me signale uniquement ce warning:
L'accès web au répertoire des fichiers ne devrait pas être autorisé
Vérifier le fichier .htaccess et la configuration du serveur web


Alors que j'ai décompressé l'archive 9.3.3 et que j'ai lancé le script depuis le nouveau répertoire...
Il y a bien un bouton en bas de la page "réessayer" mais ça ne vas pas plus loin.

si je relance le script:

[root@srv-glpi-ocs-02 glpi]# php scripts/cliupdate.php
Config::getCache() in /opt/glpi/inc/config.class.php line 2985
Service with name "Zend\Cache\Storage\Adapter\Apc" could not be created. Reason: ext/apc is disabled - see 'apc.enabled' and 'apc.enable_cli' Database version seems correct (10.3.11) - Perfect!
Current GLPI version         : 9.3.3
New GLPI version             : 9.3.3
Current GLPI database version: 9.3.2
New GLPI database version    : 9.3.2
Default GLPI Language        : fr_FR
No migration needed.
[root@srv-glpi-ocs-02 glpi]#

Je ne peux tout simplement pas aller plus loin, ni avec le script, ni via l'interface web


il semble que la BD ait été migrée correctement mais que le programme GLPI ne soit pas à jour...
Pourtant récupéré dans un dépôt officiel...

Je sais bien que ce problème a été relaté des dizaines de fois sur le web, mais je ne vois pas ce qui est faux !
J'ai bien sûr vérifié les droits sur les répertoires et c'est apache:apache pour toute l'arborescence...

l'erreur suivante est-elle fatale à la bonne exécution du programme ?
Service with name "Zend\Cache\Storage\Adapter\Apc" could not be created. Reason: ext/apc is disabled - see 'apc.enabled' and 'apc.enable_cli'

Et je n'arrive pas à trouver comment configurer cette satanée option, dans un 1er temps pour désactiver le message d'erreur...

Auriez-vous une idée ?

D'avance, merci pour votre aide

Jean

Offline

Board footer

Powered by FluxBB