You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2018-07-12 16:18:56

jlb59
Guest
From: Valenciennes
Registered: 2008-07-29
Posts: 99

probléme connexion moniteur/ordinateur

Bonjour


Je viens de voir un probléme de mise à jour au niveau de l'onglet connexion d'un ordinateur dans GLPI .


Explication :


Un moniteur branché sur un ordinateur XXX puis débranché et branché sur un autre ordinateur YYY ne remonte pas sur ce dernier!

mais reste branché sur l'ancien (XXX) .


Au niveau OCS le moniteur apparait bien branché sur YYY ..! mais rien ne change après un nouvel  import  automatique OCS/GLPI; le moniteur est toujours affecter dans glpi à XXX


Seul  la synchronisation manuel permets de mettre à jour cette connexion.


Plutot gênant !

Merci pour vos réponses

Cordialement


890000 tickets, 100000 pc et serveurs, 36000 utilisateurs
REDHAT 7.3 sur ESX vmware, glpi 9.1.7.1, OCS 2.3.1
Plugin : Import OCSNG,  Injection de fichiers , Impression pdf , uninstal,  rapport, comportement, purge de l’historique, gestion des baies.

Offline

#2 2018-09-19 14:54:26

jrope
Guest
Registered: 2018-09-19
Posts: 1

Re: probléme connexion moniteur/ordinateur

Bonjour,

J'ai travaillé sur ce sujet pour jlb59 et reproduis le problème avec la version :
OCS : 2.3.1
GLPI : 9.1.7.1
Plugin : 1.3.5

J'ai également reproduit ce problème avec la configuration suivante :
OCS : 2.5
GLPI : 9.3
Plugin : 1.5.2

Dans les deux configurations, le problème est le même : l'écran est débranché d'une machine A et branché sur une machine B. OCS voit bien le changement, mais GLPI ne le voit pas.
Par contre j'ai noté une situation ou l'information remontait correctement : lorsque l'inventaire de A est remonté dans GLPI avant l'inventaire de B. Dans ce cas, le changement est pris en compte par GLPI.

Le problème se règle en forçant une synchronisation de la machine B dans GLPI. Forcer la synchronisation de la machine A ne fonctionne pas.

  Je note par ailleurs qu'un problème similaire avait été remonté l'année dernière, mais que l'investigation n'avait pas aboutit suite au changement de logiciel inventoring :
https://forum.glpi-project.org/viewtopic.php?id=158051
J'ai essayé de suivre les pistes évoquées dans cette discussion, sans succès. En réponse aux questions qui y sont posées : Le fichier XML remonté dans OCS contient bien les moniteurs, et OCS rapporte bien ces changements dans son interface.

Dans mes environnements, j'ai paramétré le plugin pour que l'import des moniteurs se fasse selon l'option "import unique sur numéro de série".
J'ai également choisi l'option d'importation : "Comportement lors de la déconnexion : supprimer définitivement", en pensant qu'un lien pouvait subsister qui empêcherait le moniteur de changer d'ordinateur, mais je n'ai pas vu de changement.

Y a-t-il d'autres options qui nécessitent d'être mise en place ?
Quels autres tests pouvons-nous faire pour essayer de corriger ce problème ?

Cordialement

Offline

Board footer

Powered by FluxBB