You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2018-09-06 10:23:09

MailysLB
Guest
Registered: 2018-09-05
Posts: 1

Problème d'initialisation de session avec un compte interne à GLPI

Bonjour,

Je souhaiterais accéder à l'API de GLPI grâce à un compte interne afin de créer un ticket.
GLPI a été configuré avec le SSO.

Lorsque je fais appel à initSession avec un compte réseau, pas de problème (je récupère bien la session_token).
Mais quand je le fais avec un compte interne à GLPI, j'ai l'erreur 401 qui apparait.

Le compte interne est activé et j'arrive bien à me connecter sur le site.

Voici les logs de GLPI :
[Wed Sep 05 15:13:17.074569 2018] [authz_core:debug] [pid 16363] mod_authz_core.c(809): [client 172.22.12.63:50127] AH01626: authorization result of <RequireAny>: granted
[Wed Sep 05 15:13:17.103683 2018] [authz_core:debug] [pid 16363] mod_authz_core.c(809): [client 172.22.12.63:50127] AH01626: authorization result of Require valid-user : denied (no authenticated user yet)
[Wed Sep 05 15:13:17.103706 2018] [authz_core:debug] [pid 16363] mod_authz_core.c(809): [client 172.22.12.63:50127] AH01626: authorization result of <RequireAny>: denied (no authenticated user yet)
[Wed Sep 05 15:13:17.103724 2018] [auth_kerb:debug] [pid 16363] src/mod_auth_kerb.c(1971): [client 172.22.12.63:50127] kerb_authenticate_user entered with user (NULL) and auth_type Kerberos
[Wed Sep 05 15:13:17.107276 2018] [authz_core:debug] [pid 16363] mod_authz_core.c(809): [client 172.22.12.63:50127] AH01626: authorization result of Require valid-user : denied (no authenticated user yet)
[Wed Sep 05 15:13:17.107292 2018] [authz_core:debug] [pid 16363] mod_authz_core.c(809): [client 172.22.12.63:50127] AH01626: authorization result of <RequireAny>: denied (no authenticated user yet)
[Wed Sep 05 15:13:17.107304 2018] [auth_kerb:debug] [pid 16363] src/mod_auth_kerb.c(1971): [client 172.22.12.63:50127] kerb_authenticate_user entered with user (NULL) and auth_type Kerberos
[Wed Sep 05 15:13:17.110155 2018] [auth_kerb:debug] [pid 16363] src/mod_auth_kerb.c(1722): [client 172.22.12.63:50127] Verifying client data using KRB5 GSS-API
[Wed Sep 05 15:13:17.110804 2018] [auth_kerb:debug] [pid 16363] src/mod_auth_kerb.c(1738): [client 172.22.12.63:50127] Client delegated us their credential
[Wed Sep 05 15:13:17.111262 2018] [authz_core:debug] [pid 16363] mod_authz_core.c(809): [client 172.22.12.63:50127] AH01626: authorization result of Require valid-user : granted


Si quelqu'un connait la manipulation pour désactiver le SSO ou une configuration qui le permet...

Merci de votre aide !

Offline

Board footer

Powered by FluxBB