You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2018-06-25 10:33:25

flavien-dubois
Guest
Registered: 2018-06-21
Posts: 6

injecter / importer une base SQL

Bonjour à toutes et à tous.

J'ai une base SQL de glpi version 0.84 qui fait 256 Mo et j'aimerai tenter une migration vers la dernière bouture de glpi mais je n'arrive pas à importer ma base.

J'ai beau suivre des tutos pour augmenter les limitations mise en place par SQL rien n'y fait.

Quelqu'un aurait il une idée?

Offline

#2 2018-06-25 10:57:52

LaDenrée
HELPER
Registered: 2012-11-19
Posts: 4,084

Re: injecter / importer une base SQL

Bonjour,
quel type de serveur ? linux windows ?
quel type de base de données Mysql ? mariadb ?

avez vous pu faire un dump de la base 0.84 ?


Trouver la panne avant de réparer...
*GLPI 9.1.6+fusion9.1+1.1+behaviours1.5.0+reports+fields+appliances+pdf+badges+formcreator2.5.2 PHP7.0 Mariadb10
*GLPI 9.2.4(behaviours1.5.2+fusion9.2+1.0+applicatifs2.3.0+dashboard 0.8.9)hebergé sur serveur mutualisé.
*GLPI 9.3  en test (ubuntu 16.04 mariadb 10.2.4) (attente 9.3.1 et plugin compatible avant mise en prod)

Offline

#3 2018-06-25 14:54:41

flavien-dubois
Guest
Registered: 2018-06-21
Posts: 6

Re: injecter / importer une base SQL

bonjour et merci par avance.

quel type de serveur ? linux windows ? > VM sur Windows Server 2012 R2

quel type de base de données Mysql ? mariadb ? > Mysql

avez vous pu faire un dump de la base 0.84 ? Le dump crash sur GLPI directement j'ai du passer par myphpadmin (c'est un XAMPP qui fait tourner le tout)

Offline

#4 2018-06-28 19:09:34

LaDenrée
HELPER
Registered: 2012-11-19
Posts: 4,084

Re: injecter / importer une base SQL

je ne connais pas la taille limite avec phpmyadmin pour les dumps et restaurations mais ça ne marche pas quand la base est trop grosse;

vous pouvez creer un dump directement en ligne de commande :
vérifiez que les prérequis de votre nouvelle version sont ok avec votre config.

backup: # mysqldump -u root -p[root_password] [database_name] > dumpfilename.sql

    restore:# mysql -u root -p[root_password] [database_name] < dumpfilename.sql


Trouver la panne avant de réparer...
*GLPI 9.1.6+fusion9.1+1.1+behaviours1.5.0+reports+fields+appliances+pdf+badges+formcreator2.5.2 PHP7.0 Mariadb10
*GLPI 9.2.4(behaviours1.5.2+fusion9.2+1.0+applicatifs2.3.0+dashboard 0.8.9)hebergé sur serveur mutualisé.
*GLPI 9.3  en test (ubuntu 16.04 mariadb 10.2.4) (attente 9.3.1 et plugin compatible avant mise en prod)

Offline

Board footer

Powered by FluxBB