You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#26 2017-04-12 07:23:43

bzh
Member
Registered: 2016-09-25
Posts: 400

Re: Le cron GLPI ne fonctionne pas, voir documentation

Tu as combien de plugin actif et les quels ?


Virtual Box \ Ubuntu 20.4  \ GLPI 9.5.3

Offline

#27 2017-04-12 07:38:09

Glpi_Gti
Member
Registered: 2017-04-10
Posts: 16

Re: Le cron GLPI ne fonctionne pas, voir documentation

Bonjour,

Rien , aucun autre plugin, juste FusionInventory je ne veux justement pas installer d'autres modules tant que le Glpi/Fi n'est pas
100 % opérationnel. Je voulais justement évité d'éventuelle interaction.
Conf vraiment très simple.
Un OS (win7 pro a jour)
Wampserver et notepad++
Glpi+FI et voila rien d'autre.
Une seule modif sur l'OS - Pare-feu:ouverture du flux entrant et sortant pour le port 80 car sans ça rien ne passait.
Tu vois rien que du basique.
La première semaine tout Ok - La seconde apparition du message - La seule différence entre les deux semaines 30 Pc de plus de remonté - J'ai supprimé toute tâche interne afin que cela n'interfère pas sur le reste; Voilà pour l'instant ou j'en suis.
Je vais de nouveau fouiller dans les logs voir si je n'ai pas loupé quelque chose.
Cdlt

Offline

#28 2017-04-12 08:15:11

bzh
Member
Registered: 2016-09-25
Posts: 400

Re: Le cron GLPI ne fonctionne pas, voir documentation

Salut,

Tu as que celui là?

donc tu fait la sauvegarde puis relacer le plugin et tu as le pb cron

Un plugin qui ne mange pas de pain c'est impression pdf

Last edited by bzh (2017-04-12 08:19:17)


Virtual Box \ Ubuntu 20.4  \ GLPI 9.5.3

Offline

#29 2017-04-12 08:23:15

bzh
Member
Registered: 2016-09-25
Posts: 400

Re: Le cron GLPI ne fonctionne pas, voir documentation

pour le port je croit que c'est le  62354?

je ne suis pas sûr a vérifier


Virtual Box \ Ubuntu 20.4  \ GLPI 9.5.3

Offline

#30 2017-04-12 15:47:56

Glpi_Gti
Member
Registered: 2017-04-10
Posts: 16

Re: Le cron GLPI ne fonctionne pas, voir documentation

Je ne connaissais pas ce port 62354 je l'ai donc activé dans mon parefeu, j'ai tout redémarré mais rien y fait.

J'ai creusé les log du TaskScheduler pour voir l’exécution du cron, Crosoft est plutôt sympas pour lui tout ce passe bien et il m'indique un code retour 0.
Dans les logs Crosoft je n'ai pas trouvé d'erreurs non plus.
Du coup , qu'elle est le module que doit indiquer cette info a FI ??? c'est peut-être du côté là qu'il faudrait creuser mais là, si c'est le cas je ne vois pas où chercher.

Je vais voir si mon ami google peut m'aider;

Offline

#31 2017-04-12 15:58:10

ddurieux
Plugins Dev
From: Propières, France
Registered: 2005-06-17
Posts: 7,521

Re: Le cron GLPI ne fonctionne pas, voir documentation

C'est le 'taskscheduler' dans la liste des actions automatiques.

je viens de voir t'as mis  Mysql 5.7.14, c'est pas compatible avec GLPI la version 5.7....


Support / dev / installation / configuration GLPI : dcs.glpi@dcsit-group.com
DCS : expert GLPI & FusionInventory / Développeur du plugin FusionInventory
IRC #glpi sur freenode.net

Offline

#32 2017-04-12 16:02:00

bzh
Member
Registered: 2016-09-25
Posts: 400

Re: Le cron GLPI ne fonctionne pas, voir documentation

J'ai ps trop fait gaffe, mais toi tu es sous Win7 sous machine virtuel et non Linux

Donc dans ta table cron du ne devrais pas avoir a modifier quoique ce soit !


Virtual Box \ Ubuntu 20.4  \ GLPI 9.5.3

Offline

#33 2017-04-13 07:26:52

Glpi_Gti
Member
Registered: 2017-04-10
Posts: 16

Re: Le cron GLPI ne fonctionne pas, voir documentation

Bonjour,

Le soleil se présente en cette nouvelle journée de recherche.
Effectivement j'ai bien Mysql 5.7.14 car il est packagé dans la version 3.0.6 de Wampserver.
Je vais cherché une ancienne version et je vous fais un retour à l'issue.

Merci du retour.

Offline

#34 2017-04-18 10:36:19

Glpi_Gti
Member
Registered: 2017-04-10
Posts: 16

Re: Le cron GLPI ne fonctionne pas, voir documentation

Bonjour,

Après ce week end chocolaté je reviens avec une modif majeur suite au conseil de l'ami DDURIEUX au sujet d'un pb de compatibilité FI avec MySql 5.7.14.
Nouvelle config :
Machine sous Win 7 pro 64
     Virtualbox 5.1.8
          Image virtuel win7 pro
          Installation de Wampserver 2.5
                               Apache 2.4.9
                               Php 5.5.12
                               Mysql 5.6.17
Puis mise en place de Glpi 9.1.2+FusionInventory 9.1+1.0
Je suis reparti de Zéro et j'ai tout remonté - Sur ma Vm j'ai ajouté 3 applis - Firefox 52 ESR, 7Zip et Notepad++
Rien d'autre (même pas un antivirus ..... pour l'instant  j'en installerai un fois tout validé).
Pas d'autre plugin que FI.

Pour l'instant je n'ai plus le message "Le cron Glpi ne fonctionne pas voir documentation" ce qui parait être une bonne nouvelle, mais je reste en observation car la dernière fois le message est apparu après 1 semaine sans autres modifs.

Je reste en observation, je vais monter mon lien Ldap et continuer a creuser l'utilisation de FI+Glpi;
Si Pb ré-apparait je vous tiendrais informé.
Merci à vous et je croise les doigts.

Offline

#35 2017-04-18 13:44:55

max59
Member
From: Lille
Registered: 2016-03-04
Posts: 25

Re: Le cron GLPI ne fonctionne pas, voir documentation

Bonjour,

Le pansement de ce problème à faire tous les lundis pour nous :

- Désactiver la tâche planifiée sous windows puis la réactiver...


- Windows Serveur 2012 en virtuel
- Wamp 2.5
- GLPI 9.1.1
- plugin FusionInventory 9.1+1.1 // plugin DataInjection 2.4.1

Offline

#36 2017-04-18 16:01:21

Glpi_Gti
Member
Registered: 2017-04-10
Posts: 16

Re: Le cron GLPI ne fonctionne pas, voir documentation

Bonjour,

Merci du retour d'expérience.

Si c'est mon cas avec ma nouvelle installe (sur l'ancienne cela ne marchait pas car j'avais testé la désactivation puis la réactivation de la tâche planifié) je le préciserai à la suite pour que cela puisse aider d'autre personne dans la même situation.

Mais tant qu'avoir des Pbs depuis ma nouvelle installe je n'ai plus le bouton "Configuration==> Authentification==> Annuaire Ldap"
cela fait environ 3 heures que je suis dessus.
Lors de mon autre installe j'ai mis 3mn a configurer mon annuaire Ldap et là,  je n'ai plus le bouton, pourtant dans mon php.ini la ligne "extension=php_ldap.dll" est bien décommentée comme précisé dans la doc.

J'aime les casses têtes mais là....

Offline

#37 2017-04-18 16:16:52

LaDenrée
HELPER
Registered: 2012-11-19
Posts: 5,207

Re: Le cron GLPI ne fonctionne pas, voir documentation

@gti_gti
dans configuration>generale>systeme avez vous une indication sur la section LDAP directories ? (entre libraries et mysql replicas)


Trouver la panne avant de réparer...
*GLPI 9.4.6+fusion9.4+2.4+behaviours2.3.2+reports+fields+appliances+pdf+badges+formcreator2.10.4 PHP7.4 Mariadb10.3
*GLPI 9.4.6(behaviours2.2.1+fusioninventoty 9.4+1.1+applicatifs2.5.0+fields 1.9.1) php7.3 mysql5.6 hebergé sur serveur mutualisé.
TEST GLPI9.5.3 mutualisé OVH (  collecteur KO  en pop3)

Offline

#38 2017-04-19 07:28:31

Glpi_Gti
Member
Registered: 2017-04-10
Posts: 16

Re: Le cron GLPI ne fonctionne pas, voir documentation

Hello à la communauté,

Non je n'ai pas ces infos.
Infos Présentes dans cette section:
Server : Libraries : SQL Replicas : Notifications : Mails receivers : Plugin List
Mais pas de LDAP Directories

Offline

#39 2017-04-19 08:09:06

Glpi_Gti
Member
Registered: 2017-04-10
Posts: 16

Re: Le cron GLPI ne fonctionne pas, voir documentation

Voilà,

Je viens de tout supprimer, Wamp+ Glpi + Nettoyage disque et base de registre.
Réinstallation de :
- Wamp 2.5
- GLPI 9.1.2
Mais je suis toujours dans la même situation

Première installe sous Wamp 3.0.6 pas de Pb avec LDAP mais Pb avec FI
Deuxième installe sous wamp 2.5 pas de Pb avec FI mais pas de LDAP ......

Je fais une pause et je vais peut-être tenter une installe avec XAMPP....Il y a quelques années j'ai fait des installes pour Glpi 0.78 et 0.84 et je n'ai jamais eu de Pb, Il faut que je regarde car les dernières versions de xampp n'utilise plus MySql mai MariaDb et je connais pas du tout.

Offline

#40 2017-04-19 09:06:45

bzh
Member
Registered: 2016-09-25
Posts: 400

Re: Le cron GLPI ne fonctionne pas, voir documentation

Ce qui est curieux dans cette histoire c'est que le pb peut a la fois se présenté sous Linux et Windows

sur les version GLPI 9.1.1 et 9.1.2

l'idéale serais que la machine virtuel qui ne marche pas tu l'envoie au créateur de FusionInventory ;-) ddurieux
et de faire une comparaison de fichier, mais le pb c'est le poids d'une machine virtuel
ou si tu partage ta machine en pmad


Virtual Box \ Ubuntu 20.4  \ GLPI 9.5.3

Offline

#41 2017-04-19 16:35:24

Glpi_Gti
Member
Registered: 2017-04-10
Posts: 16

Re: Le cron GLPI ne fonctionne pas, voir documentation

Bonjour,

OUAH..... Ce n'est pas un cris de colère mais un de soulagement,
Mon module LDAP est enfin réapparu smile .

J'ai donc testé l'installe de Glpi avec Xampp et là pas plus de résultat positif.
J'ai testé d'autre version de Glpi (étant donné que la première cela avait marché je me suis dit pourquoi pas....Je sais c'est pas top
comme réflexion pour une recherche de panne mais là je n'avais pas mieux wink ). Mais cela n'a rien fait non plus.

Comme mon fichier php.ini était bon j'ai pris le Pb à l'envers j'ai commenté la ligne "extension=php_ldap.dll" et j'ai relancé Glpi.
Là apparition d'un message "L'extension LDAP de votre parseur PHP n'est pas installé".
Donc j'ai cherché avec ce nouveau message.
Bien-sur il était précisé qu'il fallait dé-commenté "extension=php_ldap.dll" mais sur le forum (oui celui-là) un glpien en 2014 proposait l'ajout suivant pour résoudre le Pb:

- Copier les fichiers de C:\xampp\php
Ou C:\wamp\bin\phpxxx\

    libeay32.dll
    libsasl.dll
    ssleay32.dll

Dans C:\Windows\System32 et là ça marche.

J'ai donc réinstaller WAMP pour testé et tout est réapparue.

Merci au forum et l'ensemble de ces mambres.

Pour le reste je fait une pause et testerai demain.

PS : Par contre pas de réponse au : Pourquoi lors de la première installe alors que les dll n'était pas dans C:\Windows\System32
cela marchait quand même, mais bon point trop n'en faut.

Offline

#42 2017-04-19 16:36:41

Glpi_Gti
Member
Registered: 2017-04-10
Posts: 16

Re: Le cron GLPI ne fonctionne pas, voir documentation

Oups, Désolé pour les fautes.

Offline

#43 2018-02-18 19:16:14

LinkPhoenix
Member
Registered: 2018-02-18
Posts: 2

Re: Le cron GLPI ne fonctionne pas, voir documentation

Bonjour,

j'ai parcouru cette discutions car j'avais du mal à mettre en place cette tâche cron.

Après l'avoir analysé je me suis rendu compte que les répertoires n'existaient pas, forcement j'ai fait une installation avec PHP7.0 et le dossier glpi est dans un dossier html

donc pour résoudre le problème je suis passé de cette ligne

* * * * * /usr/bin/php5 /var/www/glpi/front/cron.php &>/dev/null

qui elle est fournis par le site officiel de FusionInventory.
à cette ligne

* * * * * /usr/bin/php7.0 /var/www/html/glpi/front/cron.php &>/dev/null

et tout cela dans la crontab de l'utilisateur ROOT

j'espère que cela aidera.

Bon week-end

Configuraiton LAB
Serveur GLPI 9.2.1
OS : Debian 9 x64
Data Base : MariaDB

Offline

#44 2018-02-26 21:30:21

mikaelflora
Member
Registered: 2018-01-21
Posts: 2

Re: Le cron GLPI ne fonctionne pas, voir documentation

m.elbarhoumy wrote:

Je viens d'installer fusion inventory et j'ai se message d'erreur.

J'ai eu le même cas sur mon installation. Voici comment j'ai résolu le problème :  aller dans 'Configuration' > 'Actions automatiques' > éditer la tâche 'taskscheduler' puis cliquer sur 'Exécuter'.

Offline

#45 2018-02-27 00:16:28

LinkPhoenix
Member
Registered: 2018-02-18
Posts: 2

Re: Le cron GLPI ne fonctionne pas, voir documentation

mikaelflora wrote:
m.elbarhoumy wrote:

Je viens d'installer fusion inventory et j'ai se message d'erreur.

J'ai eu le même cas sur mon installation. Voici comment j'ai résolu le problème :  aller dans 'Configuration' > 'Actions automatiques' > éditer la tâche 'taskscheduler' puis cliquer sur 'Exécuter'.

Enfaite tu as forcé l’exécution de la tâche

exemple j'ai refait un serveur j'ai mit */5 * * * * /usr/bin/php7.0 /var/www/glpi/front/cron.php &>/dev/null

et pour pas attendre je suis aller 'Configuration' > 'Actions automatiques' et j'ai forcé l'execution de cette tâche

Offline

#46 2018-10-18 17:19:18

Sico31
Member
Registered: 2018-09-24
Posts: 324

Re: Le cron GLPI ne fonctionne pas, voir documentation

Même problème sous windows sur nos deux instances GLPI (PROD et TEST) sou windows serveur 2016.
Les actions automatiques sont Ok ainsi que la tache planifié.

Le problème d'affichage du message est résolu en arrétant la tache taskscheduler de glpi et en la relançant.
Désormais, je vois dans cette tâche la future planification à la place de "tache en cours d'execution"

Maintenant, faire fonctionner ces f... taches de découverte et d'inventaire SNMP ....


Manger un castor, c'est sauver un arbre

Offline

#47 2020-04-21 14:37:16

Alexmothe93
Member
Registered: 2018-08-31
Posts: 4

Re: Le cron GLPI ne fonctionne pas, voir documentation

Mon retour d'expérience :
Serveur Debian 9
PHP 7.0.33-0+deb9u7
MariaDB 10.1.26-MariaDB-0+deb9u1 Debian 9.1

Tests de mise à jour de GLPI de la version 9.2.3 vers la 9.4.5 sur un clone de la VM de prod.

Je me retrouve avec ce message d'erreur "Le cron GLPI ne fonctionne pas, voir documentation", alors que les cron sont bien exécutés :

root@srvglpi:~# systemctl status cron
● cron.service - Regular background program processing daemon
   Loaded: loaded (/lib/systemd/system/cron.service; enabled; vendor preset: enabled)
   Active: active (running) since Tue 2020-04-21 12:45:55 CEST; 1h 1min ago
     Docs: man:cron(8)
 Main PID: 473 (cron)
    Tasks: 1 (limit: 9830)
   CGroup: /system.slice/cron.service
           └─473 /usr/sbin/cron -f

avril 21 13:43:01 srvglpi CRON[1028]: pam_unix(cron:session): session opened for user www-data by (uid=0)
avril 21 13:43:01 srvglpi CRON[1029]: (www-data) CMD (php /var/www/html/glpi/front/cron.php)
avril 21 13:44:01 srvglpi CRON[1032]: pam_unix(cron:session): session opened for user www-data by (uid=0)
avril 21 13:44:01 srvglpi CRON[1033]: (www-data) CMD (php /var/www/html/glpi/front/cron.php)
avril 21 13:45:01 srvglpi CRON[1035]: pam_unix(cron:session): session opened for user www-data by (uid=0)
avril 21 13:45:01 srvglpi CRON[1036]: (www-data) CMD (php /var/www/html/glpi/front/cron.php)
avril 21 13:46:01 srvglpi CRON[1038]: pam_unix(cron:session): session opened for user www-data by (uid=0)
avril 21 13:46:01 srvglpi CRON[1039]: (www-data) CMD (php /var/www/html/glpi/front/cron.php)
avril 21 13:47:01 srvglpi CRON[1041]: pam_unix(cron:session): session opened for user www-data by (uid=0)
avril 21 13:47:01 srvglpi CRON[1042]: (www-data) CMD (php /var/www/html/glpi/front/cron.php)

Et les actions automatiques s'exécutaient bien aussi. Sauf en fait pour taskscheduler et d'autres, qui restent en statut "En cours d'exécution" depuis plusieurs jours/semaines/mois :

Nom				Statut		Dernière exécution	Fréquence d'exécution
queuednotification		Programmée	21/04/2020 14:00	1 minute
wakeupAgents			Programmée	21/04/2020 14:00	2 minutes
taskscheduler			Programmée	21/04/2020 14:00	1 minute
planningrecall			Programmée	21/04/2020 13:59	5 minutes
slaticket			Programmée	21/04/2020 13:59	5 minutes
temp				Programmée	21/04/2020 13:28	1 heures 0 minutes
reservation			Programmée	21/04/2020 13:27	1 heures 0 minutes
graph				Programmée	21/04/2020 13:27	1 heures 0 minutes
watcher				Programmée	21/04/2020 13:07	1 jours 0 heures 0 minutes
cleannetworkportlogs		Programmée	21/04/2020 09:31	1 jours 0 heures 0 minutes
cleanondemand			Programmée	21/04/2020 09:31	1 jours 0 heures 0 minutes
cleantaskjob			Programmée	21/04/2020 09:31	1 jours 0 heures 0 minutes
queuednotificationclean		Programmée	21/04/2020 09:30	1 jours 0 heures 0 minutes
mailgateerror			Programmée	21/04/2020 09:30	1 jours 0 heures 0 minutes
telemetry			Programmée	21/04/2020 09:30	30 jours 0 heures 0 minutes
PurgeLogs			Programmée	21/04/2020 09:30	7 jours 0 heures 0 minutes
infocom				Programmée	21/04/2020 09:29	1 jours 0 heures 0 minutes
certificate			Programmée	21/04/2020 09:29	1 jours 0 heures 0 minutes
checkupdate			Programmée	21/04/2020 09:29	7 jours 0 heures 0 minutes
closeticket			Programmée	21/04/2020 09:29	12 heures 0 minutes
alertnotclosed			Programmée	21/04/2020 09:29	12 heures 0 minutes
session				Programmée	21/04/2020 09:28	1 jours 0 heures 0 minutes
contract			Programmée	21/04/2020 09:28	1 jours 0 heures 0 minutes
createinquest			Programmée	21/04/2020 09:28	1 jours 0 heures 0 minutes
cleanoldagents			Programmée	04/03/2020 22:00	1 jours 0 heures 0 minutes
ticketrecurrent			En cours d'exécution	03/02/2020 07:01	1 heures 0 minutes
mailgate			En cours d'exécution	03/02/2020 07:01	1 minute

Du coup, aller dans la tâche et l'arrêter a suffit à résoudre le problème pour moi.
La tâche "watcher" n'est pas là pour résoudre ces tâches bloquées justement ? Je l'ai lancée manuellement, mais comme le montre le tableau ci-dessus, les tâches bloquées restent "En cours d'exécution".

Merci en tout cas pour la piste du taskscheduler a relancer !

Offline

Board footer

Powered by FluxBB