You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2018-02-12 10:54:55

Gaderions
Guest
Registered: 2018-01-24
Posts: 54

GLPI 9.1 et FusionInventory

Bonjour,

Je suis actuellement sur GLPI en version 9.1 relié avec mon nom de domaine OVH. Je souhaiterai intégrer le plugin FusionInventory a celui ci mais je ne sais pas pourquoi, cela ne fonctionne pas. J'ai un problème de compatibilité entre GLPI et FI. J'utilise pourtant une version qui devrait être compatible avec celle de GLPI soit FusionInventory 9.1+1.1. Mais, dans ma liste des plugins, on m'indique que la version de FusionInventory doit être comprise entre la 9.1 et la 9.2.
J'ai récupéré le plugin ici : https://github.com/fusioninventory/fusi … i/releases

Et ce que quelqu'un a une idée pour me dépanner, merci !

Offline

#2 2018-02-12 11:09:26

kurasul
Guest
Registered: 2017-12-20
Posts: 159

Re: GLPI 9.1 et FusionInventory

bonjour gaderions
il faut que tu recupere le plugins compatible avec ta version et le client qui va bien aussi.
as tu regarde dans les log d erreur ce qui ce passent ?

dis nous en plus
je serai sur le serveur discord en cas de souci
cdt


Kurasul // IT Manager  ============  https://discord.gg/qgDXNwS
OS + plugins: Ubuntu 16.04 // GLPI 9.2.1 // Php 7.0 // Sql + phpmyadmin // LDAP //
Fusion Inventory 9.2+1.0 //Cartographie 4.4.0 // Dashboard 1.4.0 // Gestion de baies 1.8.0 // Comptes 2.3.0 // Impression PDF
Imports fabricants 2.0.0 // Liste des taches 1.2.0 // Plus de rapports 1.4.0 // Arrêté du parc 2.4.0

Offline

#3 2018-02-12 11:48:24

Gaderions
Guest
Registered: 2018-01-24
Posts: 54

Re: GLPI 9.1 et FusionInventory

Merci pour ta réponse,
Je ne vois pas trop ce que je peux faire de plus, j'ai la version 9.1 de GLPI et que je mette le plugin Version 9.1+1.0 ou Version 9.1+1.1 (les deux seuls qui existent sur le site pour la 9.1de GLPI)

Offline

#4 2018-02-13 15:01:58

kevinG
Guest
From: Paris
Registered: 2014-02-26
Posts: 406

Re: GLPI 9.1 et FusionInventory

Bonjour,

Quand tu dis que tu as la version 9.1 c'est juste 9.1 ou il y a un chiffre après 9.1.X ?

Si oui peux-tu me dire ce qu'il y a dans le fichier setup.php à la racine du module fusioninventory ?
Cherche la fonction plugin_fusioninventory_check_prerequisites() puis la partie qui parle de la version "version_compare"

Ne modifie rien, mais indique ce qu'il y a.


Version en production GLPI 9.1.6 - Agent FI 2.3.13
Version en production Fusion Inventory 9.1+1.1
Version PHP 5.6.30
Zend Engine v2.6.0 - Zend OPcache v7.0.6-dev - Xdebug v2.5.0

Offline

#5 2018-02-13 15:27:52

Gaderions
Guest
Registered: 2018-01-24
Posts: 54

Re: GLPI 9.1 et FusionInventory

C'est GLPI en 9.1 tout court
Après les "version compare", il y a 9.1.1 et 9.2

"(version_compare(GLPI_VERSION, '9.1.1', 'lt') || version_compare(GLPI_VERSION, '9.2', 'ge'))"

Offline

#6 2018-02-13 16:19:31

kevinG
Guest
From: Paris
Registered: 2014-02-26
Posts: 406

Re: GLPI 9.1 et FusionInventory

Donc le problème vient de la, il faudrait que tu migres GLPI en version 9.1.6 (dernière version stable).
J'ai bien entendu parler d'une version 9.1.7 mais je ne l'ai pas trouvé.

Après tu peux essayer de modifier cette ligne (Mais je le déconseille fortement) mais bon s'il y a cette contrainte sur la version minimum de GLPI 9.1.1, c'est qu'il doit y avoir une raison, surement un bug.


Version en production GLPI 9.1.6 - Agent FI 2.3.13
Version en production Fusion Inventory 9.1+1.1
Version PHP 5.6.30
Zend Engine v2.6.0 - Zend OPcache v7.0.6-dev - Xdebug v2.5.0

Offline

#7 2018-02-13 17:28:05

Gaderions
Guest
Registered: 2018-01-24
Posts: 54

Re: GLPI 9.1 et FusionInventory

Bizarre qu'il n'y ai pas de plugin FI compatible avec la 9.1 de GLPI.
Mais en tout cas c'est bon j'ai pris une version plus récente et tout fonctionne super !

Merci bien !

Offline

Board footer

Powered by FluxBB