You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2014-05-14 19:30:56

mensahwilly
Member
Registered: 2014-05-14
Posts: 5

Impossible d'installer plugin ocs dans glpi 0.84.5

Bonjour à tous!
Je suis débutant sur glpi et ocs. J'ai installé OCS 2.1 et GLPI 0.84.5 sur la même machine Ubuntu 12.04. J'aimerais installer le plugin glpi-ocsinventory 1.0.2 mais quand j'ai suivi les démarches le plugin s'affiche dans l'interface de GLPI mais quand je clique sur installer rien ne se passe. le dossier plugin GLPI se trouve /opt/glpi/plugin et j'ai donné les droits de propriétaire du dossier du plugin à www-data mais toujours rien.
Pouvez vous m'apporter une aide.
Merci d'avance

Offline

#2 2014-05-15 13:33:34

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 15,184

Re: Impossible d'installer plugin ocs dans glpi 0.84.5

Avez-vous des erreurs dans les logs (glpi et apache) ?


CentOS 6.5 - CentOS 7.x
PHP 5.6 - PHP 7.x - MySQL 5.6  - MariaDB 10.2 + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#3 2014-05-15 18:01:12

mensahwilly
Member
Registered: 2014-05-14
Posts: 5

Re: Impossible d'installer plugin ocs dans glpi 0.84.5

Bonjour yllen,
qu'est ce qui doit m'alerter dans le contenu des fichiers log? j'ai fouillé le contenu de /glpi//files/_log et j'ai vu cron.log et php-errors.log mais rien d'alarmant dans ces fichiers à mon avis. Quant au dossier log de apache c'est la même chose je ne sais pas ce qui doit attirer mon attention dans le contenu.

Offline

#4 2014-05-16 08:29:08

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 15,184

Re: Impossible d'installer plugin ocs dans glpi 0.84.5

Si l'installation du plugin ne se fait pas vous devez avoir quelque chose d'indiquer dans les logs de GLPI (php-error.log ou sql-error.log).
Par contre, si c'est un problème de droit ou de propriétaire, donc d'accès au pages, ce sera des erreurs apache


CentOS 6.5 - CentOS 7.x
PHP 5.6 - PHP 7.x - MySQL 5.6  - MariaDB 10.2 + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#5 2014-05-16 09:30:51

mensahwilly
Member
Registered: 2014-05-14
Posts: 5

Re: Impossible d'installer plugin ocs dans glpi 0.84.5

Bonjour Yllen,
j'ai mis les droits du répertoire du plugin à 777 et cela a fonctionné. Merci pour ton aide.

Offline

#6 2014-05-16 09:33:46

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 15,184

Re: Impossible d'installer plugin ocs dans glpi 0.84.5

777 ? tu ne dois pas être administrateur de sécurité...


CentOS 6.5 - CentOS 7.x
PHP 5.6 - PHP 7.x - MySQL 5.6  - MariaDB 10.2 + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#7 2014-05-16 10:25:35

mensahwilly
Member
Registered: 2014-05-14
Posts: 5

Re: Impossible d'installer plugin ocs dans glpi 0.84.5

big_smile En effet je suis pas administrateur de sécurité quand bien même je suis conscient de ce que j'ai fait. Que me conseilles tu comme droit alors?

Offline

#8 2014-05-16 11:26:21

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 15,184

Re: Impossible d'installer plugin ocs dans glpi 0.84.5

755 maximum


CentOS 6.5 - CentOS 7.x
PHP 5.6 - PHP 7.x - MySQL 5.6  - MariaDB 10.2 + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#9 2014-05-16 11:39:48

mensahwilly
Member
Registered: 2014-05-14
Posts: 5

Re: Impossible d'installer plugin ocs dans glpi 0.84.5

ok c'est fait. merci

Offline

Board footer

Powered by FluxBB