You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2006-05-17 09:01:07

Mevil
Guest
Registered: 2006-05-16
Posts: 5

Problème : l'installation ne se lance pas (redhat)

Bonjour,

Voilà, je n'arrive pas à lancer l'installation de glpi 0.65 sous linux REDHAT.
J'ai dezipé les fichiers dans le répertoire /var/www/html comme dit dans le lisezmoi.txt mais après je ne comprends pas cette phrase: "Installez l'ensemble des fichiers de GLPI dans l'espace Web, à l'endroit où vous voulez que GLPI soit accessible au public."
Je ne comprends pas ou l'installer...

Ensuite pour les permissions aux différents fichiers je n'ai pas php en propriétaire, j'ai donc mis apache, c'est bon?

Quand je vais sur /var/www/html/glpi je tombe sur la page avec tout les fichiers, l'installation ne débute pas.

A noté que j'ai déjà crée la base glpidb avec un user (admin_glpi) qui a tous les droits dessus.

Je l'avais installé sur windows et tout fonctionnait normalement, mais bon je dois l'installer sous linux et je suis loin d'être un connaisseur de ce système.
SI vous pouviez m'aider ce serait sympa.
Merci d'avance.

Apache : 2.0
Mysql : 3.23
Php : je ne sais pas et "php --version" ne fonctionne pas.
glpi : 0.65
Linux redhat

Offline

#2 2006-05-17 09:08:15

Yogui
Guest
From: Hopitaux du pays du mont blanc
Registered: 2006-01-05
Posts: 62

Re: Problème : l'installation ne se lance pas (redhat)

as tu tenter de lancer

http://localhost/ton chemin vers glpi/install.php

?


Debian core 4
Apache/2.2.3 (Debian) PHP/5.2.0-8+etch7 mod_perl/2.0.2 Perl/v5.8.8
mysql 5.0.32
OCS GLPI

Offline

#3 2006-05-17 10:05:19

Mevil
Guest
Registered: 2006-05-16
Posts: 5

Re: Problème : l'installation ne se lance pas (redhat)

Oui cela ne fonctionne pas.
J'ai pourtant bien fais un alias dans le httpd.conf d'apache:


Même si mon alias est faux, il ne devrait pas se lancer si je tape /var/www/glpi/install.php dans le navigateur?

Offline

#4 2006-05-17 10:18:45

Yogui
Guest
From: Hopitaux du pays du mont blanc
Registered: 2006-01-05
Posts: 62

Re: Problème : l'installation ne se lance pas (redhat)

Tu as dit

Mevil wrote:

Bonjour,

Quand je vais sur /var/www/html/glpi je tombe sur la page avec tout les fichiers, l'installation ne débute pas.

Donc normalement dans ton navigateur tu doit mettre :

http://localhost/glpi/install.php

si tu tapes /var/www/glpi/install.php tu dois avoir un page d'erreur (sans http:// ou autre (ftp:// SMb://) tu ne donne pas à IE (ou autre) le langage à utiliser)

j'espère que ma réponse peux claire va t'aider

Last edited by Yogui (2006-05-17 12:12:26)


Debian core 4
Apache/2.2.3 (Debian) PHP/5.2.0-8+etch7 mod_perl/2.0.2 Perl/v5.8.8
mysql 5.0.32
OCS GLPI

Offline

#5 2006-05-17 11:22:53

Mevil
Guest
Registered: 2006-05-16
Posts: 5

Re: Problème : l'installation ne se lance pas (redhat)

Merci mais cela ne fonctionne pas non plus.
Il me dit:

"Forbidden

You don't have permission to access /home/glpi/install.php on this server."

Ce n'est pas un problème de permission, c'est seulement qu'il ne trouve pas le fichier.
Je dois avoir un problème d'alias ou autre chose (cf mon premier post)
Sais-tu ce que cela signifie?

"Installez l'ensemble des fichiers de GLPI dans l'espace Web, à l'endroit où vous voulez que GLPI soit accessible au public."

Offline

#6 2006-05-17 11:37:38

Yogui
Guest
From: Hopitaux du pays du mont blanc
Registered: 2006-01-05
Posts: 62

Re: Problème : l'installation ne se lance pas (redhat)

Cette phrase veut dire qu'il faut décompresser l'archive de GLPI dans le repertoire www\htlm de ton serveur Apache

ce qui doit te donner si tu ne change rien var/www/html/GLPI/...

petit solution ouvre une konsole tape locate install.php

il doit te retourner :

/var/www/html/GLPI/install.php


Debian core 4
Apache/2.2.3 (Debian) PHP/5.2.0-8+etch7 mod_perl/2.0.2 Perl/v5.8.8
mysql 5.0.32
OCS GLPI

Offline

#7 2006-05-17 11:47:52

Mevil
Guest
Registered: 2006-05-16
Posts: 5

Re: Problème : l'installation ne se lance pas (redhat)

Oui c'est bien ce que j'ai fais.
Ce n'est donc pas cela sad

Offline

#8 2006-05-17 11:50:22

Yogui
Guest
From: Hopitaux du pays du mont blanc
Registered: 2006-01-05
Posts: 62

Re: Problème : l'installation ne se lance pas (redhat)

as tu fait un locate de ton fichier install.php


Debian core 4
Apache/2.2.3 (Debian) PHP/5.2.0-8+etch7 mod_perl/2.0.2 Perl/v5.8.8
mysql 5.0.32
OCS GLPI

Offline

#9 2006-05-17 12:01:10

Mevil
Guest
Registered: 2006-05-16
Posts: 5

Re: Problème : l'installation ne se lance pas (redhat)

oui mais bizarrement il trouve le install.php qui est dans le répertoire /home/glpi (fichers de sauvegardes) et pas celui qui est dans /var/www/html/glpi/ alors que je l'ai décompressé aussi dedans (et il existe je le vois dans le répertoire par l'interface graphique).

Offline

#10 2006-05-17 12:11:55

Yogui
Guest
From: Hopitaux du pays du mont blanc
Registered: 2006-01-05
Posts: 62

Re: Problème : l'installation ne se lance pas (redhat)

si il ne le trouve pas dans /var/www/html/ avec un locate supprime tout tes fichiers existant de ce repertoire et remet les.

Si il trouve les deux dans www et dans ton home alors je ne vois pas.

tu peux tenter de lancer sur firefox ou IE html://127.0.0.1/glpi/install.php


Debian core 4
Apache/2.2.3 (Debian) PHP/5.2.0-8+etch7 mod_perl/2.0.2 Perl/v5.8.8
mysql 5.0.32
OCS GLPI

Offline

#11 2006-05-17 16:05:32

aurel
Guest
From: France
Registered: 2004-09-23
Posts: 1,248

Re: Problème : l'installation ne se lance pas (redhat)

As tu lu les tutos qui se trouvent sur cette page http://glpi.indepnet.org/rubrique.php3?id_rubrique=3 je dirais que non tongue mais surtout tu vas avoir un problème de taille car tu expliques que t'as version de MySQL est la 3.23 hors il faut au minimum la version 4.1 pour faire fonctionner GLPI. Je n'ai pas mis en ligne un tuto sur l'installation de GLPI sur une Red Hat car Fedora sans approche beaucoup wink donc lit le tuto et met à jour ton MySQL et je pense que tu devrais aller beaucoup plus loin qu'ou t'en est actuellement.


A+


Prod (Vmware) Debian 7.0 - GLPI 0.85.4 , plugin FusionInventory 0.85+1.1, Agent Fusioninventory v2.3.8
Pré Prod (Vmware) Debian 7.0 - GLPI 0.84.3 , plugin FusionInventory 0.84+1.2, Agent Fusioninventory v2.3.6

Offline

Board footer

Powered by FluxBB