You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2006-01-31 17:33:23

tmamour
Guest
Registered: 2005-06-23
Posts: 9

Message d'erreur lors de la mise à jour !

Bonjour,

Après avoir essayé la démo de la version 0.6 sur votre site j'ai voulu upgrader la mienne qui est en 0.51.

Je suis donc la procédure que vous indiquez pour faire une mise à jour, je donne mes mots de passes pour la base SQL puis le nom de la base à upgrader et la :-[  plantage avec le message d'erreur suivant :

Version 0.6
0.6 alter category tracking Erreur durant la mise à jour de la base de donnéesTable 'glpidb.glpi_tracking' doesn't exist


Bien sur apres cette erreur je ne m'attendais pas à ce que la nouvelle version fonctionne. Je récupère mon ancienne version que j'avais sauvegardée précieusement dans un coin du serveur et au lancement je m'appercois que toutes mes inters on disparus ....!
L'erreurs affichée est la suivante :

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /var/www/html/glpi/glpi/common/classes.php on line 88

De plus il est impossible d'en poster de nouvelles. J'ai peur que ma base SQL ai souffer et je vous demande votre aide.
J'ai aussi tenté de récupérer mes anciennes bases avec l'outil intégré à GLPI, aucune erreur lors de la restauration mais l'orque je veux voir ou poster des intervention il me remet l'erreur du haut.

Par avance merci.

Offline

#2 2006-02-15 16:56:24

tmamour
Guest
Registered: 2005-06-23
Posts: 9

Re: Message d'erreur lors de la mise à jour !

Re-bonjour ..

Aparrement pas de réponse de votre part, je vais donc persister encore un peu et si ça ne marche toujours pas je me retaperais tout le taf de tout retapper à la main ....!

Merci pour votre réactivité, pour ceux qui on peut être eu le même problème si jamais je trouve la solution je vous tiens au courant.

Offline

#3 2006-02-15 17:05:06

JMD
GLPI - Lead
Registered: 2004-09-13
Posts: 9,180
Website

Re: Message d'erreur lors de la mise à jour !

En ce qui concerne l'absence de réponse : http://glpi.indepnet.org/forum/viewtopic.php?id=193

Votre pb de mise à jour est curieux. Pas eu de retour de ce type.

Ensuite pour le reste :

Les Backups de vos bases de GLPI ne sont pas compatbiles entre eux.

Je m'explique : 

Un backup DB d'une version 0.51 ne marchera que sur une version 0.51
Un bacjup DB d'une version 0.6 ne fonctionnera que sur une version 0.6

Pour retrouver votre état initial  (0.51):

Il faut :

1) Récupérer vos fichiers de la 0.51
2) Restaurer une de vos bases sauvegardé de la 0.51

Et là vous retrouvez votre état initial.




Comme vous n'indiquez rien sur votre configuration, c'est difficile de vous en dire plus pour le moment.


JMD / Jean-Mathieu Doléans - Glpi-project.org - Association Indepnet
Apportez votre pierre au  projet GLPI   : Soutenir     Contribuer

Offline

#4 2006-02-15 17:07:52

jm.cierniewski
Guest
From: Nanterre 92
Registered: 2005-11-02
Posts: 1,654

Re: Message d'erreur lors de la mise à jour !

Bonjour,

A priori vous n'aviez pas sauvegardé votre base de donnée. lors de la mise à jours, de glpi, des modifications ont été effectuées dans votre base de donnée et cela la rendue incompatible avec votre ancienne version.

j'ai peur qu'il n'y ai plus grand monde en version < 0.6 vu que nous sommes tous en attente de la v 0.65... . Avez vous essayé de recommancer la maj en supprimant le fichier config_db.php  et en remettant la version de glpi à O.5 dans la database ? glpi_config ?


Plateforme :
OS : Windows 2003 Sp1 / logiciel de décompactage : Winzip / Navigateurs : Internet Explorer 6sp1 / firefox 1.5
Installation : Package Ocs NG RC3  - XAMPP version 1.5.1
Serveur  : Apache 2.0.55 / Base : 5.0.18-nt / Langage : PHP 5.1.1 / PhpMyAdmin 2.7.0-pl1

Offline

#5 2006-02-15 17:19:33

JMD
GLPI - Lead
Registered: 2004-09-13
Posts: 9,180
Website

Re: Message d'erreur lors de la mise à jour !

j'ai peur qu'il n'y ai plus grand monde en version < 0.6

Oh que si wink   Vous n'avez pas idée du nombre de structure qui tournent encore avec des versions 0.51 voir la 0.4.


JMD / Jean-Mathieu Doléans - Glpi-project.org - Association Indepnet
Apportez votre pierre au  projet GLPI   : Soutenir     Contribuer

Offline

#6 2006-02-15 17:21:42

jm.cierniewski
Guest
From: Nanterre 92
Registered: 2005-11-02
Posts: 1,654

Re: Message d'erreur lors de la mise à jour !

Comment on peut survivre avec autre chose qu'une bonne 0.65 ?????
il faudrai que j'essaie d'installer une v0.2 pour voir lol...


Plateforme :
OS : Windows 2003 Sp1 / logiciel de décompactage : Winzip / Navigateurs : Internet Explorer 6sp1 / firefox 1.5
Installation : Package Ocs NG RC3  - XAMPP version 1.5.1
Serveur  : Apache 2.0.55 / Base : 5.0.18-nt / Langage : PHP 5.1.1 / PhpMyAdmin 2.7.0-pl1

Offline

#7 2006-02-15 17:44:46

JMD
GLPI - Lead
Registered: 2004-09-13
Posts: 9,180
Website

Re: Message d'erreur lors de la mise à jour !

oui ça serait bien ça vous montrerait l'ampleur du travail réalisé wink


JMD / Jean-Mathieu Doléans - Glpi-project.org - Association Indepnet
Apportez votre pierre au  projet GLPI   : Soutenir     Contribuer

Offline

#8 2006-02-16 18:01:20

tmamour
Guest
Registered: 2005-06-23
Posts: 9

Re: Message d'erreur lors de la mise à jour !

Merci pour vos réponses, en effet je n'ai pas précisé ma configuration mais de toute façon le problème est réglé puisque je suis repartit à zéro sur une 0.6 toute propre... et elle a bien valu une petite heure pour l'incrémenter car elle est excellente.

Offline

Board footer

Powered by FluxBB