You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2005-07-15 09:05:01

MiKo59
Guest
From: Bailleul
Registered: 2005-07-15
Posts: 9
Website

Je ne comprends pas ce message ... Vous devez compiler votre php ...

En fait, je suis responsable informatique et j'aimerai mettre en place une gestion de parc et d'interventions, je suis tombé sur ce produit qui m'a l'ai génial ...

J'ai à ma disposition un serveur Linux sur lequel je fais déja tourner un Nagios (que j'ai eu toutes les peines du monde a installer ... je suis tres tres nul sous linux)

J'ai donc pris mon courrage a 2 mains et installé GLPI en lisant la documentation, tout s'est plutot pas mal passé (sur ma Debian 2.6)

Mais :

Etape 0
Vérification de la compatibilité de votre environnement avec l'execution de GLPI
Test effectué Résultats
Test du Parser PHP La version de PHP est 4.x - Parfait !
Test de l'extension mysql. Vous devez compiler votre php avec l'extension Mysql.
Test des Sessions Le support des sessions est opérationnel - Parfait !
Test de l'utilisation de Session_use_trans_id Ok - Le sessions fonctionnent (pas de problèmes de trans_id) - Parfait !
Test sur l'extension magic_quotes_sybase L'option magic_quotes_sybase n'est pas utilisée par votre serveur - Parfait !
Tests d'écriture de fichiers dump Le fichier a été créé et supprimé - Parfait !
Test d'écriture de fichiers documents Le fichier a été créé et supprimé - Parfait !
Test d'écriture du fichier de configuration Le fichier a été créé et supprimé - Parfait !

Continuer ?

Que dois-je faire ?


Sans maitrise, la puissance n'est rien.

Offline

#2 2005-07-15 10:08:17

MoYo
GLPI - Lead
From: Poitiers
Registered: 2004-09-13
Posts: 14,513
Website

Re: Je ne comprends pas ce message ... Vous devez compiler votre php ...

Quelle est votre distribution ?

Là il vous dit que mysql le lien php-MySQL n'est pas valide. Bref, que PHP ne sait pas intérroger une base Mysql.

Vous devez avoir un package du style php-mysql a installer.


MoYo - Julien Dombre - Association INDEPNET
Contribute to GLPI :    Support     Contribute     References     Freshmeat

Offline

#3 2005-07-15 10:14:57

MiKo59
Guest
From: Bailleul
Registered: 2005-07-15
Posts: 9
Website

Re: Je ne comprends pas ce message ... Vous devez compiler votre php ...

Je possède une Debian Sarge 2.6

J'ai verifié, le package PHP4-mysql est bien installé ...


Sans maitrise, la puissance n'est rien.

Offline

#4 2005-07-15 10:20:21

MoYo
GLPI - Lead
From: Poitiers
Registered: 2004-09-13
Posts: 14,513
Website

Re: Je ne comprends pas ce message ... Vous devez compiler votre php ...

est-ce que l'extension mysql est activé et le serveur web redemarré ?


MoYo - Julien Dombre - Association INDEPNET
Contribute to GLPI :    Support     Contribute     References     Freshmeat

Offline

#5 2005-07-15 10:27:34

MiKo59
Guest
From: Bailleul
Registered: 2005-07-15
Posts: 9
Website

Re: Je ne comprends pas ce message ... Vous devez compiler votre php ...

Extention MySql activée ? comment le savoir ? je n'y connais : RIEN smile

Le serveur a été redemarré oui ...

Je suis désolé si je semble ridicule, mais c'est tres compliqué pour moi


Sans maitrise, la puissance n'est rien.

Offline

#6 2005-07-15 10:32:19

MiKo59
Guest
From: Bailleul
Registered: 2005-07-15
Posts: 9
Website

Re: Je ne comprends pas ce message ... Vous devez compiler votre php ...

Oups, de pire en pire, maintenant, je viens de relancer mon serveur, et quand j'ouvre ma page :

http://192.168.0.253/glpi

là ou j'avais l'installation, avant, maintenant, il me demande si je veux télécharger le fichier ... glpi ... j'ai tout cassé ?


Sans maitrise, la puissance n'est rien.

Offline

#7 2005-07-15 10:42:02

MiKo59
Guest
From: Bailleul
Registered: 2005-07-15
Posts: 9
Website

Re: Je ne comprends pas ce message ... Vous devez compiler votre php ...

C'est réparé, mais je suis revenu à l'erreur du départ ! ... je suis certain qu'il y a quelquechose de tres simple, mais que je n'ai pas du faire correctement.

Ca fait 2 fois que je recommence avec la doc que vous avez mise a dispostion sur le site, et j'ai toujours le meme résultat.


Sans maitrise, la puissance n'est rien.

Offline

#8 2005-07-15 10:45:22

MoYo
GLPI - Lead
From: Poitiers
Registered: 2004-09-13
Posts: 14,513
Website

Re: Je ne comprends pas ce message ... Vous devez compiler votre php ...

L'extension mysql ne doit pas etre activé dans la ocnfiguration de php


MoYo - Julien Dombre - Association INDEPNET
Contribute to GLPI :    Support     Contribute     References     Freshmeat

Offline

#9 2005-07-15 10:46:37

MiKo59
Guest
From: Bailleul
Registered: 2005-07-15
Posts: 9
Website

Re: Je ne comprends pas ce message ... Vous devez compiler votre php ...

Pouvez vous me dire comment je dois faire ?


Sans maitrise, la puissance n'est rien.

Offline

#10 2005-07-15 11:01:30

MoYo
GLPI - Lead
From: Poitiers
Registered: 2004-09-13
Posts: 14,513
Website

Re: Je ne comprends pas ce message ... Vous devez compiler votre php ...

sous debian je ne peux personnellement pas vous renseigner.


MoYo - Julien Dombre - Association INDEPNET
Contribute to GLPI :    Support     Contribute     References     Freshmeat

Offline

#11 2005-07-15 11:03:07

MiKo59
Guest
From: Bailleul
Registered: 2005-07-15
Posts: 9
Website

Re: Je ne comprends pas ce message ... Vous devez compiler votre php ...

sad quelle tristesse ...

Qui pourra alors ? Si je vous donne un acces SSH ... vous ne pouvez pas jeter un oeil a ma configuration ?


Sans maitrise, la puissance n'est rien.

Offline

#12 2005-07-15 11:44:03

JMD
GLPI - Lead
Registered: 2004-09-13
Posts: 9,180
Website

Re: Je ne comprends pas ce message ... Vous devez compiler votre php ...

Pour vérifier le bon fonctionnement de php, créez le fichier phpinfo.php suivant dans /var/www/votre_rep

<? phpinfo(); ?>

et appelez le dans votre navigateur : http://localhost/votre_rep/phpinfo


Vérifiez que mysl est enabled


Vous utilisez Apache 2 ?


JMD / Jean-Mathieu Doléans - Glpi-project.org - Association Indepnet
Apportez votre pierre au  projet GLPI   : Soutenir     Contribuer

Offline

#13 2005-07-15 11:44:57

MiKo59
Guest
From: Bailleul
Registered: 2005-07-15
Posts: 9
Website

Re: Je ne comprends pas ce message ... Vous devez compiler votre php ...

Oui, j'utilise apache 2, je vais faire les tests, merci pour votre réponse smile


Sans maitrise, la puissance n'est rien.

Offline

#14 2005-07-16 11:44:16

aurel
Guest
From: France
Registered: 2004-09-23
Posts: 1,248

Re: Je ne comprends pas ce message ... Vous devez compiler votre php ...

si t'as suivi la doc du site je ne vois pas en quoi ca ne fonctionne pas moi je l'ai suivi et ca fonctionne tres bien!.. Peux tu taper dans une console la commande suivante:

dpkg -l | grep -i mysql

en clair la commande dpkg -l va lister tous les packages et le reste " | grep -i mysql" va trier les packages commençant par mysql.

@+


Prod (Vmware) Debian 7.0 - GLPI 0.85.4 , plugin FusionInventory 0.85+1.1, Agent Fusioninventory v2.3.8
Pré Prod (Vmware) Debian 7.0 - GLPI 0.84.3 , plugin FusionInventory 0.84+1.2, Agent Fusioninventory v2.3.6

Offline

#15 2005-07-16 11:45:16

aurel
Guest
From: France
Registered: 2004-09-23
Posts: 1,248

Re: Je ne comprends pas ce message ... Vous devez compiler votre php ...

Sinon oui un coup de ssh et ca devrait fonctionner mais je serais toi je ne donnerai jamais un acces ssh à une personne inconnu c'est pas tres sur ... Enfin moi je suis gentil big_smile


@+


Prod (Vmware) Debian 7.0 - GLPI 0.85.4 , plugin FusionInventory 0.85+1.1, Agent Fusioninventory v2.3.8
Pré Prod (Vmware) Debian 7.0 - GLPI 0.84.3 , plugin FusionInventory 0.84+1.2, Agent Fusioninventory v2.3.6

Offline

#16 2005-07-16 22:57:09

baaz
Guest
Registered: 2004-09-13
Posts: 513

Re: Je ne comprends pas ce message ... Vous devez compiler votre php ...

Verifier avant tout que cette ligne :

                                                       extension=mysql.so

Existe bien dans votre php.ini (/etc/php4/apache/php.ini sous debian) et n'est pas commentée.


Bazile Lebeau

Offline

#17 2005-07-18 08:08:23

MiKo59
Guest
From: Bailleul
Registered: 2005-07-15
Posts: 9
Website

Re: Je ne comprends pas ce message ... Vous devez compiler votre php ...

Ouééé ! j'ai trouvé, il me manquait un package ... un SQL-Admin ou un truc du genre, depuis, tout roule, merci a tous pour vos conseils, maintenant, je vais essayer d'installer OCS Inventory pour me simplifier la tache de saisie


Sans maitrise, la puissance n'est rien.

Offline

#18 2005-07-21 19:28:17

aurel
Guest
From: France
Registered: 2004-09-23
Posts: 1,248

Re: Je ne comprends pas ce message ... Vous devez compiler votre php ...

t'es sur que c'est un sql-admin ca me paret bizarre smile mais bon j'ai pas la science infuse lol. Plus serieusement si tu pouvez marquer sur le forum le package en question ca serait super sympa pour les autres qui pourraient se retrouver dans la meme situation que toi.

@+


Prod (Vmware) Debian 7.0 - GLPI 0.85.4 , plugin FusionInventory 0.85+1.1, Agent Fusioninventory v2.3.8
Pré Prod (Vmware) Debian 7.0 - GLPI 0.84.3 , plugin FusionInventory 0.84+1.2, Agent Fusioninventory v2.3.6

Offline

#19 2005-07-24 02:08:28

Yoann
Guest
Registered: 2005-07-22
Posts: 7

Re: Je ne comprends pas ce message ... Vous devez compiler votre php ...

Avec une debian Sarge (nouvellement Stable) :

Je pense que les packages suivants devrais suffire

apt-get install apache2 libapache2-mod-php4 php4-gd mysql-server-4.1 php4-mysql


J'en proferais l'hors de ma prochaine installation sur une machine pour noter les différents packages que j'installe, pour en faire un p'tit how-to.

Offline

#20 2005-07-24 12:01:45

JMD
GLPI - Lead
Registered: 2004-09-13
Posts: 9,180
Website

Re: Je ne comprends pas ce message ... Vous devez compiler votre php ...

Bonne idée wink

D'aillleurs ça pourrait permettre de mettre à jour la doc sur le site concernant l'installation Debian qui était pour la Woody.


JMD / Jean-Mathieu Doléans - Glpi-project.org - Association Indepnet
Apportez votre pierre au  projet GLPI   : Soutenir     Contribuer

Offline

#21 2005-07-25 17:17:09

aurel
Guest
From: France
Registered: 2004-09-23
Posts: 1,248

Re: Je ne comprends pas ce message ... Vous devez compiler votre php ...

euh smile perso j'ai reteste le tuto avec la sarge et meme la testing et je n'avais pas eu ce probleme smile

@+


Prod (Vmware) Debian 7.0 - GLPI 0.85.4 , plugin FusionInventory 0.85+1.1, Agent Fusioninventory v2.3.8
Pré Prod (Vmware) Debian 7.0 - GLPI 0.84.3 , plugin FusionInventory 0.84+1.2, Agent Fusioninventory v2.3.6

Offline

#22 2005-09-06 16:14:44

niconet
Guest
From: BORDEAUX
Registered: 2005-08-31
Posts: 33
Website

Re: Je ne comprends pas ce message ... Vous devez compiler votre php ...

bonjour,


j'avais la même chose et j'ai installé le paquet "phpmyadmin" et redémarré mon serveur apache2 .....

et tout est rentré dans l'ordre


j'utilise glpi 0,6 rc3 sur un serveur linux ubuntu 5.04 pour tester la bébette avant de passer en production sur un serveur sous sarge.


si j'ai fait un peu avancé le schimibilik ....

Last edited by niconet (2005-09-06 16:17:39)


Glpi 0.68.3 sous ubuntu 6.10 en production - Glpi 0.68.3 sous vmware ubuntu en test
php 5.1.6-1     Mysql 5.0.24a-9    Apache 2.0.55-4
-Navigateur: Firefox 1.5.0.7 sous XP et Ubuntu 2.0.0.2

Offline

Board footer

Powered by FluxBB