You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2005-06-28 17:52:04

lejoke
Guest
Registered: 2005-04-21
Posts: 3

pb m.a.j 0,42 vers 0,51a

Bonjour,
jai effectué (tente) une mise à jour. A priori tout c'est bien passé, parfait partout, installation reussie.
Je rentre le log admin puis le pass et :

Warning: loadlanguage(/home/ish/info/www/glpi/glpi/dicts/): failed to open stream: Inappropriate ioctl for device in /home/ish/info/www/glpi/glpi/common/functions.php on line 1657

Warning: loadlanguage(): Failed opening '/home/ish/info/www/glpi/glpi/dicts/' for inclusion (include_path='.:/usr/share/pear') in /home/ish/info/www/glpi/glpi/common/functions.php on line 1657

Warning: Cannot modify header information - headers already sent by (output started at /home/ish/info/www/glpi/glpi/common/functions.php:1657) in /home/ish/info/www/glpi/glpi/common/functions.php on line 351

Warning: loadlanguage(/home/ish/info/www/glpi/glpi/dicts/): failed to open stream: Inappropriate ioctl for device in /home/ish/info/www/glpi/glpi/common/functions.php on line 1657

Warning: loadlanguage(): Failed opening '/home/ish/info/www/glpi/glpi/dicts/' for inclusion (include_path='.:/usr/share/pear') in /home/ish/info/www/glpi/glpi/common/functions.php on line 1657

Warning: Cannot modify header information - headers already sent by (output started at /home/ish/info/www/glpi/glpi/common/functions.php:1657) in /home/ish/info/www/glpi/glpi/common/functions.php on line 448

pb de droits d'acces au rep ?? 
ce qui me tracasse c'est le "inappropriate ioctl"

en recherchant sur le forum j'ai lu un sujet qui semblait s'approcher de mon souci mais la personne était sous windows


infos: GLPI est installé sur un sun v20z (il ne fait pas que ça rassurez vous) os: redhat entreprise

Merci de votre aide et bravo au developpeurs (on ne le repetera jamais assez)

cdlt

Offline

#2 2005-06-28 19:22:33

aurel
Guest
From: France
Registered: 2004-09-23
Posts: 1,248

Re: pb m.a.j 0,42 vers 0,51a

comment avez proceder exactement pour faire la mise a jour ?

@+


Prod (Vmware) Debian 7.0 - GLPI 0.85.4 , plugin FusionInventory 0.85+1.1, Agent Fusioninventory v2.3.8
Pré Prod (Vmware) Debian 7.0 - GLPI 0.84.3 , plugin FusionInventory 0.84+1.2, Agent Fusioninventory v2.3.6

Offline

#3 2005-06-29 10:26:34

lejoke
Guest
Registered: 2005-04-21
Posts: 3

Re: pb m.a.j 0,42 vers 0,51a

en suivant benoitement la procédure détaillée là:
http://glpi.indepnet.org/article.php3?id_article=68


après avoir donné les droits en ecriture à apache aux repertoires /glpi/glpi/config, /glpi/backups/dump et /glpi/docs , j'ai finit par les donner à tout l'arbo de Glpi  et rien de mieux, bref je patauge.
voili

@+

Offline

#4 2005-06-29 13:44:08

baaz
Guest
Registered: 2004-09-13
Posts: 513

Re: pb m.a.j 0,42 vers 0,51a

Quelle sont les versions de php, apache et mysql ?


Bazile Lebeau

Offline

#5 2005-06-29 16:40:07

lejoke
Guest
Registered: 2005-04-21
Posts: 3

Re: pb m.a.j 0,42 vers 0,51a

Oups, désolé, j'aurais probablement du commencer par là, alors:
php version 4.3.2
Apache 2.0
Mysql 3.23.58
phpmyadmin 2.5.7-pl1

voili voilou

@+

Offline

#6 2005-06-30 11:02:19

JMD
GLPI - Lead
Registered: 2004-09-13
Posts: 9,180
Website

Re: pb m.a.j 0,42 vers 0,51a

Humm là je vois pas trop. Ce n'est pas un pb de droit d'écriture mais ça semble plutot être un pb d'ouverture du fichier de langue.

1) vérifiez qu'il est bien présent dans glpi/glpi/dicts

2) débugguez la fonction loadlanguage située dans glpi/glpi/common/functions.php  vers la ligne 1650 en plaçant des echo sur les variables qu'elle utilise pour vérifier qu'elle pointe bien sur les bons chemins

3) Dites nous quoi, je n'ai jamais rencontré ce message d'érreur , je suis intéressé par les retours que vous pourrez nous faire


JMD / Jean-Mathieu Doléans - Glpi-project.org - Association Indepnet
Apportez votre pierre au  projet GLPI   : Soutenir     Contribuer

Offline

#7 2005-06-30 11:21:34

baaz
Guest
Registered: 2004-09-13
Posts: 513

Re: pb m.a.j 0,42 vers 0,51a

je dirai plutot qu'il s'agit d'un probleme de session.

A priori il n'y a rien dans la variable $_SESSION["glpilanguage"] ... du coup il essaye d'inclure glpi/gpi/dicts qui est un répertoire et non un fichier d'ou l'erreur d'IO.

Je ne sais pas trop d'ou ça peux venir... peut etre un problème de support des session d'apache2...


Bazile Lebeau

Offline

Board footer

Powered by FluxBB