You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2013-08-29 00:05:45

alexcs
Guest
Registered: 2009-09-08
Posts: 47

Image in a public articles cannot be displayed

My public articles is showing broken links to images in a public articles, when I try to access a FAQ without login. If I try to access only the image, I receive the message: "Unauthorized access to this file".

More details in forum:
http://www.glpi-project.org/forum/viewt … 45#p163745

Offline

#2 2013-08-30 09:41:28

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 15,090

Re: Image in a public articles cannot be displayed

If your article was created in the root entity and image added from the root entity, i have no problem.

Do you have created your article with image in another entity and change it to root entity in the database ?


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#3 2013-08-30 15:25:54

alexcs
Guest
Registered: 2009-09-08
Posts: 47

Re: Image in a public articles cannot be displayed

I've created the articles and image in a root entity. It has been working until version 0.83.8.

I've made a test trying to access the image link below and it cannot be accessed from anonymous(without login):
https://www.myhostname.br/helpdesk/fron … docid=1189

Offline

#4 2013-09-05 19:13:26

alexcs
Guest
Registered: 2009-09-08
Posts: 47

Re: Image in a public articles cannot be displayed

Today I installed the 0.84.1 version, but I had the same problem.
Anyone has the same problem?

Offline

Board footer

Powered by FluxBB