You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2013-08-27 15:38:15

sdd.abonnement
Guest
Registered: 2013-08-27
Posts: 13

Erreur lors de l'exécution des scripts du plugin OCSINVENTORYNG

Bonjour,

Suite à la mise à jour de GLPI (v 0.84) et du plugin OCSINVENTORYNG (v 1.01), la mise à jour des ordinateurs ne se fait plus via le script "ocsng_fullsync.sh"

Erreur suivante dans le fichier "ocsng_fullsync.log"
        Manage delete items in OCS server #2: "NomSERVER"
=====================================================
        Thread #1: starting (1/2)
        Thread #1: cannot get server information

        Thread #1: done!!
=====================================================
=====================================================
        Thread #2: starting (2/2)
        Thread #2: cannot get server information

        Thread #2: done!!
=====================================================
cleaning up.

Dans le fichier "syslog" j'ai l'erreur :
vm-inventory suhosin[3572]: ALERT - script tried to disable memory_limit by setting it to a negative value -1 bytes which is not allowed (attacker 'REMOTE_ADDR not set', file 'unknown')

Je précise que j'utilisais avant la maj vers GLPI 0.84 le plugin "massocsimport" et comme spécifié dans la doc de maj j'ai désinstallé le plugin "massocsimport" après avoir installé le plugin "ocsinventoryng"

Via l'interface GLPI "Synchronisation des ordinateurs déjà importés" l'import s'effectue correctement en mode manuel.

GLPI est installé sur une Debian squeeze.

Sauriez-vous d'où vient mon problème ?

Merci pour votre aide.

Offline

#2 2013-08-29 15:05:14

sdd.abonnement
Guest
Registered: 2013-08-27
Posts: 13

Re: Erreur lors de l'exécution des scripts du plugin OCSINVENTORYNG

Bonjour à tous,

Pour information mon problème de plugin est résolu.
J'avais pourtant suivi la procédure décrite dans la documentation du plugin, mais la synchro automatique via un cron ne fonctionnait pas de même que via la ligne de commande. Par contre la syncro manuelle via l'interface de GLPI fonctionnait.

J'ai résolu mon problème en faisant les manipulations suivantes :
- dans GLPI, menu "Configuration", puis "Plugins"
- désactivation du plugin "OCS Inventory NG", puis "Désinstaller"
- fermeture de GLPI
- en shell : suppression du répertoire "ocsinventoryng" dans "...glpi/plugins/"
- en shell : réinstallation du plugin
- dans GLPI, menu "Configuration", puis "Plugins"
- installation du plugin "OCS Inventory NG, puis activation
=> le cron fonctionne avec le script "/var/www/glpi/plugins/ocsinventoryng/scripts/ocsng_fullsync.sh".
Je n'ai même pas eu besoin de reconfigurer quoi que ce soit au niveau de GLPI.

Voilà j'espère que ça pourra vous aider si vous rencontrer ce genre de problème.

Oups ... j'allais oublié : Merci aux développeurs.

Last edited by sdd.abonnement (2013-08-29 15:06:18)

Offline

Board footer

Powered by FluxBB