You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2020-05-27 10:34:47

codefire
Member
Registered: 2020-05-27
Posts: 12

problème mise à jour

Bonjour,

depuis hier, suite à une mise-à-jour de CentOS, lorsque je consulte glpi, je tombe sur la page "update needed".
Tous les checks sont OK et sous le tableau est indiqué "Votre version de la base de données n'est pas compatible avec la version des fichiers installés. Une mise à jour est nécessaire."

Lorsque je click sur "Mettre à jour", je recois le message suivant:
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at root@localhost to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.


Je suis en glpi 9.4.6

Merci d'avance pour l'aide.

Last edited by codefire (2020-05-27 18:19:04)

Offline

#2 2020-05-28 11:23:10

codefire
Member
Registered: 2020-05-27
Posts: 12

Re: problème mise à jour

Dans le log apache voici l'erreur:
[Client x.x.x.x:xxxx] /usr/share/glpi/install/.htaccess: Require not allowed here, refer: http://monserver/glpi/

Je n'ai pas de fichier .htaccess dans /usr/share/glpi/install

et voici le contenu du fichier glpi.conf, à propos de ce directory:

<Directory /usr/share/glpi/install>

    # Install is only allowed via local access (from the GLPI server).
    # Add your IP address if you need it for remote installation,
    # but remember to remove it after installation for security.

    <IfModule mod_authz_core.c>
        # Apache 2.4
        Require local
        # Require ip ##.##.##.##
    </IfModule>
    <IfModule !mod_authz_core.c>
        # Apache 2.2
        Order Deny,Allow
        Deny from All
        Allow from 127.0.0.1
        Allow from ::1
    </IfModule>

    ErrorDocument 403 "<p><b>Restricted area.</b><br />Only local access allowed.<br />Check your configuration or contact your administrator.</p>"

    <IfModule mod_php5.c>
        # migration could be very long
        php_value max_execution_time 0
        php_value memory_limit -1
    </IfModule>
    <IfModule mod_php7.c>
        # migration could be very long
        php_value max_execution_time 0
        php_value memory_limit -1
    </IfModule>
</Directory>



Je ne vois pas comment débloquer ma situation, merci de m'aider sad

Offline

#3 2020-05-28 14:41:42

codefire
Member
Registered: 2020-05-27
Posts: 12

Re: problème mise à jour

résolu

Offline

Board footer

Powered by FluxBB