You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2006-03-29 18:36:58

tarentino
Guest
Registered: 2006-03-29
Posts: 6

Pb maj bdd

Bonjour,

GLPI version 6.0
Apache + PHP 4 + Mysql 3.23.58

Ma version 0.6 fonctionnait impécablement, j'ai donc voulu migrer vers la 6.5 stable.

Copie des fichiers sur le serveur par ftp en conservant les répertoire docs/ et backup/ .

Ensuite il me propose de faire la maj, mais j'ai un message d'erreur lors de la mise à jour:

0.65 add ajax fields in configErreur durant la mise à jour de la base de donnéesYou have an error in your SQL syntax near '; ' at line 4

j'ai essayé ça trouver dans le message suivant http://glpi.indepnet.org/forum/viewtopic.php?id=1671

ALTER TABLE `glpi_config` ADD `dropdown_max` INT DEFAULT '100' NOT NULL ,
        ADD `ajax_wildcard` CHAR( 1 ) DEFAULT '*' NOT NULL ,
        ADD `use_ajax` SMALLINT DEFAULT '0' NOT NULL ,
        ADD `ajax_limit_count` INT DEFAULT '50' NOT NULL ;

mais malheureusement j'ai de nouveau un mesage d'erreur (différent) :

0.65 alter various fields in device_case Erreur durant la mise à jour de la base de donnéesYou have an error in your SQL syntax near '; ' at line 1

Offline

#2 2006-03-29 19:56:36

tsmr
GLPI-DEV
From: Rennes
Registered: 2005-08-26
Posts: 11,632
Website

Re: Pb maj bdd

ta version de mysql ? y a une limitation maintenant hmm min 4.1 je crois

Last edited by tsmr (2006-03-29 19:57:05)


Xavier Caillaud
Blog GLPI Infotel

Offline

#3 2006-03-29 20:04:05

aurel
Guest
From: France
Registered: 2004-09-23
Posts: 1,248

Re: Pb maj bdd

Ouai votre version de Mysql est beaucoup trop ancienne pour fonctionner avec GLPI. Lors de l'installation il est écrit qu'il faut au moins une version 4.X pour que tout fonctionne.

A+


Prod (Vmware) Debian 7.0 - GLPI 0.85.4 , plugin FusionInventory 0.85+1.1, Agent Fusioninventory v2.3.8
Pré Prod (Vmware) Debian 7.0 - GLPI 0.84.3 , plugin FusionInventory 0.84+1.2, Agent Fusioninventory v2.3.6

Offline

#4 2006-03-29 20:31:29

tarentino
Guest
Registered: 2006-03-29
Posts: 6

Re: Pb maj bdd

Le soucis, c'est uniquement lors de la mise à jour, si je fais une installation il n'y a pas de problème.

Je ne sais pas si il y a une limitation au niveau de la version de mysql, en tout cas moi ca fonctionne très bien avec une 3.23.58 depuis déjà quelques temps, y compris pour la version 0.65 en faisant une installation.

La maj plante.

Si quelqu'un à une idée. J'ai l'impression que c'est dans la procédure de MAJ.

Last edited by tarentino (2006-03-29 20:31:48)

Offline

#5 2006-03-29 20:56:30

aurel
Guest
From: France
Registered: 2004-09-23
Posts: 1,248

Re: Pb maj bdd

Cf. les prerequis.
> Maintenant GLPI demande MySQL >= 4.1
>
> Julien


Tout ça c'est tiré de la mailing list de Glpi donc à mon avis les dev ne t'aiderons pas pas car il précise bien que GLPI requiert une version supérieure à celle que tu utilise mais peut être qu'une personne pourra t'aider...

A+


Prod (Vmware) Debian 7.0 - GLPI 0.85.4 , plugin FusionInventory 0.85+1.1, Agent Fusioninventory v2.3.8
Pré Prod (Vmware) Debian 7.0 - GLPI 0.84.3 , plugin FusionInventory 0.84+1.2, Agent Fusioninventory v2.3.6

Offline

#6 2006-03-29 21:22:46

JMD
GLPI - Lead
Registered: 2004-09-13
Posts: 9,180
Website

Re: Pb maj bdd

C'est marqué dans le Readme et le lisez moi fourni dans l'archive de GLPI  également


JMD / Jean-Mathieu Doléans - Glpi-project.org - Association Indepnet
Apportez votre pierre au  projet GLPI   : Soutenir     Contribuer

Offline

#7 2006-03-29 21:30:36

tarentino
Guest
Registered: 2006-03-29
Posts: 6

Re: Pb maj bdd

Merci mais cela ne résoud pas mon problème.

C'est bizarre, un einstallation fonctionne impécablement et la maj plante.

Je vais essayer de passer en mysql 4.1 si mon hébergeur le permet.

Merci

Offline

#8 2006-03-30 08:15:52

aurel
Guest
From: France
Registered: 2004-09-23
Posts: 1,248

Re: Pb maj bdd

re,

je n'y connais vraiment pas grand chose en base de données mais ce que je peux te dire c'est que si un logiciel requiert au minimum une version d'un autre logiciel il faut essayer de s'y tenir sinon tu risques avoir des choses un jour ou l'autre qui ne fonctionneront et qui pourraient s'avérées génantes. Le problème que tu pourrais avoir par exemple maitenant c'est de passer de MySQL 3.x au 5. Vu le nombre de choses plus ou moins importantes qui changent entre les releases, je ne jouerais pas avec le feu car si tu utilises GLPI comme moi c.à.d pour gérer ton parc info et consommables et plus tu n'aurras pas envie de tout perdre sad

A+


Prod (Vmware) Debian 7.0 - GLPI 0.85.4 , plugin FusionInventory 0.85+1.1, Agent Fusioninventory v2.3.8
Pré Prod (Vmware) Debian 7.0 - GLPI 0.84.3 , plugin FusionInventory 0.84+1.2, Agent Fusioninventory v2.3.6

Offline

#9 2006-03-30 08:58:25

tarentino
Guest
Registered: 2006-03-29
Posts: 6

Re: Pb maj bdd

J'ai fait la mise à jour de mysql en 4.1 et la maj de la base GLPI c'est bien déroulée.

Merci à tous et encore féliciation au développeur pour ce magnificque outils.

Bonne continuation

Offline

#10 2006-03-30 11:24:56

JMD
GLPI - Lead
Registered: 2004-09-13
Posts: 9,180
Website

Re: Pb maj bdd

Merci pour vous encouragements.


JMD / Jean-Mathieu Doléans - Glpi-project.org - Association Indepnet
Apportez votre pierre au  projet GLPI   : Soutenir     Contribuer

Offline

Board footer

Powered by FluxBB