You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2006-03-02 12:08:40

jblemaire
Guest
Registered: 2006-03-02
Posts: 4

Les emails ne sont pas envoyés

Bonjour,

J'ai une installation de GLPI dans laquelle je n'ai jamais réussi à faire du suivi par email.
Ni l'administrateur ni nes techniciens à qui on affecte une intervention ne recoivent de mail.
La fonction mail() est bien activée sur mon serveur et dans la page "Suivis par email" tous les champs sont à oui.
D'où cela peut il venir ?

Ma config :
Red Hat 3
Apache 2.0.46
PHP 4.3.2
MySQL 4.1.12
GLPI 0.6

Offline

#2 2006-03-02 12:24:10

MoYo
GLPI - Lead
From: Poitiers
Registered: 2004-09-13
Posts: 14,513
Website

Re: Les emails ne sont pas envoyés

la fonction mail est bien activé mais est-ce qu'elle fonctionne ?
c'est à dire est-ce qu'apache ou plutot php est bien configurer pour envoyer des mails ?


MoYo - Julien Dombre - Association INDEPNET
Contribute to GLPI :    Support     Contribute     References     Freshmeat

Offline

#3 2006-03-02 12:30:06

jblemaire
Guest
Registered: 2006-03-02
Posts: 4

Re: Les emails ne sont pas envoyés

Oui les mails fonctionnent dans une autre application située sur le même serveur.
De plus j'ai fait un script avec la fonction mail() de PHP qui fonctionne très bien

Offline

#4 2006-03-02 12:57:54

le gogole
Guest
Registered: 2006-01-24
Posts: 25

Re: Les emails ne sont pas envoyés

Voila ba moi j'ai le même pb et à vrai dire je sais pas du tout par ou commencer ( je travaille sous Mandriva 2006, glpi0.6).

J'ai bien mis php-mbstring,php-imap et php-ldap

et au niveau du php.ini j'ai effectué ces modifs:
[mail function]
; For Win32 only.
SMTP = mail.nom_de_domaine.fr  <= Modifs

; For Win32 only.
sendmail_from = me@localhost.com

; For Unix only.  You may supply arguments as well (default: "sendmail -t -i").
sendmail_path = /usr/lib/sendmail -t -i    =< Modifs

Voila il manque des choses a modifier car a vrai dire j'en sais vraiment rien

Offline

#5 2006-03-02 14:14:32

JMD
GLPI - Lead
Registered: 2004-09-13
Posts: 9,180
Website

Re: Les emails ne sont pas envoyés

Le gogole :

php-imap et php-ldap -> on vous a déjà répondu que ça n'avait rien à voir avec l'envoi de mail ça . C'est pour l'authentification externe....

Bref pour les mails GLPI n'utilise rien de magique. Il a juste besoin que la fonction mail() de php fonctionne et ça c'est de l'administration serveur....


JMD / Jean-Mathieu Doléans - Glpi-project.org - Association Indepnet
Apportez votre pierre au  projet GLPI   : Soutenir     Contribuer

Offline

#6 2006-03-02 14:17:41

JMD
GLPI - Lead
Registered: 2004-09-13
Posts: 9,180
Website

Re: Les emails ne sont pas envoyés

Jblemaire :

Là c'est difficilement compréhensible si votre fonction mail() de php fonctionne, je vois pas pourquoi GLPI n'arrive pas à l'utiliser. Il faudrait editer le fichier mimemail.php qui se trouve dans /glpi/common/functions/   et mettre le mode debug à true.

Là vous allez avoir plus d'infos à nous retourner .


JMD / Jean-Mathieu Doléans - Glpi-project.org - Association Indepnet
Apportez votre pierre au  projet GLPI   : Soutenir     Contribuer

Offline

#7 2006-03-02 15:31:09

aurel
Guest
From: France
Registered: 2004-09-23
Posts: 1,248

Re: Les emails ne sont pas envoyés

Regarde ce post http://glpi.indepnet.org/forum/viewtopic.php?id=2257 qui parle de la fonction  mail.

@+


Prod (Vmware) Debian 7.0 - GLPI 0.85.4 , plugin FusionInventory 0.85+1.1, Agent Fusioninventory v2.3.8
Pré Prod (Vmware) Debian 7.0 - GLPI 0.84.3 , plugin FusionInventory 0.84+1.2, Agent Fusioninventory v2.3.6

Offline

#8 2006-03-02 16:20:44

jblemaire
Guest
Registered: 2006-03-02
Posts: 4

Re: Les emails ne sont pas envoyés

J'ai regardé le post 2257. A quoi sert EXIM ?
Par ailleurs j'ai activé le debug et fait une impression écran des messages : http://lafleche.ecritel.net/mail.gif
Je ne vois rien de bizare dedans...

Offline

#9 2006-03-02 16:42:39

emgenet
Guest
From: Charleville-Mézières - 08
Registered: 2006-02-10
Posts: 770
Website

Re: Les emails ne sont pas envoyés

dans le poste pré-cité, je n'ai fourni cette solution que pour debian, Exim sous debian, je gère, par est-ce qu'il existe sous les autres distrib et quel est le moyen de le configuré ?

Aucune idée.

Voilà, c'était juste pour apporté une petite précision.

@+

Manu


GLPI: 0.72.3 et OCS 1.0.1
Plateforme: Linux Debian Lenny (5.0) Navigateur: IE7-8 & FrFx2-3
PHP: 5.2.6;  MySQL: 5.0.51;  Apache: 2.2.9;

Offline

#10 2006-03-02 19:33:29

JMD
GLPI - Lead
Registered: 2004-09-13
Posts: 9,180
Website

Re: Les emails ne sont pas envoyés

Jb lemaire non il n'y a rien de bizarre dans votre retour écran.

Si votre fonction mail() php fonctionne pour d'autres appli , ce n'est pas un prb de configuration.

D'ailleurs normament la configuraiton par défaut sur les distribs permet d'envoyer des mails. Il n'y a donc pas besoin de rebidouiller.

Les mails sont bien générés. La question est qu'est ce que fait votre machine de ces mails ?

Il faudrait checker sur la machine dans les logs : syslog etc.... pour voir où vont ces mails .


JMD / Jean-Mathieu Doléans - Glpi-project.org - Association Indepnet
Apportez votre pierre au  projet GLPI   : Soutenir     Contribuer

Offline

#11 2006-03-03 12:45:19

jblemaire
Guest
Registered: 2006-03-02
Posts: 4

Re: Les emails ne sont pas envoyés

En fait cela vient du programme sendmail.
La fonction mail() de PHP ne fonctionne pas mais une autre appli arrive à envoyer des mails en écrivant toute l'enveloppe SMTP.
Bref il faut configurer mon sendmail.

Offline

#12 2006-03-03 12:47:56

MoYo
GLPI - Lead
From: Poitiers
Registered: 2004-09-13
Posts: 14,513
Website

Re: Les emails ne sont pas envoyés

ouep allez voir dans el FQ mail du site vous trouverez peut-etre une reponse.


MoYo - Julien Dombre - Association INDEPNET
Contribute to GLPI :    Support     Contribute     References     Freshmeat

Offline

#13 2006-03-04 11:32:21

aurel
Guest
From: France
Registered: 2004-09-23
Posts: 1,248

Re: Les emails ne sont pas envoyés

Est ce que tu as quelque chose dans les logs qui pourraient nous aider un peu parce que là on a pas matière à t'aider. Vérifie le /var/log/message par exemple.

@+


Prod (Vmware) Debian 7.0 - GLPI 0.85.4 , plugin FusionInventory 0.85+1.1, Agent Fusioninventory v2.3.8
Pré Prod (Vmware) Debian 7.0 - GLPI 0.84.3 , plugin FusionInventory 0.84+1.2, Agent Fusioninventory v2.3.6

Offline

#14 2006-03-06 12:28:47

le gogole
Guest
Registered: 2006-01-24
Posts: 25

Re: Les emails ne sont pas envoyés

Bon je sais que j'dois commencer a vous souler la mais j'y arrive pas à configurer mon suivi d'email. Je ne recois rien. Vous m'avez dit d'activez ma fonction mail ce qui équivaudrait pour moi à aller faire des modifs au nivo du fichier php.ini. Ce que j'ai fait mais ca marche tjrs pas. De plus je ne sais pas si les modifications ne sont à faire qu'ici.

Sachant que je travaille sous MAndriva 2006, que j'ai comme paramètre : domaine = chateaubriant, adresse IP pour acces aux mails = 132.147.12.51 comment faut-il alors que je paramètre mon php.ini ?

Voici ma config :

[mail function]
; For Win32 only.
SMTP = 132.147.12.51

; For Win32 only.
sendmail_from = nom_boite_email@ch-chateaubriant.fr

; For Unix only.  You may supply arguments as well (default: "sendmail -t -i").
sendmail_path = /usr/lib/sendmail -t -i

Ya koi a changer ? C'est tout faux ? Dsl c'est que  je suis novice en la matière

Offline

#15 2006-03-08 16:19:55

Yogui
Guest
From: Hopitaux du pays du mont blanc
Registered: 2006-01-05
Posts: 62

Re: Les emails ne sont pas envoyés

Bonjour à tous j'ai le même genre de problème les usagés ne reçoivent pas de mail de confirmation par contre les admins en reçoivent avez vous déjà vu ce problème

merci

Yog


Debian core 4
Apache/2.2.3 (Debian) PHP/5.2.0-8+etch7 mod_perl/2.0.2 Perl/v5.8.8
mysql 5.0.32
OCS GLPI

Offline

#16 2006-03-08 16:25:06

tsmr
GLPI-DEV
From: Rennes
Registered: 2005-08-26
Posts: 11,632
Website

Re: Les emails ne sont pas envoyés

Yogui wrote:

Bonjour à tous j'ai le même genre de problème les usagés ne reçoivent pas de mail de confirmation par contre les admins en reçoivent avez vous déjà vu ce problème

merci

Yog

as tu bien configuré ton suivi par email dans glpi ?


Xavier Caillaud
Blog GLPI Infotel

Offline

#17 2006-03-08 16:31:52

Yogui
Guest
From: Hopitaux du pays du mont blanc
Registered: 2006-01-05
Posts: 62

Re: Les emails ne sont pas envoyés

Oui j'ai coché oui partout pour mes tests

je vien de décourir ce topic :

http://glpi.indepnet.org/forum/viewtopic.php?id=1991

je suis en grande recherche de correctif.


Debian core 4
Apache/2.2.3 (Debian) PHP/5.2.0-8+etch7 mod_perl/2.0.2 Perl/v5.8.8
mysql 5.0.32
OCS GLPI

Offline

#18 2006-03-08 16:38:40

MoYo
GLPI - Lead
From: Poitiers
Registered: 2004-09-13
Posts: 14,513
Website

Re: Les emails ne sont pas envoyés

il y a toute une FAQ mail sur le site aussi.


MoYo - Julien Dombre - Association INDEPNET
Contribute to GLPI :    Support     Contribute     References     Freshmeat

Offline

#19 2006-03-08 17:07:38

Yogui
Guest
From: Hopitaux du pays du mont blanc
Registered: 2006-01-05
Posts: 62

Re: Les emails ne sont pas envoyés

Je l'ai lu et même relu smile

Pour tester mes envoie de mail j'ai "copier" ce petit script :

<?echo "je vais t'envoyer un mail<br>---<br>";if (mail("f.guillot@ch-sallanches-chamonix.fr", "test mail", "bouh"))
{ echo "mail envoyé..";}else {echo "mail PAS envoyé..";}?>



réponse :

je vais t'envoyer un mail
---
mail envoyé..

bref l'envoie des mails ce passe bien

Mon php.ini semble donc bien configuré

[mail function]
; For Win32 only.
SMTP = localhost
smtp_port = 25

(Mon serveur pour glpi est lui même serveur de messagerie)

Bref je ne comprend pas tu disai dans le topic : http://glpi.indepnet.org/forum/viewtopic.php?id=1991 qu'il devait y avoir un correctif

Last edited by Yogui (2006-03-08 17:08:17)


Debian core 4
Apache/2.2.3 (Debian) PHP/5.2.0-8+etch7 mod_perl/2.0.2 Perl/v5.8.8
mysql 5.0.32
OCS GLPI

Offline

#20 2006-06-21 10:19:46

flobib
Guest
Registered: 2006-06-02
Posts: 28

Re: Les emails ne sont pas envoyés

bonjour j'ai activé la fonction mail dans glpi mais persone ne recoit de mail.

Je suis sous Mandriva 2006, j'ai comme domaine ch-chateaubriant, adresse ip serseur messagerie: 132.147.12.51
Voici ma config :

[Mail function]
;For Win32 only
SMTP = 132.147.12.51

;For Win32 only
sendmail_from = me@ch-chateaubriant.fr

For Unix only
sendmail_path = /usr/lib/sendmail -t -i

Pouvez m'indiquer si il y a d'autre modification à faire.
Merci


(\ _ /)        GLPI 0.68-2
(='.'=)       OS : Mandriva 2006 Navigateur : Firefox, IE
(")^(")       Installation : Package Ocs NG 1.0RC3-1
                 Serveur : Apache 2.2.0 Mysql : 4.1.12 Langage : PHP 5.1.1 / PhpMyAdmin 2.7.0-pl1

Offline

#21 2006-06-21 11:58:47

aurel
Guest
From: France
Registered: 2004-09-23
Posts: 1,248

Re: Les emails ne sont pas envoyés

Salut,

tu as décommenté les deux lignes For "Win32 only" & "For Unix only" et si je ne m'abuse en only veut dire seuleument et toi tu veux en faisant ça utiliser les deux options hors tu ne dois en choisir qu'une seule en fonction de ton OS sur lequel tourne GLPI à savoir Linux pour toi (Mandriva) donc recommente la ligne en dessous de For Win 32 only.


A+


Prod (Vmware) Debian 7.0 - GLPI 0.85.4 , plugin FusionInventory 0.85+1.1, Agent Fusioninventory v2.3.8
Pré Prod (Vmware) Debian 7.0 - GLPI 0.84.3 , plugin FusionInventory 0.84+1.2, Agent Fusioninventory v2.3.6

Offline

#22 2006-06-21 14:15:27

ddebatty
Guest
Registered: 2006-02-07
Posts: 11

Re: Les emails ne sont pas envoyés

pour info:

[Mail function]
;For Win32 only
SMTP = 132.147.12.51

;For Win32 only
sendmail_from = me@ch-chateaubriant.fr

ne sert a rien pour ceux qui sont sous linux...

perso j'utilise ssmtp au lieu de sendmail...
je suis sous freebsd, mais je pence que ce doit aussi etre valide pour des distributions de linux...
http://glpi-project.org/forum/viewtopic.php?id=3553

Offline

#23 2006-06-21 14:28:18

flobib
Guest
Registered: 2006-06-02
Posts: 28

Re: Les emails ne sont pas envoyés

ca y est j'ai réussi a faire fonctionner le suivi par mail. En fait il fallait configurer le fichier main.cf de postix.
Merci


(\ _ /)        GLPI 0.68-2
(='.'=)       OS : Mandriva 2006 Navigateur : Firefox, IE
(")^(")       Installation : Package Ocs NG 1.0RC3-1
                 Serveur : Apache 2.2.0 Mysql : 4.1.12 Langage : PHP 5.1.1 / PhpMyAdmin 2.7.0-pl1

Offline

Board footer

Powered by FluxBB