You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2019-10-02 11:21:13

hcimadomo-procsi
Guest
Registered: 2017-07-12
Posts: 1

glpi 9.4.4. : recherche avec "elements visualisés" ne marche pas

Bonjour,
depuis la maj en 9.4.4., la recherche avec "elements visualisés" ne marche pas. cela concerne toutes les recherches.
Merci de votre aide.
Cordialement

Offline

#2 2019-10-02 15:38:16

fabibus
Guest
From: Nantes
Registered: 2008-02-05
Posts: 156

Re: glpi 9.4.4. : recherche avec "elements visualisés" ne marche pas

Bonjour,
J'ai le même soucis. Mise à jour de GLPI version 9.4.3 vers 9.4.4...
La recherche sur le nom ou sur le domaine renvoi un résultat.
Quand on recherche sur les "éléments visualisés" (domaine et nom de machine affiché), on obtient rien .


Plateforme en exploitation : GLPI 9.4.4 + FusionInventory 9.4+1 sur Fedora 27
PHP 7.1 ,Apache 2.4, Mysql 8

Offline

#3 2019-10-04 01:37:14

cconard96
Guest
Registered: 2018-07-31
Posts: 16

Re: glpi 9.4.4. : recherche avec "elements visualisés" ne marche pas

Can you see if this resolves your issue?
https://github.com/glpi-project/glpi/pull/6388

Offline

#4 2019-10-04 09:03:45

bluzz04
Guest
Registered: 2013-09-19
Posts: 9

Re: glpi 9.4.4. : recherche avec "elements visualisés" ne marche pas

cconard96 wrote:

Can you see if this resolves your issue?
https://github.com/glpi-project/glpi/pull/6388

Bonjour.

Cette solution a fonctionné pour moi en modifiant le fichier inc/search.class.php.

De mon côté c'est la présence du champ Groupe Technique qui posait problème.

Merci.

Offline

#5 2019-10-04 09:51:46

fabibus
Guest
From: Nantes
Registered: 2008-02-05
Posts: 156

Re: glpi 9.4.4. : recherche avec "elements visualisés" ne marche pas

Merci pour la réactivité.
Résolu pour moi sur toutes les recherches sauf pour la recherche des ordinateurs quand il y a un champs fusioninventory affiché :

Unknown column 'glpi_plugin_fusioninventory_inventorycomputercomputers.last_fusioninventory_update' in 'where clause'


Plateforme en exploitation : GLPI 9.4.4 + FusionInventory 9.4+1 sur Fedora 27
PHP 7.1 ,Apache 2.4, Mysql 8

Offline

#6 2019-10-07 16:33:22

mab3
Guest
Registered: 2014-09-22
Posts: 132

Re: glpi 9.4.4. : recherche avec "elements visualisés" ne marche pas

Bonjour à tous,

J'ai ajouté un bug ici à ce sujet : (recherche de catégories de tickets ne renvoie rien, mais génère une erreur dans la log SQL de GLPI)
https://github.com/glpi-project/glpi/issues/6425


Contexte : GLPI 9.4.3/FusionInventory 9.4+1.1 / Agent FI 2.5.1

Offline

#7 2019-10-08 08:20:47

omupvm
Guest
Registered: 2009-11-30
Posts: 3

Re: glpi 9.4.4. : recherche avec "elements visualisés" ne marche pas

cconard96 wrote:

Can you see if this resolves your issue?
https://github.com/glpi-project/glpi/pull/6388

Bonjour,
Je confirme qu'après application de ce correctif, la recherche sur les ordinateurs avec les éléments visualisés continue de ne pas fonctionner quand les champs  responsable technique ou groupe technique sont affichés :

   Error: Unknown column 'glpi_users_users_id_tech.realname' in 'where clause'
   Error: Unknown column 'glpi_groups_groups_id_tech.completename' in 'where clause'

Offline

#8 2019-10-08 09:51:51

mab3
Guest
Registered: 2014-09-22
Posts: 132

Re: glpi 9.4.4. : recherche avec "elements visualisés" ne marche pas

Bonjour,

Pour ma part, le patch corrige le problème de mon contexte.


Contexte : GLPI 9.4.3/FusionInventory 9.4+1.1 / Agent FI 2.5.1

Offline

#9 2019-10-18 10:34:50

AM
Member
Registered: 2019-10-18
Posts: 1

Re: glpi 9.4.4. : recherche avec "elements visualisés" ne marche pas

Bonjour,

Le bugfixe #6388 fonctionne.
Mais obligé de désélectionner la colonne "Plugins - FusInv - Dernier inventaire" pour obtenir un résultat dans la recherche d'ordinateurs sur "éléments visualisés".

Depuis MAJ en 9.4.4 & fusion 9.4 + 1.1

Last edited by AM (2019-10-18 10:42:03)

Offline

#10 2019-10-18 11:10:10

DavidS
Member
Registered: 2019-10-03
Posts: 1

Re: glpi 9.4.4. : recherche avec "elements visualisés" ne marche pas

Bonjour,

Toujours un soucis pour afficher les résultats de recherche dans "éléments visualisés" pour les utilisateurs, matériels réseaux et imprimantes. Pas de soucis pour les autres catégories.
J'ai effectué les modifications comme indiqué dans le fix #6388.

GLPI 9.4.4 / FusionInventory 9.4+1.0

EDIT : Cela provient du plugin "fields" version 1.10.2 j'ai rajouté un champ IP que j'ai affiché si je l'enlève pas de soucis la recherche fonctionne.

Last edited by DavidS (2019-10-18 11:43:24)

Offline

Board footer

Powered by FluxBB