You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2019-09-03 23:40:24

silennnce
Guest
Registered: 2009-06-03
Posts: 5

GLPI9.4 souci extension

Bonjour,

Pour mettre en situation :
- J'avais un Debian 9 avec GLPI 9.4.2 installé.
- J'ai mis à jours Debian 10 (Il y a plus d'un mois de cela...) Tout c'est bien passé. GLPI Fonctionne toujours. Depuis 1 mois pas de constat ou erreur inquiétante.
- Aujourd'hui je vais mettre à jours en 9.4.3
C'est la que les problèmes arrivent. Je fais les essaies sur une VM de test, snapshot ok me permettant les retours en arrière.

Problème :
Lors de la mise à jours en 9.4.3, lors de la page de test, j'ai le signalement de plugin absent. Dont un bloquant. Jusque la rien de grave, j'avais déjà eu le cas, on installe les plugins correspondant, on relance la mise à jours et hop ca déroule. Sauf que la... j'ai de la résistance...

Autre analyse :
Je retourne au point 0 (avec mon snapshot), j'ouvre GLPI (donc non mis à jours) en version 9.4.2, je vais dans configuration -> générale -> Système, et la je constate les 3 plugins en erreur. Que je n'avais pas en Debian 9, mais présent en Debian 10. Cela n'a pas empêché GLPI de fonctionner, mais m’empêche de mettre à jours aujourd'hui.

Liste des plugins en alerte :
APCu extension is not present (En attention Jaune) - Pas trouvé de solution
curl extension is missing (En attention Rouge) - Pas trouvé de solution
cas extension is missing (En attention Jaune) - apt-get install php-cas -> Solution Ok

Information sur le serveur :

PHP 7.3 installé

apt-get install php7.3
apt-cache policy php7.3
php7.3:
  Installé : 7.3.4-2
  Candidat : 7.3.4-2
 Table de version :
 *** 7.3.4-2 500
        500 http://ftp.nc.debian.org/debian buster/main amd64 Packages
        500 http://debian.nautile.nc/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status

apt-cache policy nginx

nginx:
  Installé : 1.16.0-1~stretch
  Candidat : 1.16.0-1~stretch
 Table de version :
 *** 1.16.0-1~stretch 100
        100 /var/lib/dpkg/status
     1.16.0-1~buster 500
        500 http://nginx.org/packages/debian buster/nginx amd64 Packages
     1.14.2-2 500
        500 http://ftp.nc.debian.org/debian buster/main amd64 Packages
        500 http://debian.nautile.nc/debian buster/main amd64 Packages

apt-cache policy php-apcu

php-apcu:
  Installé : 5.1.17+4.0.11-1
  Candidat : 5.1.17+4.0.11-1
 Table de version :
 *** 5.1.17+4.0.11-1 500
        500 http://ftp.nc.debian.org/debian buster/main amd64 Packages
        500 http://debian.nautile.nc/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status

apt-cache policy php-apcu-bc

php-apcu-bc:
  Installé : 1.0.4-4
  Candidat : 1.0.4-4
 Table de version :
 *** 1.0.4-4 500
        500 http://ftp.nc.debian.org/debian buster/main amd64 Packages
        500 http://debian.nautile.nc/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status

apt-cache policy php-curl

php-curl:
  Installé : 2:7.3+69
  Candidat : 2:7.3+69
 Table de version :
 *** 2:7.3+69 500
        500 http://ftp.nc.debian.org/debian buster/main amd64 Packages
        500 http://debian.nautile.nc/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status

On voit bien que les plugins sont installé. Auriez vous des idées, des pistes pour m'aider à dépanner cela?

Merci,

Offline

#2 2019-09-10 11:13:30

Mr.Propre
Guest
Registered: 2016-10-12
Posts: 87

Re: GLPI9.4 souci extension

Je vois nginx comme démon HTTP.
Je sais qu'il peut y avoir des restrictions des "referer" à désactiver.


Version 9.4.2 sous Debian

Offline

#3 2019-09-16 00:53:48

silennnce
Guest
Registered: 2009-06-03
Posts: 5

Re: GLPI9.4 souci extension

Bonjour,

Vu le peu de retour, c'est déjà une réponse.
Merci à toi, je vais chercher des pistes de ce coté la.

Offline

Board footer

Powered by FluxBB