You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2019-07-05 11:39:45

shenpins
Member
Registered: 2019-06-07
Posts: 6

Inventaire distant hôte VMware ne fonctionne pas

Bonjour à tous,

Je sollicité votre aide car je ne parvient pas à réaliser l'inventaire de mes hôtes ESXi.

Je suis sous :

- Débian 9.9
- GLPI 9.4.2
- FusionInventory 1.1

L'inventaire de mes postes fonctionne correctement
La découverte réseau fonctionne correctement.
L'inventaire réseau (SNMP) fonctionne correctement (principalement utilisé pour les imprimantes).

Lorsque je crée une tâche "Inventaire distant hôte VMware", celle-ci reste en statue "préparé" et "a faire"

Je force mon planificateur de tâche et exécute manuellement un inventaire sur l'agent défini dans ma tâche.
La requête d'"Inventaire distant hôte VMware" a bien été reçu sur mon agent car dans les logs je voir bien la ligne "running task ESX".
J'ai remarqué que lorsqu'il n'y avait aucune requête d'"Inventaire distant hôte VMware" envoyé à un agent, le message ci-dessous apparaissait dans les logs :
"No ESX job enabled or ESX support disabled server side".

J'ai essayé d'envoyer la requête d'"Inventaire distant hôte VMware" sur deux agents différents, un sous Windows 2012 R2 et un sous mon serveur GLPI, même résultat.
L'inventaire "normal" fonctionne correctement sur ces deux agents.

Dans les propriétés des deux agents, le module "Inventaire distant des hôtes VMware" est bien activé.

Voici le message d'erreur retourné par les deux agents

Agent Windows :

[Fri Jul  5 08:42:38 2019][info] running task ESX
[Fri Jul  5 08:42:40 2019][error] [http client] communication error: 500 Can't connect to ***-glpi:443 (Hôte inconnu. )

==> ***-glpi:443 étant le nom de mon serveur GLPI, j'ai remplacé par des étoiles car il y a le nom de la société.

Agent Debian :

[info] running task ESX
[error] [http client] communication error: 404 Not Found

Sur l'agent Windows je ne comprend pas pourquoi il essaye d'envoyer des infos à l'adresse "***-glpi:443" alors que pour un inventaire classique, l'agent envoie bien les infos à la bonne adresse, à savoir :
"https://***-GLPI/plugins/fusioninventory/"

Je sèche, il doit y avoir un paramétrage que j'ai zappé, mais j'ai fouillé le net, ce forum, les menu de fusion, en vain.

Je vous remercie pour votre lecture.

Bonne journée.

Offline

#2 2019-07-05 12:09:13

Jean-Christophe
Moderator
Registered: 2007-08-22
Posts: 350

Re: Inventaire distant hôte VMware ne fonctionne pas

Bonjour,

Est-ce que dans
Setup > General > "General Setup" > "URL of the application"
et dans
Administration > Entities > [Ton Entité] > Fusioninventory > "Service URL"
C'est bien la même URL qui est indiquée ?

Offline

#3 2019-07-05 12:23:15

shenpins
Member
Registered: 2019-06-07
Posts: 6

Re: Inventaire distant hôte VMware ne fonctionne pas

Salut Je te remercie pour ta réponse

Setup > General > "General Setup" > "URL of the application"
L'url indiqué est https://***-glpi

Administration > Entities > [Ton Entité] > Fusioninventory > "Service URL"
L'url indiqué est https://***-glpi/plugins/fusioninventory

Il s'agit du même nom au deux endroits.

Je viens d'essayé de changer Setup > General > "General Setup" > "URL of the application"
Par l'URL https://***-glpi/plugins/fusioninventory

J'ai le même résultat sur les deux agents

Offline

#4 2019-07-05 13:02:34

Jean-Christophe
Moderator
Registered: 2007-08-22
Posts: 350

Re: Inventaire distant hôte VMware ne fonctionne pas

Essaye de retirer le "/plugins/fusioninventory" des deux côtés. Ici, j'ai juste le chemin vers la page d'accueil de GLPI et ça fonctionne.

Mais je me souviens avoir du chipoter un peu avec ça.

Offline

#5 2019-07-05 13:59:47

shenpins
Member
Registered: 2019-06-07
Posts: 6

Re: Inventaire distant hôte VMware ne fonctionne pas

Re,

Je viens de changer
Setup > General > "General Setup" > "URL of the application"
L'url indiqué est https://***-glpi

Administration > Entities > [Ton Entité] > Fusioninventory > "Service URL"
L'url indiqué est https://***-glpi/

Mes ESXi remontent correctement dans mon inventaire ! Coool !

Je te remercie !

Cependant, je ne trouve pas le vcenter pourtant alors que la récolte semble fonctionner.

vcenter.jpg

Aurais-tu une idée ou alors je ne cherche pas au bon endroit.
Mes ESXi sont tombés dans le type ordinateurs.
J'ai bien entendu parcouru tout les types, en vain

Offline

#6 2019-07-09 10:10:59

Jean-Christophe
Moderator
Registered: 2007-08-22
Posts: 350

Re: Inventaire distant hôte VMware ne fonctionne pas

En effet, le vCenter doit être inventorié comme un ordinateur. Il n'est pas remonté par les inventaires vmware puisque, techniquement, ce n'est pas un serveur de virtualisation.
Il faut le voir comme un serveur de gestion. A ce titre, il ne contient pas de machines virtuelles.
Du coup, il faut inventorier le vcenter à part.

Tant mieux si tu es dépanné :-)

Bonne journée,
JC

Offline

#7 2019-07-09 10:37:23

Jean-Christophe
Moderator
Registered: 2007-08-22
Posts: 350

Re: Inventaire distant hôte VMware ne fonctionne pas

Par contre, une petite remarque...

Si les ESX1, 2 et 3 sont connectés sur le vcenter (d'un point de vue VMWare), il n'est pas nécessaire de les inventorier séparément. Ils seront inventoriés via le vcenter.

Offline

Board footer

Powered by FluxBB