You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2019-03-12 11:52:08

Montesquieu
Member
Registered: 2019-02-28
Posts: 5

GLPI 9.3.3 à 9.4.0 problème

Bonjour à tous,

Je souhaite mettre à jour GLPI de la version 9.3.3 à la 9.4.0.

Tout se passe bien, je backup FTP + base de donnée OCS + GLPI , je garde uniquement files et mes plugins dans le FTP, j'upload GLPI 4.0

Je procède par la suite à la mise à jour sur GLPI et arrivé à la mise à jour base de donnée je n'ai aucune barre d'avancement et rien ne bouge si ce n'est que j'ai le texte:
Mise à jour de la table .... (une table "itiles" me semble t'il).

Bref, j'ai laissé toute une nuit comme ça et aucun avancement non plus, j'ai tout tenté
GLPI tourne sur Debian Wheezy , PHP 5.6.40 et MySQL 5.7 (donc ok pour GLPI 4.0 normalement)

J'ai tenté plusieurs fois mais impossible et à chaque fois je suis finalement obligé de restaurer les backups.

Quelqu'un aurait déjà vécu ce problème ou a t'il une solution ?

Merci d'avance

Cdt,

Offline

#2 2019-03-12 12:19:39

LaDenrée
HELPER
Registered: 2012-11-19
Posts: 4,532

Re: GLPI 9.3.3 à 9.4.0 problème

surprenant : les noms de toutes les tables glpi commencent par glpi_****
avez vous choisi la bonne base sur le bon serveur ?


avez vous tenté la mise à jour via la console : https://glpi-install.readthedocs.io/en/ … -line.html


Trouver la panne avant de réparer...
*GLPI 9.1.6+fusion9.1+1.1+behaviours1.5.0+reports+fields+appliances+pdf+badges+formcreator2.5.2 PHP7.0 Mariadb10
*GLPI 9.4.2(behaviours2.2.1+fusioninventoty 9.4+1.1+applicatifs2.5.0+fields 1.9.1)hebergé sur serveur mutualisé.

Offline

#3 2019-03-12 14:40:33

Montesquieu
Member
Registered: 2019-02-28
Posts: 5

Re: GLPI 9.3.3 à 9.4.0 problème

Oui tout à fait autant pour moi je parle bien d'une table nommé "glpi_itiles" (ressemble à peu près à ça)

Je vais me pencher sur la maj en ligne de commande, merci

Offline

#4 2019-03-12 18:40:59

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 14,930

Re: GLPI 9.3.3 à 9.4.0 problème

des tables glpi_itil... il y en a 4 en 9.4.

Il faudrait les erreurs dans les logs de GLPI, dans les logs d'apache pour poouvoir vous aider


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#5 2019-03-16 12:17:57

damer
Member
Registered: 2019-02-17
Posts: 45

Re: GLPI 9.3.3 à 9.4.0 problème

Chez moi la mise à jour de la 9.3.3 à la 9.4 ne fonctionne pas .
il y a un gros soucis avec la version 9.4 et idem avec la 9.4.1

Offline

#6 2019-03-18 15:55:02

Montesquieu
Member
Registered: 2019-02-28
Posts: 5

Re: GLPI 9.3.3 à 9.4.0 problème

damer wrote:

Chez moi la mise à jour de la 9.3.3 à la 9.4 ne fonctionne pas .
il y a un gros soucis avec la version 9.4 et idem avec la 9.4.1

Idem rien à faire

Offline

#7 2019-03-24 16:22:42

damer
Member
Registered: 2019-02-17
Posts: 45

Re: GLPI 9.3.3 à 9.4.0 problème

Bonjour ,

J'ai peut être une piste pour la version 9.4 ou la 9.4.1
les nouvelles version utilises le Sass / Scss .
cependant le PHP / Apache via le naviguateur ne reconnait pas ce format
et je n'arrive pas à l'ajoiuter dans apache
Avez vous une piste pour l'ajouter ou me dire exactement les module à ajouter
merci d'avance pour votre
aide
Damer

Ps : pour se problème il ne faut pas faire une mise nécessairement (cela ne fonctionne pas après une mise et avec une nouvelle installation.

Last edited by damer (2019-03-24 16:25:00)

Offline

#8 2019-03-25 12:33:39

Montesquieu
Member
Registered: 2019-02-28
Posts: 5

Re: GLPI 9.3.3 à 9.4.0 problème

damer wrote:

Bonjour ,

J'ai peut être une piste pour la version 9.4 ou la 9.4.1
les nouvelles version utilises le Sass / Scss .
cependant le PHP / Apache via le naviguateur ne reconnait pas ce format
et je n'arrive pas à l'ajoiuter dans apache
Avez vous une piste pour l'ajouter ou me dire exactement les module à ajouter
merci d'avance pour votre
aide
Damer

Ps : pour se problème il ne faut pas faire une mise nécessairement (cela ne fonctionne pas après une mise et avec une nouvelle installation.

Je comprends pas très bien, le SASS / SCSS s'execute comme du HTML, côté client et non serveur, en quoi cela poserait problématique au niveau de la mise à jour ?

J'ai regardé les pré-requis d'installation, je possède tout les modules et tout ce qu'il faut pourtant:

https://glpi-install.readthedocs.io/fr/ … sites.html

Offline

#9 2019-03-26 12:43:49

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 14,930

Re: GLPI 9.3.3 à 9.4.0 problème

Vous n'avez toujours pas postés les logs demandés


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#10 2019-03-26 12:48:00

Montesquieu
Member
Registered: 2019-02-28
Posts: 5

Re: GLPI 9.3.3 à 9.4.0 problème

yllen wrote:

Vous n'avez toujours pas postés les logs demandés

Pour ma part je ne peux pas, je fais une restauration du serveur complète quand je me plante sur la mise à jour GLPI

Offline

#11 2019-03-31 13:04:53

damer
Member
Registered: 2019-02-17
Posts: 45

Re: GLPI 9.3.3 à 9.4.0 problème

Bonjour,

Version glpi 9.4
Voici le problème avec le lien ci dessous
https://snag.gy/7h41z2.jpg

Voici les logs :

PHP ERRORS

[2019-02-20 21:26:14] glpiphplog.WARNING: Test logger 
[2019-02-20 21:32:35] glpiphplog.WARNING: Test logger 
[2019-02-20 21:37:30] glpiphplog.WARNING: Test logger 
[2019-02-20 21:39:18] glpiphplog.DEBUG: Html::compileScss() in /var/www/glpi094/inc/html.class.php line 6688
css/styles is new, loading  {"user":"@srvubutuglpideux"}
[2019-02-20 21:39:18] glpiphplog.DEBUG: Html::compileScss() in /var/www/glpi094/inc/html.class.php line 6688
css/palettes/auror is new, loading  {"user":"@srvubutuglpideux","mem_usage":"0.000\", 1.09Mio)"}
[2019-02-20 21:43:45] glpiphplog.WARNING: Test logger 

EVENT LOG

2019-02-20 21:40:08 [@srvubutuglpideux]
[login] 3: glpi se connecte depuis l'IP 192.168.0.34
2019-03-24 14:17:20 [@srvubutuglpideux]
[login] 3: glpi se connecte depuis l'IP 192.168.0.34

CRON LOG

2019-02-20 21:39:48 [@srvubutuglpideux]
Interne #1 : Démarrage createinquest
2019-02-20 21:47:38 [2@srvubutuglpideux]
Interne #1 : Démarrage watcher
2019-02-23 11:54:12 [@srvubutuglpideux]
Interne #1 : Démarrage ticketrecurrent
2019-02-23 11:55:56 [@srvubutuglpideux]
Interne #1 : Démarrage planningrecall
2019-03-09 21:50:02 [@srvubutuglpideux]
Interne #1 : Démarrage queuednotification
2019-03-15 20:17:59 [@srvubutuglpideux]
Interne #1 : Démarrage queuednotificationclean
2019-03-15 20:23:31 [@srvubutuglpideux]
Interne #1 : Démarrage temp
2019-03-15 20:25:19 [@srvubutuglpideux]
Interne #1 : Démarrage mailgateerror
2019-03-16 10:32:55 [@srvubutuglpideux]
Interne #1 : Démarrage contract
2019-03-16 10:35:23 [@srvubutuglpideux]
Interne #1 : Démarrage infocom
2019-03-17 13:32:39 [@srvubutuglpideux]
Interne #1 : Démarrage mailgate
2019-03-17 13:35:34 [@srvubutuglpideux]
Interne #1 : Démarrage session
2019-03-17 13:36:08 [@srvubutuglpideux]
Interne #1 : Démarrage graph
2019-03-23 11:49:04 [@srvubutuglpideux]
Interne #1 : Démarrage reservation
2019-03-23 11:57:50 [@srvubutuglpideux]
Interne #1 : Démarrage closeticket
2019-03-23 11:58:42 [@srvubutuglpideux]
Interne #1 : Démarrage alertnotclosed
2019-03-23 12:00:28 [@srvubutuglpideux]
Interne #1 : Démarrage slaticket
2019-03-23 12:30:09 [@srvubutuglpideux]
Interne #1 : Démarrage olaticket
2019-03-24 14:17:04 [@srvubutuglpideux]
Interne #1 : Démarrage createinquest
2019-03-24 14:23:23 [2@srvubutuglpideux]
Interne #1 : Démarrage watcher
2019-03-24 18:45:32 [@srvubutuglpideux]
Interne #1 : Démarrage planningrecall
2019-03-24 19:10:17 [@srvubutuglpideux]
Interne #1 : Démarrage ticketrecurrent
2019-03-24 19:11:50 [2@srvubutuglpideux]
Interne #1 : Démarrage queuednotification
2019-03-24 19:13:03 [@srvubutuglpideux]
Interne #1 : Démarrage temp
2019-03-24 19:18:13 [@srvubutuglpideux]
Interne #1 : Démarrage queuednotificationclean
2019-03-24 19:18:16 [@srvubutuglpideux]
Interne #1 : Démarrage mailgateerror
2019-03-24 19:18:18 [@srvubutuglpideux]
Interne #1 : Démarrage contract
2019-03-24 19:18:19 [@srvubutuglpideux]
Interne #1 : Démarrage infocom
2019-03-24 19:18:20 [@srvubutuglpideux]
Interne #1 : Démarrage mailgate
2019-03-24 19:18:21 [@srvubutuglpideux]
Interne #1 : Démarrage graph
2019-03-24 19:18:22 [@srvubutuglpideux]
Interne #1 : Démarrage session
2019-03-24 19:18:28 [@srvubutuglpideux]
Interne #1 : Démarrage slaticket
2019-03-24 19:18:42 [@srvubutuglpideux]
Interne #1 : Démarrage olaticket
2019-03-24 19:20:34 [@srvubutuglpideux]
Interne #1 : Démarrage reservation
2019-03-24 19:21:17 [@srvubutuglpideux]
Interne #1 : Démarrage closeticket
2019-03-24 19:31:24 [@srvubutuglpideux]
Interne #1 : Démarrage alertnotclosed
2019-03-31 12:34:56 [@srvubutuglpideux]
Interne #1 : Démarrage planningrecall

Merci pour votre aide

Offline

#12 2019-04-05 12:37:07

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 14,930

Re: GLPI 9.3.3 à 9.4.0 problème

Damer : merci de poster votre configuration complète (Configuration > Générale > onglet Système)


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#13 2019-04-14 15:51:31

damer
Member
Registered: 2019-02-17
Posts: 45

Re: GLPI 9.3.3 à 9.4.0 problème

Bonjour ,

ce jour j'ai suivi l'url : https://glpi-install.readthedocs.io/en/ … ht=php.ini

Je n'ai pas encore testé la mise jour mais j'ai testé simplement l'installation 9.4.0 et 9.4.1 et ceci fonctionne après les ajout de certains modules
et l'ajout dans php.ini a la fin du fichier

/etc/php/7.2/apache2 (version ubuntu server )

memory_limit = 64M ;        // max memory limit
file_uploads = on ;
max_execution_time = 600 ;  // not mandatory but adviced
register_globals = off ;    // not mandatory but adviced
magic_quotes_sybase = off ;
session.auto_start = off ;
session.use_trans_sid = 0 ; // not mandatory but adviced

cependant après les modifications je dois encore tester la
les mise à jour entre version. et l'installation et mise à jour de la dernière version 9.4.2
je vous tiens au courant si je constate un problème.

cependant j'ai eux un problème avec l'installation de certains modules

    session: to get user sessions support; NOT OK
    zlib: to get backup and restore database functions; NOT OK
   
Optional extensions

  openssl: secured communications; NOT OK

avez vous une idée pourquoi les modules php ci dessous ne sont pas installable.
merci
Damer

Last edited by damer (2019-04-14 16:09:43)

Offline

#14 2019-05-10 21:37:41

damer
Member
Registered: 2019-02-17
Posts: 45

Re: GLPI 9.3.3 à 9.4.0 problème

Bonjour,
comme je n'ai pas eux de réponse au problème ci dessus.
ceci peut être cloturé
merci

Offline

Board footer

Powered by FluxBB