You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2019-01-18 11:45:04

Cool_Head
Guest
Registered: 2010-02-24
Posts: 20

Grosse mise à jour de Glpi

Bonjour,

Je migre mon glpi d'un Windows 2008 R2 utilisant Xampp (Apache 2.4.23 / MySQL 5.6.32 [mariadb]) à un W2016 (IIS, MySQL 8).
Je ne parviens pas à exporter la base 'Glpi' que se soit depuis phpmyadmin ou depuis des mysqldump en ligne de commande.
L'outil de Glpi d'export reste à 0%.

En passant par phpMyadmin, j'ai un fichier de 18M. A l'import dans le nouveau phpMyadmin j'ai : "Incorrect format parameter"
En passant par les lignes de command : "mysqldump -u root -p --opt glpi > c:\tmp\glpi-2019.sql" => mysqldump: Got error: 1932: "Table 'glpi.glpi_plugin_mobile_options' doesn't exist in engine" when using LOCK TABLES

Comment résoudre ce type de problème ?

Offline

#2 2019-01-21 11:35:51

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 15,037

Re: Grosse mise à jour de Glpi

L"outil d'export/import fourni par GLPI est pour les petites structures.

Lors du changement de serveur, changez-vous également la version de GLPI ?
Si oui, il faut, sur le nouveau serveur installer la même version de GLPI que votre ancien serveur et laisser GLPI faire sa migration.


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#3 2019-01-22 13:00:22

Cool_Head
Guest
Registered: 2010-02-24
Posts: 20

Re: Grosse mise à jour de Glpi

Non. J'ai avant tout updaté l'ancien serveur en GLPI 9.3.3 pour qu'il soit en phase avec le nouveau.

J'ai désormais accès à l’installation de Glpi mais je bloque sur l'authentification.
A la connexion du superuser "glpi" j'ai l'erreur : Identifiant ou mot de passe incorrect avec le password par défaut
Si j'utilise le password que de lancienne base, je bocle sur le page login avec le message "Utilisation invalide de l'identifiant de session"

Ce qui est étrange aussi, c'est que depuis l'interface de l'ancien serveur j'ai le choix authentification 'display_login_source' et pas sur le nouveau.

Offline

#4 2019-01-22 13:54:08

Cool_Head
Guest
Registered: 2010-02-24
Posts: 20

Re: Grosse mise à jour de Glpi

Problème d'interface (choix de mode d'authentification) ok.

Maintenant ce n'est vraiment plus que : "invalid use of session" pour chaque connexion avec un login/password correct.
Je ne peux plus entrer dans mon Glpi; même en admin avec le compte glpi.

Offline

#5 2019-01-24 10:16:14

Cool_Head
Guest
Registered: 2010-02-24
Posts: 20

Re: Grosse mise à jour de Glpi

Marquer comme résolu.

[j'ai tjrs le problème "invalid use of session" mais j'ouvre un autre ticket car ce n'est plus en lien avec le demande initiale]

Offline

Board footer

Powered by FluxBB