You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2019-01-04 18:08:52

RussBurden
Member
Registered: 2019-01-03
Posts: 2

File Injection (datainjection) Plugin issue

I would post in the plugin section, but it appeared to be all French, so I'll give it a go here,

GLPI 9.3.3
File Injection 2.6.4
Ubuntu 18.04.1 LTS

I am attempting to create mappings in my model so I can import data into the inventory.  I create a new model and import a file to inject, but the header row appears as one long line instead of individual headers.  This file is a standard CSV, and I tried with header and data, and just the header row.  Quotes around the headers and no quotes.  I don't know if this is a bug or I'm doing something wrong,  the documentation for this plugin is basically non-existent unless I'm missing that as well.

Any help would be appreciated.

Offline

#2 2019-02-12 22:58:51

sbirl
Guest
From: Pennsylvania
Registered: 2018-08-13
Posts: 11

Re: File Injection (datainjection) Plugin issue

I wish to help, but Im going to complain instead.  The interface is not intuitive.

Im trying to import a 5000-line CSV of computers from GLPI 0.83.7 (no I cant simply bring over the glpi_computers table).

Under the "Mappings" tab the 1st line of the CSV, not a header line, is also being treated as 1-long line surrounded by parenthesis:
    (1,0,'','','','','',0,1,'','2018-01-19 14:20:28',0,0,0,NULL,NULL,0,241,0,0,136,225,1,'Server Template',0,1,' ',0,0,1,0,0,NULL,NULL,0,-1,5,-1,897,0,'',0.0000,NULL),

The next step/tab "Additional Information" also lacks any tips on how to proceed ...

Even browsing to /glpi/plugins/datainjection/docs/ is pointless.

Offline

#3 2019-02-12 23:05:53

sbirl
Guest
From: Pennsylvania
Registered: 2018-08-13
Posts: 11

Re: File Injection (datainjection) Plugin issue

Oh! I think I found the bug: I went back to the first tab, the "Model" tab, and noticed that under "Specific file format options" both "Header's presence" and "File delimitor" were incorrect (Yes instead of No, and, semicolon instead of comma, respectively).

Once I updated those two fields, re-did the "File to inject" tab, the "Mappings" tab was much more appropriate to work with.

So, in case you havent already figured it out (a month later) double-check your "Model" settings.

Offline

Board footer

Powered by FluxBB