You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2018-12-20 18:48:33

rfaure
Member
Registered: 2018-12-20
Posts: 2

GLPI 9.3.1 - Authentification LDAP pb connexion

Bonjour à tous,

Je rencontre un pb avec GLPI 9.3.1 installé sous WAMP, les utilisateurs de l'entité racine, se connecte via synchro LDAP mais les utilisateurs ayant des comptes AD avec des mdp vide ne peuvent pas se connecter à GLPI, un message veuilez renseigner ce champs s'affiche au niveau du champs Mot de passe et bloque la connexion.

Y a t'il une option à activer pour autoriser ces utilisateurs à ce connecter avec leur compte sans mdp en gardant la synchro LDAP active ?


Cordialement,

Offline

#2 2019-01-04 17:04:19

Mr.Propre
Guest
Registered: 2016-10-12
Posts: 64

Re: GLPI 9.3.1 - Authentification LDAP pb connexion

Pas testé mais as-tu tenté la modification du code HTML de la page ?
Enlever l'élément required sur la ligne :

<input type="password" name="fieldxxxxxxxx" id="login_password" required="required" placeholder="Mot de passe"  />

Version 9.4.2 sous Debian

Offline

#3 2019-01-07 17:15:09

rfaure
Member
Registered: 2018-12-20
Posts: 2

Re: GLPI 9.3.1 - Authentification LDAP pb connexion

Bonjour,

J'ai essayé la modification sur la page index.php, suit à cette modification j'ai maintenant une redirecton vers la page de login avec le message Identifiant ou mot de passe vide, lorsque je test la connexion avec un utilisateur LDAP sans mot de passe.

La connexion fonctionne lorsque je définie un mot de passe à l'utilisateur LDAP.

Cordialement,

Offline

Board footer

Powered by FluxBB