You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2018-12-13 21:25:19

totoec
Member
Registered: 2018-12-10
Posts: 9

problemas al loguearse usuario LDAP GLPI

Hola a todos,

Tengo un problema al loguearse cierto usuario en el GLPI version 9.2.3 , le sale un mensaje "Usted no tiene acceso a esta aplicacion debido a que su cuenta fue desactivada o eliminada",

ya revise la conexion del GLPI con LDAP y esta correcto, lo que me estaba fijando es que del active directory borre 2 grupos, y en el glpi esos grupos estaban como Dinamicos ,ahora como borre esos grupos LDAP, en el GLPI ya no tengo esos grupos pero si estan otros grupos que no estan como Dinamicos. Al no estar esos grupos Dinamicos no me deja Loguearme como usuario LDAP, para probar en el Active Directory le agrege nuevamente el grupo que le borre, y al intentar loguearme como usuario LDAP Walla!! Funciona.


Hay alguna forma de poner a un grupo de GLPI como dinamico ya que eso le veo como solucion.

Gracias por su ayuda

Offline

#2 2018-12-14 16:34:37

totoec
Member
Registered: 2018-12-10
Posts: 9

Re: problemas al loguearse usuario LDAP GLPI

alguien que le haya pasado esto?  muchas gracias

Offline

#3 2018-12-18 23:04:22

makeijan
Guest
From: Pontevedra, Galicia
Registered: 2008-01-29
Posts: 185
Website

Re: problemas al loguearse usuario LDAP GLPI

No entiendo muy bien el comportamiento.
Lo que si te puedo decir es que un grupo dinámico es el que se crea de manera automática.
Sin verlo es díficil identificar el problema.
Saludos

Offline

#4 2018-12-19 16:37:12

totoec
Member
Registered: 2018-12-10
Posts: 9

Re: problemas al loguearse usuario LDAP GLPI

Gracias makeijan

te explico mas como surgio el problema, hace semanas atras el GLPI funcionaba sin ningun problema, pero hace unos dias mi compañero de Redes creo en el Active Directory una politica que si te equivocas 3 veces al ingresar tu clave de usuario, la cuenta de usuario se bloqueaba, eso afectaba a nivel de Active Directory, como GLPI ocupa esa conexion habia usuarios que no podian loguearse al GLPI yo pense que era problema solo de Active Directory pero mi compañero de Redes luego de activar de nuevo al usuario, el usuario implicado se intengo loguearse y aparecio el mensaje "Usted no tiene acceso a esta aplicacion debido a que su cuenta fue desactivada o eliminada".

Como presuncion vi con el super usuario del GLPI que hay usuarios que tiene grupos Dinamicos y grupos normales,


vi que en ciertos usuarios que no pueden loguearse no tenian grupos dinamicos , asi que vi otro usuario que si pudo loguearse vi el grupo dinamico y ese grupo lo añadi al usuario (Active Directory) que no podia loguearse,
luego en el glpi sincronize ese usuario y intengo loguearse y funciono, lo malo es que no se cumple con todos los usuarios que no pueden loguearse.

Hay una opcion en "Configuracion->Autentificación->Configuracion" "Acción cuando un usuario es borrado del directorio LDAP" estaba en Deshabilitar y le cambie a Preservar.

Intente tambien el script "ldap_mass_sync.php" para sincronizar todos los usuarios, pero igual sigue algunos usuarios sin poder loguearse en el GLPI 

Muchas Gracias por su ayuda

Offline

Board footer

Powered by FluxBB