You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2017-11-22 12:35:55

asphe
Guest
Registered: 2017-01-31
Posts: 10

Cron : Ne peut récupérer le verrou de la DB

Bonjour,

J'ai installé GLPI 9.1.1 sur un serveur Ubuntu.

J'ai configuré mon cron.php pour qu'il mette mes actions automatiques en route, celui-ci fonctionne toutes les minutes.

Sur GLPI, les actions automatiques sont en CLI avec 1minute de fréquence.

Le problème que je rencontre c'est que assez régulièrement pendant environ 15minutes (soit 15 tentatives), les actions automatiques ne se déclenchent pas.
L'action mailgate reste figée en "en cours d'éxecution" tant que le problème persiste.

Lorsque je vais dans les logs de cron, j'ai un message :


2017-11-21 21:47:01 [@monserveur]
Ne peut récupérer le verrou de la DB

Cela est assez gênant car mailgate ne fonctionne pas pendant cette période. Je n'ai rien trouvé sur le sujet, si vous avez une idée je suis preneur.

Merci d'avance ! smile

Offline

#2 2017-11-22 12:42:51

machadomall
Guest
From: Brazil, Brasilia, DF
Registered: 2011-10-30
Posts: 169

Re: Cron : Ne peut récupérer le verrou de la DB

Hello,

I do not know if the problem, in my first time I installed GLPI in Debian I had this problem with PHP7, I did a new installation and I installed PHP5.6 and I did not have that problem anymore.

I believe that the problem is in PHP7, I've seen this in several cases.
Today I use the version of GLPI 9.2.1 in Centos 7, PHP5.6 and MariaDB, I used the repository of Remi Collet which by the way is perfect.

Hugs.


Márcio Machado
Brasília-DF / Brasil

Offline

#3 2017-11-23 09:04:24

asphe
Guest
Registered: 2017-01-31
Posts: 10

Re: Cron : Ne peut récupérer le verrou de la DB

Bonjour,

Problème résolu.

Il s'agit d'un message d'erreur lié au collecteur en erreur de connexion.
J'ai désactivé le collecteur, arrêté via l'interface web GLPI les actions automatiques en cours d'execution puis réinitialisé les dernières dates d'executions et tout placé en mode GLPI et non CLI.
Dans les logs de cron j'ai pu voir que le fait qu'aucune action CLI soit active a été détecté. j'ai donc ensuite remis les actions mailgate etc en mode CLI et tout fonctionne.

----------------------------

Hello machadomall,

Thanks for your help yesterday I tried to repeat my problem on a same hardware, os configuration but with php5 instead of php7. I had the same problem, did you have a connexion's error on your mail collector ?
As I said at the top of my answer, I just disabled the collector because it was in error and it works for me.

Offline

Board footer

Powered by FluxBB