You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2017-09-28 15:13:22

netsyspro
Guest
Registered: 2012-09-13
Posts: 32

MAJ de 9.2-RC1 à 9.2

Salut,

J'ai la version 9.2-RC1 installée et quand j'ai voulu passer à la version 9.2-RC2, j'ai eu un msg d'erreur qui ressemble à "it is not possible to update from a development version to another development version", çàd, "il n'est pas possible de mettre à jour d'une version beta à une autre version beta".

Quand la version finale 9.2 est sortie, j'ai essayé de faire une maj de 9.2-RC1 à 9.2, et là j'ai le msg d'erreur "You are trying to use GLPI with outdated files compared to the version of the database. Please install the correct GLPI files corresponding to the version of your database.", çàd, "vous essayez d'utiliser GLPI avec des fichiers qui sont obsolètes par rapport à la version de la base de données. Merci d'installer la bonne version de fichiers de GLPI qui correspond à la version de votre base de données".

Qqun peut m'aider svp ?

Merci

Offline

#2 2017-09-28 18:22:17

netsyspro
Guest
Registered: 2012-09-13
Posts: 32

Re: MAJ de 9.2-RC1 à 9.2

Au cas où personne n'a une idée comment résoudre ce pb, est-ce que si
   1. je ré-installe GLPI à zéro, çàd, nouvelle base et en utilisant la dernière version des fichiers,
   2. et qu'ensuite, j'importe une sauvegarde de la base de données de la version 9.2-RC1,
   3. et que j'écrase les fichiers dans le sous-dossier "files",
cela résoudra le pb ?

Merci de votre aide.

Last edited by netsyspro (2017-09-28 18:22:49)

Offline

#3 2017-09-28 18:57:50

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 14,405

Re: MAJ de 9.2-RC1 à 9.2

Pour les pages de GLPI, vous les avez récupéré où ? dans le tar.gz de la release ou sur github ?


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#4 2017-09-29 10:47:27

netsyspro
Guest
Registered: 2012-09-13
Posts: 32

Re: MAJ de 9.2-RC1 à 9.2

Offline

#5 2017-10-02 13:07:27

netsyspro
Guest
Registered: 2012-09-13
Posts: 32

Re: MAJ de 9.2-RC1 à 9.2

Est-ce que le release sur GitHub est OK ?

Offline

#6 2017-10-02 14:17:56

LaDenrée
HELPER
Registered: 2012-11-19
Posts: 4,286

Re: MAJ de 9.2-RC1 à 9.2

bonjour,
pour avoir une mise à jour propre il faut repartir de la dernière version stable cad 9.1 et pas de la 9.2 RC-1. c'est pour ça que les "releases canditate" ne doivent pas être utilisée en prod( en plus du risque d'avoir plusieurs bugs non corrigés)


Trouver la panne avant de réparer...
*GLPI 9.1.6+fusion9.1+1.1+behaviours1.5.0+reports+fields+appliances+pdf+badges+formcreator2.5.2 PHP7.0 Mariadb10
*GLPI 9.2.4(behaviours1.5.2+fusion9.2+1.0+applicatifs2.3.0+dashboard 0.8.9)hebergé sur serveur mutualisé.
*GLPI 9.3.3  en test (ubuntu 18.04 mariadb 10.2.4)

Online

#7 2017-10-02 14:32:06

netsyspro
Guest
Registered: 2012-09-13
Posts: 32

Re: MAJ de 9.2-RC1 à 9.2

OK. Cela m'apprendra :-(
Et que puis-je faire maintenant pour repasser à la version 9.1 stable ?

Offline

#8 2017-10-02 17:56:52

netsyspro
Guest
Registered: 2012-09-13
Posts: 32

Re: MAJ de 9.2-RC1 à 9.2

Ou est-ce qu'il y a un autre moyen de résoudre ce pb ?

Merci

Offline

#9 2017-10-04 16:56:21

netsyspro
Guest
Registered: 2012-09-13
Posts: 32

Re: MAJ de 9.2-RC1 à 9.2

Quelqu'un peut m'aider svp ?

Offline

#10 2017-10-04 17:07:47

alexccl
Guest
Registered: 2017-10-04
Posts: 23

Re: MAJ de 9.2-RC1 à 9.2

pour un autre problème, j'ai du repartir d'une installation propre.
Tu sauvegarde la bdd dans maintenance, tu copie ton dossier glpi pour sauvegarde.

Tu efface la bdd et le dossier glpi.
Tu réinstalle en partant de zero.

Après une fois démarré, tu colle la sauvegarde (maintenance) tu écrase le dossier glpi/files par ta sauvegarde de files/ et tu remonte ta bdd a partir du menu maintenance

.... important les sauvegarde attention ..!

Je pense que ça doit marcher entre la RC9.2 et la 9.2

Last edited by alexccl (2017-10-04 17:08:23)

Offline

#11 2017-10-04 17:14:23

netsyspro
Guest
Registered: 2012-09-13
Posts: 32

Re: MAJ de 9.2-RC1 à 9.2

OK je vais essayer cela ce soir et te tiendrai informé.

Merci de tes conseils.

Offline

#12 2017-10-05 08:35:33

netsyspro
Guest
Registered: 2012-09-13
Posts: 32

Re: MAJ de 9.2-RC1 à 9.2

La sauvegarde à partir de la page "Maintenance" sur l'interface GLPI est hyper lente.
J'ai effectué un dump avec mysqldump en ligne de commande.
Je poste les résultats dans quelques minutes.

Offline

#13 2017-10-05 08:59:48

netsyspro
Guest
Registered: 2012-09-13
Posts: 32

Re: MAJ de 9.2-RC1 à 9.2

Ça marche pas :-(
J'ai le msg d'erreur "You are trying to use GLPI with outdated files compared to the version of the database. Please install the correct GLPI files corresponding to the version of your database."

Une idée ?

Offline

#14 2017-10-05 09:02:01

alexccl
Guest
Registered: 2017-10-04
Posts: 23

Re: MAJ de 9.2-RC1 à 9.2

quand tu a installé la version remise à zero ça a démarré correcetement ?

Offline

#15 2017-10-05 11:53:06

netsyspro
Guest
Registered: 2012-09-13
Posts: 32

Re: MAJ de 9.2-RC1 à 9.2

Oui et j'ai pu installer une instance fraîche (nouvelle base et fichiers) de la version 9.2.

Offline

#16 2017-10-05 15:22:12

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 14,405

Re: MAJ de 9.2-RC1 à 9.2

Dans le fichier inc/define.php quelle est la valeur de GLPI_VERSION ?
Dans la table glpi_configs quelle est la valeur du champ name 'version' ?


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#17 2017-10-06 16:49:34

netsyspro
Guest
Registered: 2012-09-13
Posts: 32

Re: MAJ de 9.2-RC1 à 9.2

yllen,

J'ai restauré la version 9.2-dev :
   Dans le fichier inc/define.php quelle est la valeur de GLPI_VERSION ? => 9.2-dev
   Dans la table glpi_configs quelle est la valeur du champ name 'version' ? => 9.2-dev

Last edited by netsyspro (2017-10-06 16:57:59)

Offline

#18 2017-10-09 12:05:59

netsyspro
Guest
Registered: 2012-09-13
Posts: 32

Re: MAJ de 9.2-RC1 à 9.2

Bonjour,

Quelqu'un peut m'aider svp ? yllen, ... ?

Offline

#19 2017-10-09 15:11:13

alexccl
Guest
Registered: 2017-10-04
Posts: 23

Re: MAJ de 9.2-RC1 à 9.2

Tu peux essayer de voir ce qu'il y dans les mêmes fichier d'une installation vierge et mettre pareil sur ton backup.

Offline

#20 2017-10-09 17:53:39

netsyspro
Guest
Registered: 2012-09-13
Posts: 32

Re: MAJ de 9.2-RC1 à 9.2

Alex,

Je ne suis pas sûr d'avoir bien compris : tu veux que je regarde la valeur de ces 2 variables/constants dans une installation vierge, OK.
Mais à quel backup fais-tu allusion ? En ce moment, je n'ai que l'instance 9.2-dev qui est utilisée.

Offline

#21 2017-10-10 11:10:01

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 14,405

Re: MAJ de 9.2-RC1 à 9.2

Dans le difne.php supprimer -dev à la fin du nom de la version et relancer la migration


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#22 2017-10-10 15:16:08

netsyspro
Guest
Registered: 2012-09-13
Posts: 32

Re: MAJ de 9.2-RC1 à 9.2

yllen,

J'ai besoin de plus de détails concernant ce qu'il faut faire exactement, et en quel ordre ?
Peux-tu me détailler les étapes stp ?

Merci

Offline

#23 2017-10-10 15:25:26

netsyspro
Guest
Registered: 2012-09-13
Posts: 32

Re: MAJ de 9.2-RC1 à 9.2

Pour info :
J'ai essayé de faire comme ci-dessous sans succès :
1. Pour rappel, j'utilise la version 9.2-dev en ce moment
2. J'ai supprimé "-dev" dans le fichier inc/define.php et rechargé la page dans le navigateur. Résultat : "You are trying to use GLPI with outdated files compared to the version of the database. Please install the correct GLPI files corresponding to the version of your database."
3. J'ai supprimé "-dev" dans le tableau glpi_configs de la bdd et rechargé la page dans le navigateur. Résultat : GLPI fonctionne "normalement", çàd, la page de migration n'est pas chargée.

Offline

#24 2017-10-11 15:18:10

netsyspro
Guest
Registered: 2012-09-13
Posts: 32

Re: MAJ de 9.2-RC1 à 9.2

Quelqu'un a une suggestion svp... ?

Merci...

Offline

#25 2017-10-11 17:11:13

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 14,405

Re: MAJ de 9.2-RC1 à 9.2

Si vous avez une version 9.2-dev et que vous voulez mettre la version 9.2 stable, il faut prendre les fichiers dans le paquet de la release et non dans les fichiers de github.
En effet, sous github c'est toujours une version de dev.


CentOS 6.5 - CentOS 7
PHP 5.6 - PHP 7 - MySQL 5.6  + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

Board footer

Powered by FluxBB