You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2005-12-02 17:05:55

François Coulier
Guest
Registered: 2005-12-02
Posts: 2

extension mysql?

Bonjour,

J'essaye d'installer GLPI sur mon PC, mais je ne passe pas l'étape 2, pour laquelle j'ai deux erreurs:
1) Vous devez compiler votre php avec l'extension Mysql.
2) GLPI ne peux pas fonctionner correctement sans les fonctions utf8_encode et utf8_decode ; Essayez d'activer le support du XML pour PHP


Pour le moment, j'essaye de résoudre la 1ère erreur (pb aves mysql), je verrais après pour UTF8.

Je tourne sous Mandrake 9.1, mysql 4.0.11, phpmysql 4.3, lipbphp-common 430, apache 2.0, apache2-mod-php 2.0.44.

/etc/php.ini contient la ligne "extension=msql.so" (et httpd a été redémarré après la modif de php.ini)
php.ini est bien lu (et j'ai pu résoudre un problème de mémoire allouée, par exemple)

Php et mysql fonctionne par ailleurs sur la même machine, par exemple avec SPIP, et je ne comprends pas pourquoi il faut que je recompile php.

Toute aide est la bienvenue....


François

Offline

#2 2005-12-03 01:23:02

JMD
GLPI - Lead
Registered: 2004-09-13
Posts: 9,180
Website

Re: extension mysql?

Bonsoir,

Pour ce qui est de la mémoire allouée, cela ne bloque pas l'installation.


Pour le point 1 nous avons trés rarement ce retour de bug mais nous l'avons tout de meme quelque fois et nous n'avons toujours pas réussi à cerner le pb.

Aussi je vais vous demander de tester cette manip et de m'indiquer le résultat obtenu ;

Editez le fichier install.php  situé à la racine GLPI.

Ligne 268 , remplacez :

if(!function_exists("mysql_connect")) {

Par

if(!function_exists("mysql_query")) {

Cela devrait réglér votre point 1.

Pour le point 2 : il y a déjà eut des réponses à ce sujet sur le forum faites une petite recherche vous devriez trouvez.

Tenez moi au courant.


JMD / Jean-Mathieu Doléans - Glpi-project.org - Association Indepnet
Apportez votre pierre au  projet GLPI   : Soutenir     Contribuer

Offline

#3 2005-12-05 15:33:46

François Coulier
Guest
Registered: 2005-12-02
Posts: 2

Re: extension mysql?

Merci!

Ça roule.

François

Offline

#4 2006-02-06 12:55:28

ryu31
Guest
Registered: 2006-02-06
Posts: 4

Re: extension mysql?

bonjour,


Il me reste egalement un probleme lors de la phase d'install. glpi :

> "Vous devez compiler votre php avec l'extension Mysql"

j'ai effectuer la modif.:
remplacez :

if(!function_exists("mysql_connect")) {

Par

if(!function_exists("mysql_query")) {

--> ligne 244    (ligne 268 indique:   case "M" : $mem*=1024;)

redemarrer le server apache..



Le prob. persiste ! ??

Que puis-je pour solutionner ce prob .?



Merci pour vos reponses '

bonne journee

ryu.31@voila.fr

Offline

#5 2006-02-06 14:02:13

tomdak
Guest
Registered: 2006-01-05
Posts: 55

Re: extension mysql?

tu est sous kel version linux??

Offline

#6 2006-02-06 15:29:30

ryu31
Guest
Registered: 2006-02-06
Posts: 4

Re: extension mysql?

version distrib. : Red Hat Linux release 8.0
version noyau : 2.4.18-14



cdt,

Offline

#7 2006-02-06 16:17:29

tomdak
Guest
Registered: 2006-01-05
Posts: 55

Re: extension mysql?

installe php-mysql

Offline

#8 2006-02-06 17:08:36

ryu31
Guest
Registered: 2006-02-06
Posts: 4

Re: extension mysql?

c'etait deja fait: 

mysql-4.0.15

php-4.3.10



les 2 services tournent.



cdt,

Offline

#9 2006-02-06 18:39:32

JMD
GLPI - Lead
Registered: 2004-09-13
Posts: 9,180
Website

Re: extension mysql?

Les deux services peuvent tourner mais si le module php-mysql n'est pas installé , php est incapable de communiquer avec mysql.

D'aprés l'erreur que vous remontez, il semble que votre pb vienne de là.

Si ce n'est pas le cas et pour éviter d'incriminer GLPI, il y a t'il d'autres applis php-mysql qui tournent sur votre serveur ?


JMD / Jean-Mathieu Doléans - Glpi-project.org - Association Indepnet
Apportez votre pierre au  projet GLPI   : Soutenir     Contribuer

Offline

#10 2006-02-07 18:30:12

ryu31
Guest
Registered: 2006-02-06
Posts: 4

Re: extension mysql?

bonjour,


je viens d'installer le module:

[root@fc1 root]# rpm -qa |grep php
php-4.2.2-8.0.5
php-imap-4.2.2-8.0.5
php-mysql-4.0.2-1
php-ldap-4.2.2-8.0.5


toujours la meme erreur, phase1:
" Vous devez compiler votre php avec l'extension Mysql "


qu'est-je puis oublier ??




Merci!

Offline

#11 2006-02-07 18:34:46

chacawaca
Guest
From: Québec
Registered: 2005-07-11
Posts: 513

Re: extension mysql?

P-E aller faire un tour sur le forum de votre distribution, ils seront mieux en mesure de vous aidez pour faire fonctionner mysql php et apache ensemble.

Last edited by chacawaca (2006-02-07 18:35:39)

Offline

#12 2006-02-07 18:46:32

JMD
GLPI - Lead
Registered: 2004-09-13
Posts: 9,180
Website

Re: extension mysql?

Je pige pas là si tout est installé et configuré corrrectement , il n'y a pas de raison que GLPI vous affiche ce message d'érreur.

Le test fait par GLPI est vraiment simple if(!function_exists("mysql_query"))

Si mysql_query ne fonctionne pas c'est qu'il y a un pb.

Créez un fichier test.php avec le contenu ci-dessous et pointez dessus avec un navigateur :

<?php

echo "Test de l'extension php pour mysql";

if (!function_exists('mysql_query')){
        
echo "L'extension n'est pas installée";
}else{
echo "L'extension est installée";
}

?>

Si ça marche pas, c'est que le pb ne vient pas de GLPI, il faudra donc aller voir sur d'autres forums.


JMD / Jean-Mathieu Doléans - Glpi-project.org - Association Indepnet
Apportez votre pierre au  projet GLPI   : Soutenir     Contribuer

Offline

#13 2006-02-08 09:40:57

tomdak
Guest
Registered: 2006-01-05
Posts: 55

Re: extension mysql?

a tu installé le paquet php-mysql??
perso pour moi ce paquet qui ma retirer ce petit pb sous mandriva 2006!!

Last edited by tomdak (2006-02-08 09:42:22)

Offline

#14 2006-07-21 14:18:55

winsa
Guest
Registered: 2006-06-14
Posts: 39

Re: extension mysql?

Voila je veux installer glpi sur une distrib REDHAT. seulement au moment des test j'ai le message "Vous devez compiler votre php avec l'extension Mysql."

J'ai donc regarder le fichier install.php a la racine de glpi mais celui ci a deja subit la modification et pourtant toujours le même soucis.

j'ai :

php-mysql 4.2.2-2
php 4.2.2.2
mysql 3.23.58

c'est koi le problème ????

Offline

#15 2006-07-21 15:16:58

tsmr
GLPI-DEV
From: Rennes
Registered: 2005-08-26
Posts: 11,632
Website

Re: extension mysql?

je t'arrete tout de suite déjà ton mysql est trop vieux : 4.1 mini


Xavier Caillaud
Blog GLPI Infotel

Offline

#16 2006-07-24 11:44:18

aurel
Guest
From: France
Registered: 2004-09-23
Posts: 1,248

Re: extension mysql?

Faudrait lire les Readme ou lisezmoi de temps en temps ça éviterais de répéter toujours les mêmes choses. De plus GLPI étant en UTF-8 je ne vois pas comment sur une vieille REDHAT tu vas pouvoir t'en sortir. Tu peux essayer une Fedora Core ça fonctionne très bien avec ou une Red Hat Entreprise qui est dispo en téléchargement sur le site de RedHat (sans le support car lui est payant).

A+


Prod (Vmware) Debian 7.0 - GLPI 0.85.4 , plugin FusionInventory 0.85+1.1, Agent Fusioninventory v2.3.8
Pré Prod (Vmware) Debian 7.0 - GLPI 0.84.3 , plugin FusionInventory 0.84+1.2, Agent Fusioninventory v2.3.6

Offline

#17 2006-08-13 00:49:42

JMD
GLPI - Lead
Registered: 2004-09-13
Posts: 9,180
Website

Re: extension mysql?

Je ferme ce thread


JMD / Jean-Mathieu Doléans - Glpi-project.org - Association Indepnet
Apportez votre pierre au  projet GLPI   : Soutenir     Contribuer

Offline

Board footer

Powered by FluxBB