You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2005-09-23 16:05:46

networkontrol
Guest
From: Haute-Savoie
Registered: 2005-09-23
Posts: 6
Website

utf8 encode et utf8 decode...encore

Bonjour a tous,
Je suis en train de mettre en plca glpi sur le site de ma société, mais hélas mon serveur refuse l'installation.
Comme déja expliqué dans un précédent message, lors de l'installation, il m'informe qu'il ne peu pas utiliser les fonctions utf8 decode et utf8 encode.
Mon serveur est sous mandrake 9.0, php 4.x.
J'ai installé les modules php-xml, php-domxml. J'ai redémarré apache...rien n'y fait.
Si vous avez des idées j'en serais heureux! Serais-ce la version de mandrake qui serait trop vieille ?


Plateforme :
OS : Linux Mandrake10.2 / Apache : 2.0.53 / Mysql : 5.0.19 / Php : 5.0.3 / Installation : OCS Inventory NG v 4020 / GLPI v0.68.1
Base de connaissances pour administrateurs réseaux sous Linux
http://www.networkontrol.net

Offline

#2 2005-09-23 16:07:20

networkontrol
Guest
From: Haute-Savoie
Registered: 2005-09-23
Posts: 6
Website

Re: utf8 encode et utf8 decode...encore

J'oubliais que la version de glpi qui je tente d'installer est 0.6.
Merci...


Plateforme :
OS : Linux Mandrake10.2 / Apache : 2.0.53 / Mysql : 5.0.19 / Php : 5.0.3 / Installation : OCS Inventory NG v 4020 / GLPI v0.68.1
Base de connaissances pour administrateurs réseaux sous Linux
http://www.networkontrol.net

Offline

#3 2005-09-23 16:32:39

btravouillon
Guest
Registered: 2005-09-22
Posts: 2

Re: utf8 encode et utf8 decode...encore

Bonjour,

as-tu installé les locales UTF8 ?

++

Offline

#4 2005-09-23 16:50:28

networkontrol
Guest
From: Haute-Savoie
Registered: 2005-09-23
Posts: 6
Website

Re: utf8 encode et utf8 decode...encore

Les locales sont installés...mais je viens de résoudre le problème en installant glpi v0.5.
Je vais rester comme cela pour le moment et verrais plus tard pourquoi cela ne passe pas.


Plateforme :
OS : Linux Mandrake10.2 / Apache : 2.0.53 / Mysql : 5.0.19 / Php : 5.0.3 / Installation : OCS Inventory NG v 4020 / GLPI v0.68.1
Base de connaissances pour administrateurs réseaux sous Linux
http://www.networkontrol.net

Offline

#5 2005-10-18 22:18:26

babeloo
Guest
From: Guadeloupe
Registered: 2004-12-26
Posts: 251

Re: utf8 encode et utf8 decode...encore

bonjour

j'ai le même problème : mandrake 10.1 et GLPI 0.6 impossible à installer :
j'obtiens ce message en rouge :
" GLPI ne peux pas fonctionner correctement sans les fonctions utf8_encode et utf8_decode ; Essayez d'activer le support du XML pour PHP "

j'ai pourtant installé php-xml et php-domxml. quand je choisis d'afficher konqueror en encodage utf8 il ne me pose aucune difficulté.
suis perdue
quelqu'un aurait la solution SVP ?

Merci d'avance


OU dans forêt AD - système : serveur: ubuntu server 10.10 - Apache/2.2.16 (Ubuntu) - Version du client MySQL: 5.1.49 -
OCS server linux 2.0RC2  - agent windows 4.0.5.4 - GLPI 0.78.2 - Firefox 3.6
                                                              -o-o-o-o-o-
Ce n'est pas parce que c'est difficile qu'on n'ose pas, C'est parce qu'on n'ose pas que c'est difficile.

Offline

#6 2005-10-18 22:25:50

MoYo
GLPI - Lead
From: Poitiers
Registered: 2004-09-13
Posts: 14,513
Website

Re: utf8 encode et utf8 decode...encore

vous avez bien redemarré le serveur web ?


MoYo - Julien Dombre - Association INDEPNET
Contribute to GLPI :    Support     Contribute     References     Freshmeat

Offline

#7 2005-10-18 22:31:57

babeloo
Guest
From: Guadeloupe
Registered: 2004-12-26
Posts: 251

Re: utf8 encode et utf8 decode...encore

Oui, oui, j'ai même redémarré le pc et rien à faire.
Je fais des recherches dans les fichiers d'install de mandrake 10.1 (avec les termes uft8, locales, xml, encod) mais je ne vois plus rien à ajouter.
A se claquer la tête !


OU dans forêt AD - système : serveur: ubuntu server 10.10 - Apache/2.2.16 (Ubuntu) - Version du client MySQL: 5.1.49 -
OCS server linux 2.0RC2  - agent windows 4.0.5.4 - GLPI 0.78.2 - Firefox 3.6
                                                              -o-o-o-o-o-
Ce n'est pas parce que c'est difficile qu'on n'ose pas, C'est parce qu'on n'ose pas que c'est difficile.

Offline

#8 2005-10-18 23:01:11

MoYo
GLPI - Lead
From: Poitiers
Registered: 2004-09-13
Posts: 14,513
Website

Re: utf8 encode et utf8 decode...encore

hum hum ...

voilà tout les packages PHP que j'ai chez moi sur une 10.1:
phpMyAdmin-2.6.0-1mdk
php-gd-4.3.8-2mdk
php-xml-4.3.8-1mdk
php-ini-4.3.8-1mdk
apache2-mod_php-2.0.50_4.3.8-2mdk
php-pgsql-4.3.8-1mdk
php-imagick-4.3.8_0.9.11-2mdk
php-mcrypt-4.3.1-1mdk
php-cli-4.3.8-3.4.101mdk
php-mime_magic-4.3.8-1mdk
php-rrdtool-4.3.8_1.0.48-1mdk
libc-client-php0-2004-2.3.101mdk
libphp_common432-4.3.8-3.4.101mdk
php-mysql-4.3.8-1mdk
php-imap-4.3.8-1mdk
php-manual-fr-4.3.8-1mdk
php-domxml-4.3.8-1mdk
php-ldap-4.3.8-1mdk
php-curl-4.3.8-1mdk
php-snmp-4.3.8-1mdk


MoYo - Julien Dombre - Association INDEPNET
Contribute to GLPI :    Support     Contribute     References     Freshmeat

Offline

#9 2005-10-18 23:11:40

JMD
GLPI - Lead
Registered: 2004-09-13
Posts: 9,180
Website

Re: utf8 encode et utf8 decode...encore

Essayez ça :  # urpmi php-xmlrpc php-xml


JMD / Jean-Mathieu Doléans - Glpi-project.org - Association Indepnet
Apportez votre pierre au  projet GLPI   : Soutenir     Contribuer

Offline

#10 2005-10-19 18:56:21

babeloo
Guest
From: Guadeloupe
Registered: 2004-12-26
Posts: 251

Re: utf8 encode et utf8 decode...encore

Bonjour,

Rien à faire : j'ai pourtant tout installé et ce message reste toujours affiché, impossible de continuer l'install.
Tant pis, je vais rester à la version 0.51
Dommage de ne pas pouvoir bénéficier de l'évolution de l'application.


OU dans forêt AD - système : serveur: ubuntu server 10.10 - Apache/2.2.16 (Ubuntu) - Version du client MySQL: 5.1.49 -
OCS server linux 2.0RC2  - agent windows 4.0.5.4 - GLPI 0.78.2 - Firefox 3.6
                                                              -o-o-o-o-o-
Ce n'est pas parce que c'est difficile qu'on n'ose pas, C'est parce qu'on n'ose pas que c'est difficile.

Offline

#11 2005-10-19 19:16:52

MoYo
GLPI - Lead
From: Poitiers
Registered: 2004-09-13
Posts: 14,513
Website

Re: utf8 encode et utf8 decode...encore

Avez vous testez d'installer tous les packages que j'ai donné dans ma liste ?
Dans l'ordre :
php-xml-4.3.8-1mdk
php-domxml-4.3.8-1mdk
php-mime_magic-4.3.8-1mdk
php-imap-4.3.8-1mdk
php-ldap-4.3.8-1mdk
php-curl-4.3.8-1mdk


MoYo - Julien Dombre - Association INDEPNET
Contribute to GLPI :    Support     Contribute     References     Freshmeat

Offline

#12 2005-10-19 19:59:36

babeloo
Guest
From: Guadeloupe
Registered: 2004-12-26
Posts: 251

Re: utf8 encode et utf8 decode...encore

Oui, j'ai toutes ces extensions et j'ai même upgradé ma 10.1 vers une 2005LE.
Cela n'a rien changé.
J'ai cherché avec google mais je n'ai pas trouvé de solution.
Tant pis.


OU dans forêt AD - système : serveur: ubuntu server 10.10 - Apache/2.2.16 (Ubuntu) - Version du client MySQL: 5.1.49 -
OCS server linux 2.0RC2  - agent windows 4.0.5.4 - GLPI 0.78.2 - Firefox 3.6
                                                              -o-o-o-o-o-
Ce n'est pas parce que c'est difficile qu'on n'ose pas, C'est parce qu'on n'ose pas que c'est difficile.

Offline

#13 2005-10-19 20:39:37

babeloo
Guest
From: Guadeloupe
Registered: 2004-12-26
Posts: 251

Re: utf8 encode et utf8 decode...encore

Juste quelques petites précisions :
dans phpinfo () , à plusieurs endroits, (par ex. dans variables), il y a ceci " utf8_general_ci "
De plus, j'affiche Firefox en encodage utf8 et idem pour phpMyAdmin.
Peut-être y a-t-il moyen de désactiver quelque part dans GLPI cette obligation d'UTF8 ?
Dans l'affirmative, merci de m'indiquer à quel endroit.
Si ce n'est pas possible, eh bien, je resterai en 0.51.
Cordialemetn


OU dans forêt AD - système : serveur: ubuntu server 10.10 - Apache/2.2.16 (Ubuntu) - Version du client MySQL: 5.1.49 -
OCS server linux 2.0RC2  - agent windows 4.0.5.4 - GLPI 0.78.2 - Firefox 3.6
                                                              -o-o-o-o-o-
Ce n'est pas parce que c'est difficile qu'on n'ose pas, C'est parce qu'on n'ose pas que c'est difficile.

Offline

#14 2005-10-29 01:43:11

babeloo
Guest
From: Guadeloupe
Registered: 2004-12-26
Posts: 251

Re: utf8 encode et utf8 decode...encore

Bonjour,

J'ai installé mandriva 2006 et tutti va bene !
Juste les accents qui se sont transformés en ? je les corrige au fur et à mesure que j'en trouve et la correction est conservée, donc, aucun problème.
Cette application est vraiment du tonnerre !
Merci encore


OU dans forêt AD - système : serveur: ubuntu server 10.10 - Apache/2.2.16 (Ubuntu) - Version du client MySQL: 5.1.49 -
OCS server linux 2.0RC2  - agent windows 4.0.5.4 - GLPI 0.78.2 - Firefox 3.6
                                                              -o-o-o-o-o-
Ce n'est pas parce que c'est difficile qu'on n'ose pas, C'est parce qu'on n'ose pas que c'est difficile.

Offline

#15 2005-10-29 01:52:34

JMD
GLPI - Lead
Registered: 2004-09-13
Posts: 9,180
Website

Re: utf8 encode et utf8 decode...encore

Content que ça fonctionne désormais chez vous.

Pour les accents c'est pas normal. Faudra voir pourquoi ça fait ça.


JMD / Jean-Mathieu Doléans - Glpi-project.org - Association Indepnet
Apportez votre pierre au  projet GLPI   : Soutenir     Contribuer

Offline

#16 2005-10-29 02:11:00

babeloo
Guest
From: Guadeloupe
Registered: 2004-12-26
Posts: 251

Re: utf8 encode et utf8 decode...encore

Je comprends que cela vous dérange, mais, entre nous, comme je n'y connais rien en programmation, j'ai une peur bleue de " casser " quelque chose en allant " toucher " les fichiers. (sauf si vous avez besoin que je vérifie quelque chose dans l'un d'entre eux).
Tout fonctionne, ça me va très bien. De plus, je suis la seule à l'utiliser pour mes 150 machines ; juste mes boss qui ont un accès "normal" pour jeter un oeil durant les périodes de statistiques (donc, bientôt !).
Je ne peux pas utiliser le helpdesk car je n'ai pas de LDAP : mes stations sont dans un domaine dont les pdc et bdc sont sur NT. Je n'ai pas de serveur de messagerie. Donc, impossible d'utiliser le helpdesk....
Bon we


OU dans forêt AD - système : serveur: ubuntu server 10.10 - Apache/2.2.16 (Ubuntu) - Version du client MySQL: 5.1.49 -
OCS server linux 2.0RC2  - agent windows 4.0.5.4 - GLPI 0.78.2 - Firefox 3.6
                                                              -o-o-o-o-o-
Ce n'est pas parce que c'est difficile qu'on n'ose pas, C'est parce qu'on n'ose pas que c'est difficile.

Offline

#17 2005-10-29 16:43:57

tsmr
GLPI-DEV
From: Rennes
Registered: 2005-08-26
Posts: 11,632
Website

Re: utf8 encode et utf8 decode...encore

babeloo wrote:

Je ne peux pas utiliser le helpdesk car je n'ai pas de LDAP : mes stations sont dans un domaine dont les pdc et bdc sont sur NT. Je n'ai pas de serveur de messagerie. Donc, impossible d'utiliser le helpdesk....
Bon we

et la configuration POP ?


Xavier Caillaud
Blog GLPI Infotel

Offline

#18 2005-10-29 22:43:26

babeloo
Guest
From: Guadeloupe
Registered: 2004-12-26
Posts: 251

Re: utf8 encode et utf8 decode...encore

Plaît-il ?
Je croyais qu'il fallait donner un nom de serveur, genre pop.wanadoo.fr.
Je ne maîtrise pas du tout ce sujet.


OU dans forêt AD - système : serveur: ubuntu server 10.10 - Apache/2.2.16 (Ubuntu) - Version du client MySQL: 5.1.49 -
OCS server linux 2.0RC2  - agent windows 4.0.5.4 - GLPI 0.78.2 - Firefox 3.6
                                                              -o-o-o-o-o-
Ce n'est pas parce que c'est difficile qu'on n'ose pas, C'est parce qu'on n'ose pas que c'est difficile.

Offline

#19 2005-10-30 15:20:40

baaz
Guest
Registered: 2004-09-13
Posts: 513

Re: utf8 encode et utf8 decode...encore

Il est possible sinon d'utiliser le Helpdesk de maniere anonyme sans identification préalable.

Pour cela il suffit de mettre l'option "authoriser le helpdesk anonyme" à oui (dans le menu configuration générale).

Ensuite c'est simple il suffit de faire pointer votre navigateur vers le fichier helpdesk.html (qui se trouve à la racine de GLPI) pour poster une demande d'intervention.

Il est possible de modifier le fichier helpdesk.html sans trop de problèmes (pour le rendre plus joli) tant que vous gardez les memes nom pour les champs du formulaire.

La seule différence avec le helpdesk "classique" c'est que les interventions seront toutes postées par le même utilisateur "helpdesk" au lieu d'être postée par l'utilisateur qui s'est identifié dans le mode "classique".


Bazile Lebeau

Offline

#20 2005-10-30 16:20:06

babeloo
Guest
From: Guadeloupe
Registered: 2004-12-26
Posts: 251

Re: utf8 encode et utf8 decode...encore

Merci pour cette information mais je ne préfère pas utiliser l'anonymat du helpdesk car je connais mes utilisateurs : beaucoup oublieront d'indiquer leur nom dans le corps de la demande d'aide ; pour le matériel, pas de problème puisque le nom du matériel concerné est obligatoire.
En revanche, pour les logiciels.... Je vois déjà la situation : exemple : " openoffice n'imprime pas mon tableau sur une seule page ! remets moi excel ! " ... c'est le genre de remarque que j'entends trop souvent, mais de collègues identifiés.
Si c'est par GLPI, ils rouspèteront encore plus fort en me téléphonant au motif que ce " site d'aide  est de la m.... : puisque je ne viens plus les dépanner !  " (et pour cause, ils seront restés anonymes dans leur message !).
Donc, tant que je ne maîtriserai pas l'envoi de mail par GLPI, mon "helpdesk" restera téléphonique.
Merci encore pour tout.


OU dans forêt AD - système : serveur: ubuntu server 10.10 - Apache/2.2.16 (Ubuntu) - Version du client MySQL: 5.1.49 -
OCS server linux 2.0RC2  - agent windows 4.0.5.4 - GLPI 0.78.2 - Firefox 3.6
                                                              -o-o-o-o-o-
Ce n'est pas parce que c'est difficile qu'on n'ose pas, C'est parce qu'on n'ose pas que c'est difficile.

Offline

#21 2005-10-30 16:44:36

MoYo
GLPI - Lead
From: Poitiers
Registered: 2004-09-13
Posts: 14,513
Website

Re: utf8 encode et utf8 decode...encore

pour l'envoie de mail il suffit juste d'un serveur smtp. Celui que vous utilisez pour envoyer vos mails ira tres bien a priori.
pop.wanadoo.fr ne marchera pas car c'est un serveur de recupération de mail et pas d'envoi.


MoYo - Julien Dombre - Association INDEPNET
Contribute to GLPI :    Support     Contribute     References     Freshmeat

Offline

#22 2005-11-07 18:21:39

babeloo
Guest
From: Guadeloupe
Registered: 2004-12-26
Posts: 251

Re: utf8 encode et utf8 decode...encore

Bonjour,

Il semblerait que ce message d'erreur relatif aux fonctions utf8 decode et utf8 encode pourrait être aussi consécutif à l'absence dans le php.ini (/etc/php.ini) de la phrase sur la fonction : mbstring.func_overload = 7.
Juste une autre piste pour celles et ceux qui auraient encore ce message.


OU dans forêt AD - système : serveur: ubuntu server 10.10 - Apache/2.2.16 (Ubuntu) - Version du client MySQL: 5.1.49 -
OCS server linux 2.0RC2  - agent windows 4.0.5.4 - GLPI 0.78.2 - Firefox 3.6
                                                              -o-o-o-o-o-
Ce n'est pas parce que c'est difficile qu'on n'ose pas, C'est parce qu'on n'ose pas que c'est difficile.

Offline

#23 2005-11-07 18:35:12

baaz
Guest
Registered: 2004-09-13
Posts: 513

Re: utf8 encode et utf8 decode...encore

merci pour eux smile


Bazile Lebeau

Offline

#24 2006-01-13 11:01:15

tomdak
Guest
Registered: 2006-01-05
Posts: 55

Re: utf8 encode et utf8 decode...encore

meme probleme avez vous solutionné celui ci
ou telecharger le packtage xml-php car pas present sur mon serveur
de meme pour locales UTF8?

Offline

#25 2006-01-13 11:09:48

MoYo
GLPI - Lead
From: Poitiers
Registered: 2004-09-13
Posts: 14,513
Website

Re: utf8 encode et utf8 decode...encore

Solutionné ? c'est a vous d'installer les bonnes librairies pour faire fonctionner GLPI.


MoYo - Julien Dombre - Association INDEPNET
Contribute to GLPI :    Support     Contribute     References     Freshmeat

Offline

Board footer

Powered by FluxBB