You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2020-07-08 14:02:38

Steph2019
Member
Registered: 2019-02-16
Posts: 25

[GLPI 9.5] : Colonnes incompatible fuseaux horaire

Bonjour,

Depuis la mise à jour du GLPI 9.5 et la mise à jour de la timezone, J'ai un message dans accueil et tableau de bord.

"449 colonnes sont incompatible avec l'utilisation des fuseaux horaires avec le triangle jaune".

Si vous avez un indice

Sinon tout est fonctionnel, j'ai juste ce message.


si cela peut servir :
Operating system: Linux srv-glpi 3.10.0-1127.13.1.el7.x86_64 #1 SMP Tue Jun 23 15:46:38 UTC 2020 x86_64
PHP 7.4.7 apache2handler (Core, PDO, Phar, Reflection, SPL, SimpleXML, Zend OPcache, apache2handler, apcu, bcmath, bz2,
    calendar, ctype, curl, date, dom, exif, fileinfo, filter, ftp, gd, gettext, gmp, hash, iconv, imap, intl, json, ldap, libxml,
    mbstring, mcrypt, mysqli, mysqlnd, openssl, pcre, pdo_mysql, pdo_sqlite, posix, recode, session, shmop, snmp, sockets, sodium,
    sqlite3, standard, sysvmsg, sysvsem, sysvshm, tidy, tokenizer, xml, xmlreader, xmlrpc, xmlwriter, xsl, zip, zlib)
Setup: max_execution_time="600" memory_limit="128M" post_max_size="5M" safe_mode="" session.save_handler="files"
    upload_max_filesize="10M"
Software: Apache/2.4.6 (CentOS) PHP/7.4.7 ()
    Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.116 Safari/537.36
Server Software: MariaDB Server
    Server Version: 10.3.20-MariaDB
    Server SQL Mode:
    Parameters: root@localhost/glpi
    Host info: Localhost via UNIX socket

Last edited by Steph2019 (2020-07-08 14:03:07)

Offline

#2 2020-07-08 14:07:57

Steph2019
Member
Registered: 2019-02-16
Posts: 25

Re: [GLPI 9.5] : Colonnes incompatible fuseaux horaire

vous pouvez clôturer

il fallait effectuer cette commande, je l'ai vu dans le log

php bin/console glpi:migration:timestamps

Offline

#3 2020-07-20 16:55:04

stdglpi
Member
Registered: 2020-02-19
Posts: 42

Re: [GLPI 9.5] : Colonnes incompatible fuseaux horaire

Merci j'ai la même erreur je vais effectuer la même chose.

Offline

#4 2020-07-22 17:23:15

jejeroro
Member
Registered: 2011-09-05
Posts: 71

Re: [GLPI 9.5] : Colonnes incompatible fuseaux horaire

En meme temps j'ai eu aussi des pb avec le mailgate et la creation de tickets par mail HS en 9.5.0

un membre a suggéré le passage en 9.5.1 et tout est rétabli!!

Offline

#5 2020-08-04 15:37:40

Vince.LCIA
Member
Registered: 2014-05-28
Posts: 26

Re: [GLPI 9.5] : Colonnes incompatible fuseaux horaire

Steph2019 wrote:

vous pouvez clôturer

il fallait effectuer cette commande, je l'ai vu dans le log

php bin/console glpi:migration:timestamps

Bonjour,
J'ai la même erreur.

Cette commande est à taper à quel endroit ?
Mon installation GLPI est sous Windows Server 2012, IIS / php7.4

Merci.


Belle journée.
Vincent.
--------
GLPI 9.5.1 - IIS webserver / Windows Server 2012

Offline

#6 2020-08-21 12:12:20

tofic
Member
Registered: 2013-04-15
Posts: 3

Re: [GLPI 9.5] : Colonnes incompatible fuseaux horaire

Vince.LCIA wrote:
Steph2019 wrote:

vous pouvez clôturer

il fallait effectuer cette commande, je l'ai vu dans le log

php bin/console glpi:migration:timestamps

Bonjour,
J'ai la même erreur.

Cette commande est à taper à quel endroit ?
Mon installation GLPI est sous Windows Server 2012, IIS / php7.4

Merci.

En ligne de commande, et en fonction de l'emplacement et de ta version de php:

c:\Program Files\PHP\v7.4\php.exe c:\inetpub\wwwroot\glpi\bin\console glpi:migration:timestamps

Last edited by tofic (2020-08-21 12:13:05)

Offline

#7 2020-09-01 15:48:20

Theconan995
Member
Registered: 2020-08-24
Posts: 21

Re: [GLPI 9.5] : Colonnes incompatible fuseaux horaire

J'ai passé cette commande mais il me reste toujours 6 colonnes incompatibles :S


GLPI 9.5.2 / XAMPP 2.5 / PHP 7.2.33 / MySQL 5.7.20 / Apache 2.4 / phpMyAdmin 5.0.2 / FusionInventory 9.5.0 sur Windows Server 2012R2

Offline

#8 2020-11-17 13:05:36

Isia
Member
Registered: 2019-05-26
Posts: 68

Re: [GLPI 9.5] : Colonnes incompatible fuseaux horaire

Salut pour Nginx c'est du type /usr/bin/php7.4 /var/www/glpi/bin/console glpi:migration:timestamps

Last edited by Isia (2020-11-17 13:05:43)

Offline

#9 2021-05-04 11:25:37

yannix63
Member
Registered: 2008-10-29
Posts: 189
Website

Re: [GLPI 9.5] : Colonnes incompatible fuseaux horaire

Bonjour, Je viens de passer la commande donné par Isia (au passage merci)
Je suis passé de 454 colonnes incompatibles à 1 colonne incompatible

Comment savoir de quelle colonne il parle et comment corriger ce nouveau problème ?

Merci a tous

Offline

#10 2021-05-04 14:57:15

yannix63
Member
Registered: 2008-10-29
Posts: 189
Website

Re: [GLPI 9.5] : Colonnes incompatible fuseaux horaire

2021-05-04-14-48-10.png


Du coup pour faire suite à mon précédent mail voici en complément la copie d'écran de la migration

2021-05-04-10-53-13-Copie.png

Lors de la migration, le message a l'air d'etre lié à l'absence d'une table
Faut-t’il créer la table manquante ? Cette table est-elle présente dans vos bases et si oui quelle en est la structure

Merci à tous pour vos retour

Offline

#11 2021-05-04 18:03:33

yannix63
Member
Registered: 2008-10-29
Posts: 189
Website

Re: [GLPI 9.5] : Colonnes incompatible fuseaux horaire

Dossier clos pour moi
problème réglé après création de la table dans phpmyadmin (peu importe la structure) et en repassant la commande

Offline

Board footer

Powered by FluxBB