You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2019-10-18 12:59:33

windshaman
Member
Registered: 2019-10-18
Posts: 4

GLPI 9.4.4/9.4.3 - Affichage lent, plus de CSS

Bonjour,

Un problème étrange est survenu sur mon installation de production qui était en 9.4.3 : plusieurs utilisateurs m'ont rapporté que le chargement de l'interface était très lent et que la charte graphique avait disparu. Ce problème s'est propagé peu à peu à tous les utilisateurs et également sur mes postes de travail.
GLPI tourne sans problème particulier depuis 6 mois sur une VM Debian 9. Au début, j'ai pensé à une mise à jour du serveur apache qui aurait pu poser problème. J'ai donc restauré une sauvegarde de la VM et même en remontant sur des snapshots datant de 15 jours, le problème d'affichage est toujours présent.
J'ai tenté une migration de 9.4.3 vers 9.4.4 et c'est sans effet : les pages sont très longues à charger et le CSS ne semble pas pris en compte.
Je précise que le serveur web n'est pas accessible hors du réseau local.

Je ne sais pas trop par où commencer, un peu d'aide serait la bienvenue :-)

--Edit 1 : J'ai un peu avancé sur le sujet. En renommant le fichier glpi/front/css.php (mv css.php css.php.bak), le chargement est instantané. Je n'ai toujours pas d'interface graphique mais au moins je n'ai plus de délais anormalement longs au niveau du chargement. Il semblerait qu'une partie de mon problème soit lié à la compilation du CSS mais je sèche un peu de ce côté là.

--Edit 2 : Si je commente uniquement les lignes suivantes, le chargement de GLPI est instantané (toujours sans CSS) :
if (!defined('GLPI_ROOT')) {
   define('GLPI_ROOT', dirname(__DIR__));

Last edited by windshaman (2019-10-21 16:26:39)

Offline

#2 2019-10-22 12:16:10

windshaman
Member
Registered: 2019-10-18
Posts: 4

Re: GLPI 9.4.4/9.4.3 - Affichage lent, plus de CSS

Bonjour, mise à jour de mon problème :

Après avoir tenté des choses dans tous les sens, j'ai voulu créer une nouvelle VM pour réaliser une installation propre, au cas où j'aurais loupé quelque chose.

Installation Debian X : OK
Installation MariaDB 15.1 : OK
Installation Apache + PHP 7.3 et extensions nécessaires : OK
Téléchargement GLPI 9.4.4 : OK

Je passe bien la validation de l'installation, j'entre les identifiants de connexion à la base de données, je sélectionne la base de données et je clique sur Continuer.
Le navigateur mouline et rien ne se passe.

Sincèrement, je suis perdu. Il y a un problème avec la 9.4.4 ?

--Edit : Même problème avec GLPI 9.4.0 et 9.3.3. Cela semble être un problème côté configuration serveur mais je ne vois pas ce qui pose problème.

Last edited by windshaman (2019-10-22 12:32:04)

Offline

#3 2019-10-22 16:14:02

windshaman
Member
Registered: 2019-10-18
Posts: 4

Re: GLPI 9.4.4/9.4.3 - Affichage lent, plus de CSS

Informations sur le système, l'installation et la configuration

 
GLPI 9.4.4 (/glpi => /var/www/html/glpi)
Installation mode: TARBALL

Server

 
Operating system: Linux XXXX-inventory 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1+deb9u5 (2019-08-11) x86_64
PHP 7.0.33-0+deb9u3 apache2handler (Core, PDO, Phar, Reflection, SPL, SimpleXML, Zend OPcache, apache2handler, apc, apcu, bz2,
	calendar, ctype, curl, date, dom, exif, fileinfo, filter, ftp, gd, gettext, hash, iconv, imap, intl, json, ldap, libxml,
	mbstring, mysqli, mysqlnd, openssl, pcre, pdo_mysql, posix, readline, session, shmop, snmp, soap, sockets, standard, sysvmsg,
	sysvsem, sysvshm, tokenizer, wddx, xml, xmlreader, xmlrpc, xmlwriter, xsl, zip, zlib)
Setup: max_execution_time="30" memory_limit="128M" post_max_size="8M" safe_mode="" session.save_handler="files"
	upload_max_filesize="2M" 
Software: Apache/2.4.25 (Debian) (Apache/2.4.25 (Debian) Server at ocsinventory-ng.XXXX.lan Port 443)
	Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:69.0) Gecko/20100101 Firefox/69.0
Server Software: Debian 9.8
	Server Version: 10.1.38-MariaDB-0+deb9u1
	Server SQL Mode: 
	Parameters: user-glpi@localhost/glpi
	Host info: Localhost via UNIX socket
	
mysqli extension is installed
ctype extension is installed
fileinfo extension is installed
json extension is installed
mbstring extension is installed
iconv extension is installed
zlib extension is installed
curl extension is installed
gd extension is installed
simplexml extension is installed
xml extension is installed
ldap extension is installed
imap extension is installed
Zend OPcache extension is installed
APCu extension is installed
xmlrpc extension is installed
CAS extension is installed
exif extension is installed
Database version seems correct (10.1.38) - Perfect!Database version seems correct (10.1.38) - Perfect!
OK/var/www/html/glpi/files/_log : OK
OK/var/www/html/glpi/config : OK
OK/var/www/html/glpi/files : OK
OK/var/www/html/glpi/files/_dumps : OK
OK/var/www/html/glpi/files/_sessions : OK
OK/var/www/html/glpi/files/_cron : OK
OK/var/www/html/glpi/files/_graphs : OK
OK/var/www/html/glpi/files/_lock : OK
OK/var/www/html/glpi/files/_plugins : OK
OK/var/www/html/glpi/files/_tmp : OK
OK/var/www/html/glpi/files/_cache : OK
OK/var/www/html/glpi/files/_rss : OK
OK/var/www/html/glpi/files/_uploads : OK
OK/var/www/html/glpi/files/_pictures : OK
Web access to the files directory should not be allowed but this cannot be checked automatically on this instance.
Make sure acces to error log file is forbidden; otherwise review .htaccess file and web server configuration.

Libraries

 
htmLawed version 1.2.4 in (/var/www/html/glpi/lib/htmlawed)
phpmailer/phpmailer version 6.0.7 in (/var/www/html/glpi/vendor/phpmailer/phpmailer/src)
simplepie/simplepie version 1.5.2 in (/var/www/html/glpi/vendor/simplepie/simplepie/library)
tecnickcom/tcpdf version 6.2.26 in (/var/www/html/glpi/vendor/tecnickcom/tcpdf)
michelf/php-markdown in (/var/www/html/glpi/vendor/michelf/php-markdown/Michelf)
true/punycode in (/var/www/html/glpi/vendor/true/punycode/src)
iamcal/lib_autolink in (/var/www/html/glpi/vendor/iamcal/lib_autolink)
sabre/vobject in (/var/www/html/glpi/vendor/sabre/vobject/lib)
zendframework/zend-cache in (/var/www/html/glpi/vendor/zendframework/zend-cache/src)
zendframework/zend-i18n in (/var/www/html/glpi/vendor/zendframework/zend-i18n/src)
zendframework/zend-serializer in (/var/www/html/glpi/vendor/zendframework/zend-serializer/src)
monolog/monolog in (/var/www/html/glpi/vendor/monolog/monolog/src/Monolog)
sebastian/diff in (/var/www/html/glpi/vendor/sebastian/diff/src)
elvanto/litemoji in (/var/www/html/glpi/vendor/elvanto/litemoji/src)
symfony/console in (/var/www/html/glpi/vendor/symfony/console)
leafo/scssphp in (/var/www/html/glpi/vendor/leafo/scssphp/src)
phpCas version 1.3.3 in (/usr/share/php)

LDAP directories

 
Server: 'XXXXX1', Port: '389', BaseDN: 'DC=XXXX,DC=lan', Connection filter:
		'(&(objectClass=user)(objectCategory=person)(!(userAccountControl:1.2.840.113556.1.4.803:=2)))', RootDN: 'svc-glpi@XXXX.lan',
		Use TLS: none

SQL replicas

 
Not active

Notifications

 
Way of sending emails: SMTP+TLS (support@XXXXX.net@ssl0.ovh.net)

Mails receivers

 
Name: 'support@XXXXX.net' Active: Yes
	Server: '{ssl0.ovh.net:993/imap/ssl}INBOX' Login: 'support@XXXXX.net' Password: Yes

Plugins list

 
	additionalalerts     Name: Alertes supplémentaires        Version: 2.2.0      State: Enabled
	archires             Name: Architectures réseau           Version: 2.6.0      State: Not installed
	badges               Name: Badges                         Version: 2.5.0      State: Enabled
	timelineticket       Name: Chronologie des tickets        Version: 9.4+1.0    State: Enabled
	printercounters      Name: Compteurs Imprimantes          Version: 1.6.0      State: Enabled
	mydashboard          Name: Dashboard                      Version: 1.7.4      State: Enabled
	pdf                  Name: Impression pdf                 Version: 1.6.0      State: Enabled
	moreticket           Name: More ticket                    Version: 1.4.6      State: Not installed
	ocsinventoryng       Name: OCS Inventory NG               Version: 1.6.0      State: Enabled
	mreporting           Name: Plus de rapports               Version: 1.6.1      State: Enabled

OCS Inventory NG
Host: localhost
Connection: Ok
Use the OCSNG software dictionary: No

Last edited by windshaman (2019-10-22 16:18:13)

Offline

#4 2019-10-31 14:13:55

neo2020
Member
Registered: 2019-10-31
Posts: 2

Re: GLPI 9.4.4/9.4.3 - Affichage lent, plus de CSS

J'ai un probleme similaire depuis une upgrade de 9.2 a 9.4
CSS load mais le site est beaucoup plus lent.
au debut j'avais php56 et le load time de chaque page etait 8s, apres une upgrade a php7 j'ai un load time de 4s mais c'est beaucoup plus lent qu'avant.
Chrome indique que le load time est causé pas css.php.

Offline

#5 2019-10-31 14:26:39

Jean-Christophe
Moderator
Registered: 2007-08-22
Posts: 429

Re: GLPI 9.4.4/9.4.3 - Affichage lent, plus de CSS

Est-ce que vous avez le problème sur toutes les pages, tous les types de matériel ?
Je suis passé en 9.4.4 depuis quelques jours et je ne rencontre aucun souci (sauf celui de la recherche globale mais qui est résolu).

Bref, pas de souci de performance pour moi, malgré une DB relativement étoffée et pas mal de plugins utilisés.

Offline

#6 2019-10-31 14:39:23

neo2020
Member
Registered: 2019-10-31
Posts: 2

Re: GLPI 9.4.4/9.4.3 - Affichage lent, plus de CSS

Pour ma part c'est sur toutes les pages, et toujours le meme fichier qui cause la lenteur "css.php?file=main_styles&v=9.4.4".

EDIT : on vient de regler le probleme de notre bord avec l'ajout de l'extension apcu.
Mais en 9.2 on avait pas cette extension d'installé et pas de probleme de perf (ni meme zend opcache).

Last edited by neo2020 (2019-10-31 15:18:44)

Offline

Board footer

Powered by FluxBB