You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2019-07-30 16:49:45

FlowFlo
Member
Registered: 2019-07-18
Posts: 6

Erreur compilation .po .mo

GLPI 9.4.2

Salut à tous,

J'ai mis en place GLPI pour mon service après-ventes.
J'aimerais modifier des traductions d'onglets afin d'optimiser mon parc.
Par exemple "périphériques" par "appareils".
J'ai modifié directement la ligne suivante dans le fichier fr_FR.po :

 msgid "Device"
msgid_plural "Devices"
msgstr[0] "Appareil"
msgstr[1] "Appareils" 

Ensuite j'ai compilé le fichier .po en .mo

 msgfmt -o fr_FR.mo -v fr_FR.po 

j'ai ce message d’erreur :

 fr_FR.po: warning: Charset missing in header.
                   Message conversion to user's charset will not work.
fr_FR.po:20: duplicate message definition...
fr_FR.po:7: ...this is the location of the first definition
msgfmt: found 1 fatal error 

Après plusieurs recherches, l’erreur viendrait d'un doublon présent dans les fichiers, mais ce n'est pas le cas de mon coté.
On me parle également d'un problème de caractère mais le fichier .po est présent depuis le début.

Auriez-vous une solution à me donner ?

Thanks !

Offline

#2 2019-07-30 17:09:45

philippe.chauvier
Guest
From: NANTES
Registered: 2006-10-24
Posts: 66
Website

Re: Erreur compilation .po .mo

Bonsoir,

Pour effectuer cette modification, il faut utiliser un éditeur tiers nommé poedit et téléchargeable ici https://poedit.net/
Télécharger le fichier [Root GLPI]/locales/fr_FR.po depuis votre serveur GLPI sur votre PC (utiliser WinSCP si serveur Linux)
Ouvrir et éditer le fichier fr_FR.po comme souhaité avec poedit puis enregistrer le fichier à l'issue
Sélectionner le menu Fichier / Compiler le MO pour générer le fichier fr_FR.mo
Transférer les deux fichiers ainsi obtenus (fr_FR.po et fr_FR.mo) sur le dossier [Root GLPI]/locales de votre serveur GLPI en écrasant les fichiers existants.
Afin de vous assurer de la prise en compte de changements, videz le cache de votre navigateur web (à partir duquel vous exploitez GLPI) et redémarrez le serveur Web (Apache sous Linux) pour uen parfaite prise en compte des changements.

Cordialement.
Philippe


NANTES METROPOLE HABITAT
OS : Ubuntu Server 16.04.6 LTS - Apache 2.4.18 - Php : 7.0.33 - MySQL : 5.7.27 - GLPI : 9.4.3 - OCS Inventory : 2.3.1 - Graphviz 2.16-3

Offline

#3 2019-07-31 09:22:12

FlowFlo
Member
Registered: 2019-07-18
Posts: 6

Re: Erreur compilation .po .mo

Bonjour,

Merci pour votre aide.
La commande msgfmt n'est pas suffisante ?
Je vais essayer cela.

Offline

#4 2019-08-01 08:54:12

philippe.chauvier
Guest
From: NANTES
Registered: 2006-10-24
Posts: 66
Website

Re: Erreur compilation .po .mo

Bonjour,

Je n'ai jamais utilisé la commande que vous citez.
La mienne fonctionne en tous cas.
Bonne journée.

Philippe


NANTES METROPOLE HABITAT
OS : Ubuntu Server 16.04.6 LTS - Apache 2.4.18 - Php : 7.0.33 - MySQL : 5.7.27 - GLPI : 9.4.3 - OCS Inventory : 2.3.1 - Graphviz 2.16-3

Offline

Board footer

Powered by FluxBB