You are not logged in.

Announcement

 Téléchargez la dernière version stable de GLPI      -     Et vous, que pouvez vous faire pour le projet GLPI ? :  Contribuer
 Download last stable version of GLPI                      -     What can you do for GLPI ? :  Contribute

#1 2018-10-19 15:05:22

squale323
Member
Registered: 2017-06-21
Posts: 25

probleme déconnexion/verrou d'un élement

Bonjour,
je rencontre un soucis que je n'avais pas auparavant, je ne sais pas si c'est un problème GLPI ou Fusioninventory.
lorsque que je récupère certains PC (pour remise en stock par exemple), je ne peux pas déconnecter les éléments qui y était connecté. de plus, je ne rencontre pas ce problème sur tous les PCs (heureusement :-) )

- je vais sur la fiche du PC, onglet "connexion", je coche  l'écran, je choisis l'action "déconnecter", j'ai un message comme quoi l'opération à été réalisée avec succès, mais l'écran est toujours dans la liste...

- je vais cette fois sur la fiche de l'écran en question, il est toujours rattaché à ce PC, donc même manip : onglet "connexion", je coche le PC, je déconnecte, ça fonctionne, le PC n'est plus la

Par contre, si je retourne sur la fiche du PC, je constate que l'écran est toujours connecté à ce PC, et qu'en plus il est maintenant verrouillé. Je précise que le fait de déverrouillé l'écran et refaire les manips ne change absolument rien.
j'ai constaté le problème sur 2 PC rattaché a des écrans, ainsi que sur un PC portable rattaché à une imprimante pour l'instant.

quelqu'un aurait une idée pour m'aider à résoudre ce soucis ?
merci


Debian 8.11
PHP 5.6 MySql 5.6
Glpi 9.4.6
FI 9.4+2.4

Offline

#2 2018-10-26 10:10:02

squale323
Member
Registered: 2017-06-21
Posts: 25

Re: probleme déconnexion/verrou d'un élement

personne n'à d'idées ?


Debian 8.11
PHP 5.6 MySql 5.6
Glpi 9.4.6
FI 9.4+2.4

Offline

#3 2018-10-26 10:35:47

Jean-Christophe
Moderator
Registered: 2007-08-22
Posts: 474

Re: probleme déconnexion/verrou d'un élement

Quand tu actives le mode debug (la petite coccinelle, en haut à droite), est-ce que tu as plus d'information?

Offline

#4 2018-10-26 10:38:30

squale323
Member
Registered: 2017-06-21
Posts: 25

Re: probleme déconnexion/verrou d'un élement

J'ai trouvé une alternative. en allant dans l'onglet "verrou", au lieu de choisir l'option"déverrouillé" (qui ne fonctionne pas pour moi), je choisi "supprimer définitivement" et la le matériel est alors bien déconnecté. ce que je ne comprends pas, c'est qu'avant je n'avais pas besoin de faire cette manip pour que par exemple un écran se déconnecte d'un PC si il était affecté à un nouveau PC. j'ai raté une option ? j'ai cherché partout mais je ne vois pas ou ça peut être...


Debian 8.11
PHP 5.6 MySql 5.6
Glpi 9.4.6
FI 9.4+2.4

Offline

#5 2018-10-26 10:40:33

squale323
Member
Registered: 2017-06-21
Posts: 25

Re: probleme déconnexion/verrou d'un élement

non rien de plus en mode debug :-(


Debian 8.11
PHP 5.6 MySql 5.6
Glpi 9.4.6
FI 9.4+2.4

Offline

#6 2018-10-26 10:59:34

squale323
Member
Registered: 2017-06-21
Posts: 25

Re: probleme déconnexion/verrou d'un élement

bon, mon alternative est foireuse, vu que maintenant le moniteur ne prend plus le statut, le lieu et l'utilisateur du PC sur lequel il est connecté...


Debian 8.11
PHP 5.6 MySql 5.6
Glpi 9.4.6
FI 9.4+2.4

Offline

#7 2018-10-29 12:56:57

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 15,184

Re: probleme déconnexion/verrou d'un élement

le moniteur et l'écran sont dans la même entité ?
Un des deux a-t-il subit un transfert ?
aucune erreur dans les logs d'apache ?


CentOS 6.5 - CentOS 7.x
PHP 5.6 - PHP 7.x - MySQL 5.6  - MariaDB 10.2 + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#8 2018-10-29 14:57:51

squale323
Member
Registered: 2017-06-21
Posts: 25

Re: probleme déconnexion/verrou d'un élement

- oui il n'y à qu'une entité
- pas de transfert
- les logs apaches c'est ce qui se trouve dans /var/log/apache2/error.log ?
si oui, j'ai ca :
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20131226/php_apcu.dll' - /usr/lib/php5/20131226/php_apcu.dll: cannot open shared object file: No such file or directory in Unknown on line 0
[Mon Oct 29 07:35:05.413505 2018] [ssl:warn] [pid 30098] AH01906: glpi:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Mon Oct 29 07:35:05.414746 2018] [mpm_prefork:notice] [pid 30098] AH00163: Apache/2.4.10 (Debian) OpenSSL/1.0.1t configured -- resuming normal operations
[Mon Oct 29 07:35:05.414758 2018] [core:notice] [pid 30098] AH00094: Command line: '/usr/sbin/apache2'
Cannot load Zend OPcache - extension already loaded
merci pour ton aide :-)


Debian 8.11
PHP 5.6 MySql 5.6
Glpi 9.4.6
FI 9.4+2.4

Offline

#9 2018-10-30 11:12:30

yllen
GLPI-DEV
From: Sillery (51)
Registered: 2008-01-14
Posts: 15,184

Re: probleme déconnexion/verrou d'un élement

les erreurs apache ne concernent pas votre problème.
Bon je viens d'arriver à reproduire votre problème : https://github.com/glpi-project/glpi/issues/4850


CentOS 6.5 - CentOS 7.x
PHP 5.6 - PHP 7.x - MySQL 5.6  - MariaDB 10.2 + APC + oOPcache
GLPI from 0.72 to dev version
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

Offline

#10 2018-10-30 13:18:26

squale323
Member
Registered: 2017-06-21
Posts: 25

Re: probleme déconnexion/verrou d'un élement

ok c'est donc bien un problème.

plus qu'a attendre un fix. Merci pour le coup de main en tout cas :-)
si besoin d'autres infos je suis dispo


Debian 8.11
PHP 5.6 MySql 5.6
Glpi 9.4.6
FI 9.4+2.4

Offline

#11 2019-02-13 11:12:43

squale323
Member
Registered: 2017-06-21
Posts: 25

Re: probleme déconnexion/verrou d'un élement

bonjour,

suite à la mise a jour 9.4.0, idem pour fusioninventory, le problème est toujours présent en ce qui me concerne. j'avais gardé une liste des PC/moniteur qui avait ces problèmes de déconnexion, et en voulant testé, impossible de déconnecté un écran d'un PC, le moniteur se retrouve en verrouillé.

Pour résumer :
- sur le PC, je vais sur l'onglet connexions, je coche l'écran, action déconnecté,
- message que l’opération est un succès, mais l'écran est toujours la,
- sur le PC, onglet Verrous, l'écran y apparaît comme verrouillé, je le déverrouille
mais l'écran est toujours connecté au PC.


Debian 8.11
PHP 5.6 MySql 5.6
Glpi 9.4.6
FI 9.4+2.4

Offline

#12 2019-02-19 10:06:35

mrspam
Member
From: Ile de La Réunion
Registered: 2017-09-28
Posts: 75

Re: probleme déconnexion/verrou d'un élement

Bonjour,

Je confirme que le problème est toujours présent sur la version 9.4.0.

Cordialement,


GLPI Prod 9.3.2 / FI 9.3+1.3 / Ubuntu 16.04.5 LTS / PHP 7.0.33
GLPI Test 9.4.0 / FI 9.4.0+1.0 / Ubuntu 16.04.5 LTS / PHP 7.0.33

Offline

#13 2019-02-19 11:10:44

mrspam
Member
From: Ile de La Réunion
Registered: 2017-09-28
Posts: 75

Re: probleme déconnexion/verrou d'un élement

Quand on déconnecte un écran sur un poste, l'écran passe en verrou sur la fiche du poste et reste affiché dans l'écrna connexion.
Pour supprimer de l'écran connexion, on est obligé de supprimer l'écran dans l'onglet verrou...


GLPI Prod 9.3.2 / FI 9.3+1.3 / Ubuntu 16.04.5 LTS / PHP 7.0.33
GLPI Test 9.4.0 / FI 9.4.0+1.0 / Ubuntu 16.04.5 LTS / PHP 7.0.33

Offline

#14 2019-04-25 13:25:59

olivier.vanoni
Member
Registered: 2017-02-27
Posts: 36

Re: probleme déconnexion/verrou d'un élement

Bonjour.
Je viens d'essayer avec la version 9.4.2, c'est pareil.

Offline

#15 2019-06-17 15:27:08

Sico31
Member
Registered: 2018-09-24
Posts: 324

Re: probleme déconnexion/verrou d'un élement

Je confirme, c'est pareil avec la V9.4.2


Manger un castor, c'est sauver un arbre

Offline

#16 2019-11-12 16:31:07

lioneldistree
Member
Registered: 2019-11-12
Posts: 1

Re: probleme déconnexion/verrou d'un élement

Bonjour

Je possède le même problème en 9.4.4.
Y-a-t-il une solution de contournement ou une solution à venir par l'équipe de développement de GLPI?

Merci d'avance pour vos réponses.

Offline

#17 2020-05-14 18:31:32

jreynaud40
Member
Registered: 2009-05-27
Posts: 25

Re: probleme déconnexion/verrou d'un élement

Bonjour,

Je suis en version 9.4.0 et j'ai ces soucis de connexion déconnexion moniteur. 1 coup ça fait le lien puis paf! perte du lien entre PC et moniteur.

Parfois j'ai 1 verrouillage sur écran (je sais pas si c'est lié avec ce bug) et comme ça veut pas se déconnecter de l'ancien poste, je fais tout supprimer, et là c'est bon, et je peux réattribuer en manuel mon écran avec le PC.

Sauf que c'est en manuel.

Est-ce que la dernière version de GLPI corrige ce bug de perte de lien aléatoire entre PC et moniteur ? Car c'est c... au possible de remettre manuellement les liaisons fréquemment, et pas sur tous les postes.


Merci pour votre aide.


Jérôme

Offline

Board footer

Powered by FluxBB